build: make building more strict, abort on errors in gccbuild phase
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 11 Jun 2009 11:10:01 +0000 (11:10 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 11 Jun 2009 11:10:01 +0000 (11:10 +0000)
Makefile

index 0f0bf42..d082a98 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -12,7 +12,12 @@ all: build
 build: gccbuild luabuild
 
 gccbuild:
 build: gccbuild luabuild
 
 gccbuild:
-       for i in $(MODULES); do make -C$$i compile; done
+       for i in $(MODULES); do \
+               make -C$$i compile || { \
+                       echo "*** Compilation of $$i failed!"; \
+                       exit 1; \
+               }; \
+       done
 
 luabuild: i18nbuild
        for i in $(MODULES); do HOST=$(realpath host) make -C$$i luabuild; done
 
 luabuild: i18nbuild
        for i in $(MODULES); do HOST=$(realpath host) make -C$$i luabuild; done