* Fixed Makefile and postinst-script to work correctly
authorSteven Barth <steven@midlink.org>
Tue, 18 Mar 2008 15:46:56 +0000 (15:46 +0000)
committerSteven Barth <steven@midlink.org>
Tue, 18 Mar 2008 15:46:56 +0000 (15:46 +0000)
(Thanks to Mickey from FF Hannover)

Makefile
contrib/package/ffluci/ipkg/ffluci.postinst

index 317f3a6..e2a74c0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -8,7 +8,7 @@ ffluci/fs.lua ffluci/i18n.lua ffluci/model/uci.lua \
 ffluci/template.lua ffluci/cbi.lua ffluci/dispatcher.lua \
 ffluci/menu.lua ffluci/init.lua ffluci/sys.lua 
 
-DIRECTORIES = dist/ffluci/model dist/ffluci/controller/public dist/ffluci/controller/admin dist/ffluci/i18n dist/ffluci/view
+DIRECTORIES = dist/ffluci/model dist/ffluci/controller dist/ffluci/i18n dist/ffluci/view
 
 INFILES = $(CFILES:%=src/%)
 OUTFILE = ffluci/init.lua
@@ -25,8 +25,7 @@ examples-source: source examples
 
 
 dist:
-       cp src/ffluci/controller/public/* dist/ffluci/controller/public/
-       cp src/ffluci/controller/admin/* dist/ffluci/controller/admin/
+       cp src/ffluci/controller/* dist/ffluci/controller/ -R
        cp src/ffluci/i18n/* dist/ffluci/i18n/
        cp src/ffluci/view/* dist/ffluci/view/ -R
        
index 0dbac00..7265cb9 100755 (executable)
@@ -1,4 +1,4 @@
 #!/bin/sh
 PATTERN='/cgi-bin/ffluci/admin:root:$p$root'
 grep $PATTERN ${IPKG_INSTROOT}/etc/httpd.conf >/dev/null 2>/dev/null || echo $PATTERN >> ${IPKG_INSTROOT}/etc/httpd.conf 
-[ -z ${IPKG_INSTROOT} ] && /etc/init.d/httpd restart
+[ -n ${IPKG_INSTROOT} ] || /etc/init.d/httpd restart