build: add mkversion.sh helper script
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 17 Jan 2009 16:35:02 +0000 (16:35 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 17 Jan 2009 16:35:02 +0000 (16:35 +0000)
contrib: (re-)generate version.lua at build time
libs/core: use version.lua
themes: adept header to version.lua, fix css for openwrt.org

build/mkversion.sh [new file with mode: 0755]
contrib/package/luci/Makefile
libs/core/luasrc/init.lua
libs/core/luasrc/version.lua [new file with mode: 0644]
themes/openwrt-light/luasrc/view/themes/openwrt-light/header.htm
themes/openwrt.org-oxygen/luasrc/view/themes/openwrt.org-oxygen/header.htm
themes/openwrt.org/htdocs/luci-static/openwrt.org/cascade.css
themes/openwrt.org/luasrc/view/themes/openwrt.org/header.htm

diff --git a/build/mkversion.sh b/build/mkversion.sh
new file mode 100755 (executable)
index 0000000..2361e5f
--- /dev/null
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+local variant
+
+if [ "${4%%/*}" = "branches" ]; then
+       variant="LuCI ${4##*[-/]} Branch"
+elif [ "${4%%/*}" = "tags" ]; then
+       variant="LuCI ${4##*[-/]} Release"
+else
+       variant="LuCI Trunk"
+fi
+
+cat <<EOF > $1
+module "luci.version"
+
+distname    = "${2:-OpenWrt}"
+distversion = "${3:-Development Snapshot}"
+
+luciname    = "$variant"
+luciversion = "${5:-svn}"
+EOF
index 3016adf..06ec7c8 100644 (file)
@@ -106,6 +106,11 @@ endef
 
 define Package/luci-core/install
        $(call Package/luci/install/template,$(1),libs/core)
+       $(PKG_BUILD_DIR)/build/mkversion.sh $(1)/usr/lib/lua/luci/version.lua \
+               "OpenWrt Firmware" \
+               "$(OPENWRTVERSION)" \
+               "$(PKG_BRANCH)" \
+               "$(PKG_VERSION)"
 endef
 
 define Package/luci-core/config
index 2eacc6c..81a65b1 100644 (file)
@@ -12,9 +12,9 @@ Copyright 2008 Steven Barth <steven@midlink.org>
 
 Licensed under the Apache License, Version 2.0 (the "License");
 you may not use this file except in compliance with the License.
-You may obtain a copy of the License at 
+You may obtain a copy of the License at
 
-       http://www.apache.org/licenses/LICENSE-2.0 
+       http://www.apache.org/licenses/LICENSE-2.0
 
 Unless required by applicable law or agreed to in writing, software
 distributed under the License is distributed on an "AS IS" BASIS,
@@ -23,7 +23,12 @@ See the License for the specific language governing permissions and
 limitations under the License.
 
 ]]--
+
+local require = require
+
 module "luci"
 
-__version__ = "0.9"
-__appname__ = "LuCI"
+local v = require "luci.version"
+
+__version__ = v.luciversion or "0.9"
+__appname__ = v.luciname    or "LuCI"
diff --git a/libs/core/luasrc/version.lua b/libs/core/luasrc/version.lua
new file mode 100644 (file)
index 0000000..9e5cb71
--- /dev/null
@@ -0,0 +1,12 @@
+--[[
+LuCI - Lua Configuration Interface
+Version definition - do not edit this file
+]]--
+
+module "luci.version"
+
+distname    = "Host System"
+distversion = "SDK"
+
+luciname    = "LuCI"
+luciversion = "SVN"
index 7972c93..689353c 100644 (file)
@@ -59,9 +59,9 @@ require("luci.http").prepare_content("application/xhtml+xml")
 </p>
 
 <div id="header">
-<h1><%=luci.config.brand.firmware%></h1>
+<h1><%=luci.version.distname%></h1>
 <p>
-(<%=luci.config.brand.distro%>) |
+: <%=luci.version.distversion%> |
 <%:load%>: <%=load1%> <%=load5%> <%=load15%> |
 <%:hostname%>: <%=hostname%>
 </p>
index a2c48b9..fe18214 100644 (file)
@@ -61,9 +61,9 @@ require("luci.http").prepare_content("application/xhtml+xml")
 </p>
 
 <div id="header">
-<h1><%=luci.config.brand.firmware%></h1>
+<h1><%=luci.version.distname%></h1>
 <p>
-<%=luci.config.brand.distro%><br />
+<%=luci.version.distversion%><br />
 <%:load%>: <%=load1%> <%=load5%> <%=load15%><br />
 <%:hostname%>: <%=hostname%>
 </p>
index 7fb7fc8..cf4265d 100644 (file)
@@ -9,6 +9,7 @@ body {
        background-position: bottom center;
        background-repeat: repeat-x;
        color: #ffffff;
+       height: 100%;
 }
 
 body {
index e658bfc..131e767 100644 (file)
@@ -59,9 +59,9 @@ require("luci.http").prepare_content("application/xhtml+xml")
 </p>
 
 <div id="header">
-<h1><%=luci.config.brand.firmware%></h1>
+<h1><%=luci.version.distname%></h1>
 <p>
-<%=luci.config.brand.distro%><br />
+<%=luci.version.distversion%><br />
 <%:load%>: <%=load1%> <%=load5%> <%=load15%><br />
 <%:hostname%>: <%=hostname%>
 </p>