applications: Add luci-wshaper (#53)
authorManuel Munz <freifunk@somakoma.de>
Sat, 15 Oct 2011 18:47:42 +0000 (18:47 +0000)
committerManuel Munz <freifunk@somakoma.de>
Sat, 15 Oct 2011 18:47:42 +0000 (18:47 +0000)
23 files changed:
applications/luci-wshaper/Makefile [new file with mode: 0644]
applications/luci-wshaper/ipkg/postinst [new file with mode: 0644]
applications/luci-wshaper/luasrc/controller/wshaper.lua [new file with mode: 0644]
applications/luci-wshaper/luasrc/model/cbi/wshaper.lua [new file with mode: 0644]
applications/luci-wshaper/root/etc/uci-defaults/luci-wshaper [new file with mode: 0644]
po/ca/wshaper.po [new file with mode: 0644]
po/de/wshaper.po [new file with mode: 0644]
po/el/wshaper.po [new file with mode: 0644]
po/en/wshaper.po [new file with mode: 0644]
po/es/wshaper.po [new file with mode: 0644]
po/fr/wshaper.po [new file with mode: 0644]
po/he/wshaper.po [new file with mode: 0644]
po/it/wshaper.po [new file with mode: 0644]
po/ja/wshaper.po [new file with mode: 0644]
po/ms/wshaper.po [new file with mode: 0644]
po/no/wshaper.po [new file with mode: 0644]
po/pl/wshaper.po [new file with mode: 0644]
po/pt/wshaper.po [new file with mode: 0644]
po/pt_BR/wshaper.po [new file with mode: 0644]
po/ro/wshaper.po [new file with mode: 0644]
po/ru/wshaper.po [new file with mode: 0644]
po/vi/wshaper.po [new file with mode: 0644]
po/zh_CN/wshaper.po [new file with mode: 0644]

diff --git a/applications/luci-wshaper/Makefile b/applications/luci-wshaper/Makefile
new file mode 100644 (file)
index 0000000..fcdd099
--- /dev/null
@@ -0,0 +1,4 @@
+PO = wshaper
+
+include ../../build/config.mk
+include ../../build/module.mk
diff --git a/applications/luci-wshaper/ipkg/postinst b/applications/luci-wshaper/ipkg/postinst
new file mode 100644 (file)
index 0000000..dad8842
--- /dev/null
@@ -0,0 +1,6 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+       ( . /etc/uci-defaults/wshaper ) && rm -f /etc/uci-defaults/wshaper
+       exit 0
+}
+
diff --git a/applications/luci-wshaper/luasrc/controller/wshaper.lua b/applications/luci-wshaper/luasrc/controller/wshaper.lua
new file mode 100644 (file)
index 0000000..9d7f01e
--- /dev/null
@@ -0,0 +1,19 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2011 Manuel Munz <freifunk somakoma de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+http://www.apache.org/licenses/LICENSE-2.0
+
+]]--
+
+module "luci.controller.wshaper"
+
+function index()
+       entry({"admin", "network", "wshaper"}, cbi("wshaper"), _("Wondershaper"), 80)
+end
+
diff --git a/applications/luci-wshaper/luasrc/model/cbi/wshaper.lua b/applications/luci-wshaper/luasrc/model/cbi/wshaper.lua
new file mode 100644 (file)
index 0000000..81225ce
--- /dev/null
@@ -0,0 +1,55 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2011 Manuel Munz <freifunk at somakoma dot de>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+]]--
+
+require("luci.tools.webadmin")
+
+m = Map("wshaper", translate("Wondershaper"),
+       translate("Wondershaper uses traffic shaping to ensure low latencies for interactive traffic even when your " ..
+       "internet connection is highly saturated."))
+
+s = m:section(NamedSection, "settings", "wshaper", translate("Wondershaper settings"))
+s.anonymous = true
+
+network = s:option(ListValue, "network", translate("Interface"))
+luci.tools.webadmin.cbi_add_networks(network)
+
+uplink = s:option(Value, "uplink", translate("Uplink"), translate("Upstream bandwidth in kbit/s"))
+uplink.optional = false
+uplink.datatype = "uinteger"
+uplink.default = "240"
+
+uplink = s:option(Value, "downlink", translate("Downlink"), translate("Downstream bandwidth in kbit/s"))
+uplink.optional = false
+uplink.datatype = "uinteger"
+uplink.default = "200"
+
+nopriohostsrc = s:option(DynamicList, "nopriohostsrc", translate("Low priority hosts (Source)"), translate("Host or Network in CIDR notation."))
+nopriohostsrc.optional = true
+nopriohostsrc.datatype = ipaddr
+nopriohostsrc.placeholder = "10.0.0.1/32"
+
+nopriohostdst = s:option(DynamicList, "nopriohostdst", translate("Low priority hosts (Destination)"), translate("Host or Network in CIDR notation."))
+nopriohostdst.optional = true
+nopriohostdst.datatype = ipaddr
+nopriohostdst.placeholder = "10.0.0.1/32"
+
+noprioportsrc = s:option(DynamicList, "noprioportsrc", translate("Low priority source ports"))
+noprioportsrc.optional = true
+noprioportsrc.datatype = "range(0,65535)"
+noprioportsrc.placeholder = "21"
+
+noprioportdst = s:option(DynamicList, "noprioportdst", translate("Low priority destination ports"))
+noprioportdst.optional = true
+noprioportdst.datatype = "range(0,65535)"
+noprioportdst.placeholder = "21"
+
+return m
diff --git a/applications/luci-wshaper/root/etc/uci-defaults/luci-wshaper b/applications/luci-wshaper/root/etc/uci-defaults/luci-wshaper
new file mode 100644 (file)
index 0000000..9e4eb15
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+uci -q batch <<-EOF >/dev/null
+       delete ucitrack.@wshaper[-1]
+       add ucitrack wshaper=wshaper
+       set ucitrack.wshaper.exec='/etc/init.d/wshaper start'
+       commit ucitrack
+EOF
+
+rm -f /tmp/luci-indexcache
+exit 0
diff --git a/po/ca/wshaper.po b/po/ca/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/de/wshaper.po b/po/de/wshaper.po
new file mode 100644 (file)
index 0000000..72195bd
--- /dev/null
@@ -0,0 +1,54 @@
+msgid ""
+msgstr ""
+"Project-Id-Version: \n"
+"POT-Creation-Date: \n"
+"PO-Revision-Date: \n"
+"Last-Translator: Manuel Munz <freifunk@somakoma.de>\n"
+"Language-Team: \n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=UTF-8\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+msgid "Downlink"
+msgstr "Download"
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr "Download Bandbreite in kbit/s"
+
+msgid "Host or Network in CIDR notation."
+msgstr "Rechner oder Netzwerk in CIDR Schreibweise"
+
+msgid "Interface"
+msgstr "Schnittstelle"
+
+msgid "Low priority destination ports"
+msgstr "Zielports mit niedriger Priorität"
+
+msgid "Low priority hosts (Destination)"
+msgstr "Zielrechner mit nideriger Priorität"
+
+msgid "Low priority hosts (Source)"
+msgstr "Quellrechner mit neidriger Priorität"
+
+msgid "Low priority source ports"
+msgstr "Quellports mit niedriger Priorität"
+
+msgid "Uplink"
+msgstr "Upload"
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr "Upload Bandbreite in kbit/s"
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr "Wondershaper Einstellungen"
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
+"Wondershaper ermöglicht mit Hilfe von Traffic Shaping niedrige Latenzzeiten "
+"für interaktiven Internetverkehr selbst wenn die Internetverbindung extrem "
+"ausgelastet ist."
diff --git a/po/el/wshaper.po b/po/el/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/en/wshaper.po b/po/en/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/es/wshaper.po b/po/es/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/fr/wshaper.po b/po/fr/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/he/wshaper.po b/po/he/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/it/wshaper.po b/po/it/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/ja/wshaper.po b/po/ja/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/ms/wshaper.po b/po/ms/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/no/wshaper.po b/po/no/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/pl/wshaper.po b/po/pl/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/pt/wshaper.po b/po/pt/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/pt_BR/wshaper.po b/po/pt_BR/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/ro/wshaper.po b/po/ro/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/ru/wshaper.po b/po/ru/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/vi/wshaper.po b/po/vi/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""
diff --git a/po/zh_CN/wshaper.po b/po/zh_CN/wshaper.po
new file mode 100644 (file)
index 0000000..4eee2b6
--- /dev/null
@@ -0,0 +1,40 @@
+msgid "Downlink"
+msgstr ""
+
+msgid "Downstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Host or Network in CIDR notation."
+msgstr ""
+
+msgid "Interface"
+msgstr ""
+
+msgid "Low priority destination ports"
+msgstr ""
+
+msgid "Low priority hosts (Destination)"
+msgstr ""
+
+msgid "Low priority hosts (Source)"
+msgstr ""
+
+msgid "Low priority source ports"
+msgstr ""
+
+msgid "Uplink"
+msgstr ""
+
+msgid "Upstream bandwidth in kbit/s"
+msgstr ""
+
+msgid "Wondershaper"
+msgstr ""
+
+msgid "Wondershaper settings"
+msgstr ""
+
+msgid ""
+"Wondershaper uses traffic shaping to ensure low latencies for interactive "
+"traffic even when your internet connection is highly saturated."
+msgstr ""