modules/admin-mini: some work on lan and wan configuration
authorSteven Barth <steven@midlink.org>
Tue, 15 Jul 2008 14:33:29 +0000 (14:33 +0000)
committerSteven Barth <steven@midlink.org>
Tue, 15 Jul 2008 14:33:29 +0000 (14:33 +0000)
contrib/package/luci/Makefile
modules/admin-mini/luasrc/controller/mini/index.lua
modules/admin-mini/luasrc/controller/mini/network.lua [new file with mode: 0644]
modules/admin-mini/luasrc/model/cbi/mini-network/basic.lua [new file with mode: 0644]
modules/admin-mini/luasrc/model/cbi/mini/luci.lua [new file with mode: 0644]
modules/admin-mini/luasrc/view/mini/index.htm [new file with mode: 0644]
modules/freifunk/luasrc/controller/freifunk/freifunk.lua

index e369acf..47a0275 100644 (file)
@@ -297,7 +297,7 @@ endef
 define Package/luci-mod-admin-mini
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-mod-admin-core
-  TITLE:=Simplified Administration module
+  TITLE:=Simplified Administration module (INCOMPLETE)
 endef
 
 define Package/luci-mod-admin-mini/install
@@ -620,7 +620,7 @@ $(eval $(call BuildPackage,luci-ff-berlin))
 $(eval $(call BuildPackage,luci-ff-augsburg))
 
 $(eval $(call BuildPackage,luci-mod-admin-core))
-#$(eval $(call BuildPackage,luci-mod-admin-mini))
+$(eval $(call BuildPackage,luci-mod-admin-mini))
 $(eval $(call BuildPackage,luci-mod-admin-full))
 $(eval $(call BuildPackage,luci-mod-freifunk))
 
index eb58e00..bde9649 100644 (file)
@@ -2,6 +2,7 @@
 LuCI - Lua Configuration Interface
 
 Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
 
 Licensed under the Apache License, Version 2.0 (the "License");
 you may not use this file except in compliance with the License.
@@ -11,36 +12,28 @@ You may obtain a copy of the License at
 
 $Id$
 ]]--
-module("luci.controller.admin.index", package.seeall)
+
+module("luci.controller.mini.index", package.seeall)
 
 function index()
        luci.i18n.loadc("admin-core")
        local i18n = luci.i18n.translate
 
        local root = node()
-       if not root.target then
-               root.target = alias("admin")
+       if not root.lock then
+               root.target = alias("mini")
        end
        
        entry({"about"}, template("about")).i18n = "admin-core"
        
-       local page   = node("admin")
-       page.target  = alias("admin", "index")
-       page.title   = i18n("administration", "Administration")
-       page.order   = 10
+       local page   = entry({"mini"}, alias("mini", "index"), i18n("mini", "Mini"), 10)
        page.i18n    = "admin-core"
        page.sysauth = "root"
+       page.ucidata = true
        
-       local page  = node("admin", "index")
-       page.target = template("admin_index/index")
-       page.title  = i18n("overview", "Übersicht")
-       page.order  = 10
-       
-       local page  = node("admin", "index", "luci")
-       page.target = cbi("admin_index/luci")
-       page.title  = i18n("a_i_ui", "Oberfläche")
-       
-       entry({"admin", "logout"}, call("action_logout"), i18n("logout"))
+       entry({"mini", "index"}, template("mini/index"), i18n("overview"), 10)
+       entry({"mini", "index", "luci"}, cbi("mini/luci"), i18n("settings"), 10)
+       entry({"mini", "index", "logout"}, call("action_logout"), i18n("logout"))
 end
 
 function action_logout()
diff --git a/modules/admin-mini/luasrc/controller/mini/network.lua b/modules/admin-mini/luasrc/controller/mini/network.lua
new file mode 100644 (file)
index 0000000..d42d31d
--- /dev/null
@@ -0,0 +1,23 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+
+module("luci.controller.mini.network", package.seeall)
+
+function index()
+       luci.i18n.loadc("admin-core")
+       local i18n = luci.i18n.translate
+
+       entry({"mini", "network"}, cbi("mini-network/basic"), i18n("network"))
+end
\ No newline at end of file
diff --git a/modules/admin-mini/luasrc/model/cbi/mini-network/basic.lua b/modules/admin-mini/luasrc/model/cbi/mini-network/basic.lua
new file mode 100644 (file)
index 0000000..c972eef
--- /dev/null
@@ -0,0 +1,80 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+m = Map("network", "Network")
+
+s = m:section(NamedSection, "lan", "interface", "Local Network")
+s:option(Value, "ipaddr", translate("ipaddress"))
+s:option(Value, "netmask", translate("netmask"))
+gw = s:option(Value, "gateway", translate("gateway"))
+gw.rmempty = true
+dns = s:option(Value, "dns", translate("dnsserver"))
+dns.rmempty = true
+
+
+s = m:section(NamedSection, "wan", "interface", "Internet Connection")
+p = s:option(ListValue, "proto", translate("protocol"))
+p:value("none", "disabled")
+p:value("static", translate("manual", "manual"))
+p:value("dhcp", translate("automatic", "automatic"))
+p:value("pppoe", "PPPoE")
+p:value("pptp", "PPTP")
+
+ip = s:option(Value, "ipaddr", translate("ipaddress"))
+ip:depends("proto", "static")
+
+nm = s:option(Value, "netmask", translate("netmask"))
+nm:depends("proto", "static")
+
+gw = s:option(Value, "gateway", translate("gateway"))
+gw:depends("proto", "static")
+gw.rmempty = true
+
+dns = s:option(Value, "dns", translate("dnsserver"))
+dns:depends("proto", "static")
+dns.rmempty = true
+
+usr = s:option(Value, "username", translate("username"))
+usr:depends("proto", "pppoe")
+usr:depends("proto", "pptp")
+
+pwd = s:option(Value, "password", translate("password"))
+pwd:depends("proto", "pppoe")
+pwd:depends("proto", "pptp")
+
+kea = s:option(Value, "keepalive", "Keep-Alive")
+kea:depends("proto", "pppoe")
+kea:depends("proto", "pptp")
+kea.rmempty = true
+
+
+cod = s:option(Value, "demand", "Dial on Demand")
+cod:depends("proto", "pppoe")
+cod:depends("proto", "pptp")
+cod.rmempty = true
+
+srv = s:option(Value, "server", "PPTP-Server")
+srv:depends("proto", "pptp")
+srv.rmempty = true
+
+mtu = s:option(Value, "mtu", "MTU")
+mtu:depends("proto", "static")
+mtu:depends("proto", "dhcp")
+mtu:depends("proto", "pppoe")
+mtu:depends("proto", "pptp")
+mtu.rmempty = true
+
+
+
+return m
\ No newline at end of file
diff --git a/modules/admin-mini/luasrc/model/cbi/mini/luci.lua b/modules/admin-mini/luasrc/model/cbi/mini/luci.lua
new file mode 100644 (file)
index 0000000..1b0f3b1
--- /dev/null
@@ -0,0 +1,36 @@
+--[[
+LuCI - Lua Configuration Interface
+
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+]]--
+require("luci.config")
+m = Map("luci", translate("webui"), translate("a_i_luci1"))
+
+c = m:section(NamedSection, "main", "core", translate("general"))
+
+l = c:option(ListValue, "lang", translate("language"))
+
+local i18ndir = luci.i18n.i18ndir .. "default."
+for k, v in pairs(luci.config.languages) do
+       if k:sub(1, 1) ~= "." and luci.fs.isfile(i18ndir .. k .. ".lua") then
+               l:value(k, v)
+       end
+end
+
+t = c:option(ListValue, "mediaurlbase", translate("design"))
+for k, v in pairs(luci.config.themes) do
+       if k:sub(1, 1) ~= "." then
+               t:value(v, k)
+       end
+end
+
+return m
\ No newline at end of file
diff --git a/modules/admin-mini/luasrc/view/mini/index.htm b/modules/admin-mini/luasrc/view/mini/index.htm
new file mode 100644 (file)
index 0000000..4ea58c2
--- /dev/null
@@ -0,0 +1,24 @@
+<%#
+LuCI - Lua Configuration Interface
+Copyright 2008 Steven Barth <steven@midlink.org>
+Copyright 2008 Jo-Philipp Wich <xm@leipzig.freifunk.net>
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+       http://www.apache.org/licenses/LICENSE-2.0
+
+$Id$
+
+-%>
+<%+header%>
+<h1><%:a_i_i_hello%></h1>
+<p><%:a_i_i_admin1%></p>
+<p><%:a_i_i_admin2%><br />
+<%:a_i_i_admin3%></p>
+<p><%:a_i_i_admin4%></p>
+<p><%:a_i_i_admin5%></p>
+<p><%:a_i_i_admin6%></p>
+<p><em><strong><a href="<%=controller%>/about"><%:a_i_i_team%></a></strong></em></p> 
+<%+footer%>
\ No newline at end of file
index 351a094..e4ab2bb 100644 (file)
@@ -17,6 +17,7 @@ function index()
        local i18n = luci.i18n.translate
 
        local page  = node()
+       page.lock   = true
        page.target = alias("freifunk")
 
        local page    = node("freifunk")