luci.mk: sort languages in lexical order 1296/head
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 2 Aug 2017 14:45:26 +0000 (16:45 +0200)
committerFlorian Eckert <fe@dev.tdt.de>
Fri, 11 Aug 2017 11:08:41 +0000 (13:08 +0200)
sorting language in .config by lexical order

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
luci.mk

diff --git a/luci.mk b/luci.mk
index 1ddb73d..0b2ec4e 100644 (file)
--- a/luci.mk
+++ b/luci.mk
@@ -7,7 +7,7 @@
 LUCI_NAME?=$(notdir ${CURDIR})
 LUCI_TYPE?=$(word 2,$(subst -, ,$(LUCI_NAME)))
 LUCI_BASENAME?=$(patsubst luci-$(LUCI_TYPE)-%,%,$(LUCI_NAME))
-LUCI_LANGUAGES:=$(filter-out templates,$(notdir $(wildcard ${CURDIR}/po/*)))
+LUCI_LANGUAGES:=$(sort $(filter-out templates,$(notdir $(wildcard ${CURDIR}/po/*))))
 LUCI_DEFAULTS:=$(notdir $(wildcard ${CURDIR}/root/etc/uci-defaults/*))
 LUCI_PKGARCH?=$(if $(realpath src/Makefile),,all)