luci-ssl-openssl: Provide OpenSSL-based LuCI collection 807/head
authorHannu Nyman <hannu.nyman@iki.fi>
Mon, 3 Oct 2016 18:09:08 +0000 (21:09 +0300)
committerHannu Nyman <hannu.nyman@iki.fi>
Mon, 3 Oct 2016 18:09:08 +0000 (21:09 +0300)
Add a new OpenSSL-based collection that uses libustream-openssl
instead of the default libustream-polarssl.
(Note: px5g still needs libpolarssl, so both libs will be included)

Mention PolarSSL in the title of luci-ssl.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
collections/luci-ssl-openssl/Makefile [new file with mode: 0644]
collections/luci-ssl/Makefile

diff --git a/collections/luci-ssl-openssl/Makefile b/collections/luci-ssl-openssl/Makefile
new file mode 100644 (file)
index 0000000..37442a3
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2016 The LuCI Team
+#
+# This is free software, licensed under the Apache License, Version 2.0 .
+#
+
+include $(TOPDIR)/rules.mk
+
+LUCI_TYPE:=col
+LUCI_BASENAME:=ssl-openssl
+
+LUCI_TITLE:=LuCI with HTTPS support (OpenSSL as SSL backend)
+LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
+ Note: px5g still requires libpolarssl
+LUCI_DEPENDS:=+luci +libustream-openssl +px5g
+
+include ../../luci.mk
+
+# call BuildPackage - OpenWrt buildroot signature
index 07c9c50..f25e311 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2008-2014 The LuCI Team <luci@lists.subsignal.org>
+# Copyright (C) 2008-2016 The LuCI Team
 #
 # This is free software, licensed under the Apache License, Version 2.0 .
 #
 #
 # This is free software, licensed under the Apache License, Version 2.0 .
 #
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 LUCI_TYPE:=col
 LUCI_BASENAME:=ssl
 
 LUCI_TYPE:=col
 LUCI_BASENAME:=ssl
 
-LUCI_TITLE:=Standard OpenWrt set with HTTPS support
+LUCI_TITLE:=LuCI with HTTPS support (PolarSSL as SSL backend)
 LUCI_DEPENDS:=+luci +libustream-polarssl +px5g
 
 include ../../luci.mk
 LUCI_DEPENDS:=+luci +libustream-polarssl +px5g
 
 include ../../luci.mk