* Added support for htdocs module directory
authorSteven Barth <steven@midlink.org>
Sun, 15 Jun 2008 16:02:47 +0000 (16:02 +0000)
committerSteven Barth <steven@midlink.org>
Sun, 15 Jun 2008 16:02:47 +0000 (16:02 +0000)
20 files changed:
applications/luci-splash/htdocs/cgi-bin/luci-splash [new file with mode: 0755]
applications/luci-splash/root/www/cgi-bin/luci-splash [deleted file]
build/config.mk
build/module.mk
libs/cbi/htdocs/luci-static/resources/cbi.js [new file with mode: 0644]
libs/cbi/root/www/luci-static/resources/cbi.js [deleted file]
libs/sgi-haserl/htdocs/cgi-bin/index.cgi [new file with mode: 0755]
libs/sgi-haserl/htdocs/cgi-bin/luci [new file with mode: 0755]
libs/sgi-haserl/htdocs/cgi-bin/luci-upload [new file with mode: 0755]
libs/sgi-haserl/htdocs/index.html [new file with mode: 0644]
libs/sgi-haserl/root/www/cgi-bin/index.cgi [deleted file]
libs/sgi-haserl/root/www/cgi-bin/luci [deleted file]
libs/sgi-haserl/root/www/cgi-bin/luci-upload [deleted file]
libs/sgi-haserl/root/www/index.html [deleted file]
themes/fledermaus/htdocs/luci-static/fledermaus/cascade.css [new file with mode: 0644]
themes/fledermaus/htdocs/luci-static/fledermaus/logo.png [new file with mode: 0644]
themes/fledermaus/root/www/luci-static/fledermaus/cascade.css [deleted file]
themes/fledermaus/root/www/luci-static/fledermaus/logo.png [deleted file]
themes/openwrt.org/htdocs/luci-static/openwrt.org/cascade.css [new file with mode: 0644]
themes/openwrt.org/root/www/luci-static/openwrt.org/cascade.css [deleted file]

diff --git a/applications/luci-splash/htdocs/cgi-bin/luci-splash b/applications/luci-splash/htdocs/cgi-bin/luci-splash
new file mode 100755 (executable)
index 0000000..c75593f
--- /dev/null
@@ -0,0 +1,4 @@
+#!/bin/sh
+echo "Status: 302 Found"
+echo "Location: /cgi-bin/luci/splash/splash$PATH_INFO"
+echo
\ No newline at end of file
diff --git a/applications/luci-splash/root/www/cgi-bin/luci-splash b/applications/luci-splash/root/www/cgi-bin/luci-splash
deleted file mode 100755 (executable)
index c75593f..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-echo "Status: 302 Found"
-echo "Location: /cgi-bin/luci/splash/splash$PATH_INFO"
-echo
\ No newline at end of file
index 81d3e08..3cf1320 100644 (file)
@@ -7,3 +7,5 @@ LUA_LIBRARYDIR = /usr/lib/lua
 LUCI_MODULEDIR = $(LUA_MODULEDIR)/luci
 LUCI_LIBRARYDIR = $(LUA_LIBRARYDIR)/luci
 
+HTDOCS = /www
+
index 4ef3668..b85dcda 100644 (file)
@@ -14,9 +14,11 @@ clean: luaclean
 luasource:
        mkdir -p dist$(LUA_MODULEDIR)
        mkdir -p dist$(LUCI_MODULEDIR)
+       mkdir -p dist$(HTDOCS)
        cp -a root/* dist -R 2>/dev/null || true
        cp -a luasrc/* dist$(LUCI_MODULEDIR) -R 2>/dev/null || true
        cp -a lua/* dist$(LUA_MODULEDIR) -R 2>/dev/null || true
+       cp -a htdocs/* dist$(HTDOCS) -R 2>/dev/null || true
        for i in $$(find dist -name .svn); do rm $$i -rf; done  
        
 luacompile: luasource
diff --git a/libs/cbi/htdocs/luci-static/resources/cbi.js b/libs/cbi/htdocs/luci-static/resources/cbi.js
new file mode 100644 (file)
index 0000000..a3a47aa
--- /dev/null
@@ -0,0 +1,42 @@
+var cbi_d = {};
+
+function cbi_d_add(field, target, value) {
+       if (!cbi_d[target]) {
+               cbi_d[target] = {};
+       }
+       if (!cbi_d[target][value]) {
+               cbi_d[target][value] = [];
+       }
+       cbi_d[target][value].push(field);
+}
+
+function cbi_d_update(target) {
+       if (!cbi_d[target]) {
+               return;
+       }
+       
+       for (var x in cbi_d[target]) {
+               for (var i=0; i<cbi_d[target][x].length; i++) { 
+                       var y = document.getElementById(cbi_d[target][x][i])    
+                       y.style.display = "none";
+               }
+       }
+       
+       var t = document.getElementById(target);
+       if (t && t.value && cbi_d[target][t.value]) {
+               for (var i=0; i<cbi_d[target][t.value].length; i++) {                   
+                       var y = document.getElementById(cbi_d[target][t.value][i])
+                       if (!y.value) { 
+                               y.style.display = "table-row";
+                       } else {
+                               y.style.display = "block";
+                       }
+               }
+       }
+}
+
+function cbi_d_init() {
+       for (var x in cbi_d) {
+               cbi_d_update(x);
+       }
+}
\ No newline at end of file
diff --git a/libs/cbi/root/www/luci-static/resources/cbi.js b/libs/cbi/root/www/luci-static/resources/cbi.js
deleted file mode 100644 (file)
index a3a47aa..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-var cbi_d = {};
-
-function cbi_d_add(field, target, value) {
-       if (!cbi_d[target]) {
-               cbi_d[target] = {};
-       }
-       if (!cbi_d[target][value]) {
-               cbi_d[target][value] = [];
-       }
-       cbi_d[target][value].push(field);
-}
-
-function cbi_d_update(target) {
-       if (!cbi_d[target]) {
-               return;
-       }
-       
-       for (var x in cbi_d[target]) {
-               for (var i=0; i<cbi_d[target][x].length; i++) { 
-                       var y = document.getElementById(cbi_d[target][x][i])    
-                       y.style.display = "none";
-               }
-       }
-       
-       var t = document.getElementById(target);
-       if (t && t.value && cbi_d[target][t.value]) {
-               for (var i=0; i<cbi_d[target][t.value].length; i++) {                   
-                       var y = document.getElementById(cbi_d[target][t.value][i])
-                       if (!y.value) { 
-                               y.style.display = "table-row";
-                       } else {
-                               y.style.display = "block";
-                       }
-               }
-       }
-}
-
-function cbi_d_init() {
-       for (var x in cbi_d) {
-               cbi_d_update(x);
-       }
-}
\ No newline at end of file
diff --git a/libs/sgi-haserl/htdocs/cgi-bin/index.cgi b/libs/sgi-haserl/htdocs/cgi-bin/index.cgi
new file mode 100755 (executable)
index 0000000..aae8591
--- /dev/null
@@ -0,0 +1,3 @@
+#!/usr/bin/haserl --shell=luac
+print("Status: 302 Found")
+print("Location: luci\n")
diff --git a/libs/sgi-haserl/htdocs/cgi-bin/luci b/libs/sgi-haserl/htdocs/cgi-bin/luci
new file mode 100755 (executable)
index 0000000..fd8e594
--- /dev/null
@@ -0,0 +1,4 @@
+#!/usr/bin/haserl --shell=luac
+require("luci.sgi.haserl")
+luci.dispatcher.indexcache = "/tmp/.luciindex"
+luci.sgi.haserl.run()
\ No newline at end of file
diff --git a/libs/sgi-haserl/htdocs/cgi-bin/luci-upload b/libs/sgi-haserl/htdocs/cgi-bin/luci-upload
new file mode 100755 (executable)
index 0000000..371967c
--- /dev/null
@@ -0,0 +1,4 @@
+#!/usr/bin/haserl --shell=luac --upload-limit=16384
+-- This is a bit hacky: remove -upload from SCRIPT_NAME
+ENV.SCRIPT_NAME = ENV.SCRIPT_NAME:sub(1, #ENV.SCRIPT_NAME - 7)
+dofile("luci")
\ No newline at end of file
diff --git a/libs/sgi-haserl/htdocs/index.html b/libs/sgi-haserl/htdocs/index.html
new file mode 100644 (file)
index 0000000..39ba558
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
+<html xmlns="http://www.w3.org/1999/xhtml">
+<head>
+<meta http-equiv="refresh" content="0; URL=/cgi-bin/index.cgi" />
+</head>
+<body style="background-color: black">
+<a style="color: white; text-decoration: none" href="/cgi-bin/index.cgi">LuCI - Lua Configuration Interface</a>
+</body>
+</html>
\ No newline at end of file
diff --git a/libs/sgi-haserl/root/www/cgi-bin/index.cgi b/libs/sgi-haserl/root/www/cgi-bin/index.cgi
deleted file mode 100755 (executable)
index aae8591..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/usr/bin/haserl --shell=luac
-print("Status: 302 Found")
-print("Location: luci\n")
diff --git a/libs/sgi-haserl/root/www/cgi-bin/luci b/libs/sgi-haserl/root/www/cgi-bin/luci
deleted file mode 100755 (executable)
index fd8e594..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/usr/bin/haserl --shell=luac
-require("luci.sgi.haserl")
-luci.dispatcher.indexcache = "/tmp/.luciindex"
-luci.sgi.haserl.run()
\ No newline at end of file
diff --git a/libs/sgi-haserl/root/www/cgi-bin/luci-upload b/libs/sgi-haserl/root/www/cgi-bin/luci-upload
deleted file mode 100755 (executable)
index 371967c..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/usr/bin/haserl --shell=luac --upload-limit=16384
--- This is a bit hacky: remove -upload from SCRIPT_NAME
-ENV.SCRIPT_NAME = ENV.SCRIPT_NAME:sub(1, #ENV.SCRIPT_NAME - 7)
-dofile("luci")
\ No newline at end of file
diff --git a/libs/sgi-haserl/root/www/index.html b/libs/sgi-haserl/root/www/index.html
deleted file mode 100644 (file)
index 39ba558..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="utf-8"?>
-<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
-<html xmlns="http://www.w3.org/1999/xhtml">
-<head>
-<meta http-equiv="refresh" content="0; URL=/cgi-bin/index.cgi" />
-</head>
-<body style="background-color: black">
-<a style="color: white; text-decoration: none" href="/cgi-bin/index.cgi">LuCI - Lua Configuration Interface</a>
-</body>
-</html>
\ No newline at end of file
diff --git a/themes/fledermaus/htdocs/luci-static/fledermaus/cascade.css b/themes/fledermaus/htdocs/luci-static/fledermaus/cascade.css
new file mode 100644 (file)
index 0000000..8f30015
--- /dev/null
@@ -0,0 +1,297 @@
+@charset "utf-8";
+
+body {
+       font-family: Verdana, Arial, sans-serif;
+       background-color: #aaaaaa;
+}
+
+h1 {
+       margin: 0%;
+       font-size: 1.4em;
+       font-weight: bold;
+       margin-bottom: 0.5em;
+}
+
+h2 {
+       margin: 0%;
+       font-size: 1.2em;
+       font-weight: bold;
+}
+
+h3 {
+       margin: 0%;
+}
+
+#header {
+       padding: 0.2em;
+       height: 4.5em;
+       background-color: #262626;
+}
+
+#columns {
+       border-left: 10.1em solid #262626;
+       border-right: 10.1em solid #262626;
+       display: block;
+       background-color: white;
+       padding: 0.1em;
+}
+
+#columnswrapper {
+       display: block;
+       margin-left: -10em;
+       margin-right: -10em;
+}
+
+#content {
+       margin-left: 14em;
+       margin-right: 14em;
+       display: block;
+       position: relative;
+       padding: 2px;
+       font-size: 0.8em;
+}
+
+.headerlogo {
+       height: 4em;
+       padding: 5px;
+}
+
+.headerlogo img {
+       height: 100%;
+}
+
+.headertitle {
+       font-size: 2.4em;
+       color: gray;
+       letter-spacing: 0.5em;
+       text-transform: lowercase;
+}
+
+.separator {
+       padding-left: 0.25em;
+       font-weight: bold;
+       font-size: 0.8em;
+       line-height: 1.4em;
+}
+
+.whitetext {
+       color: white;
+}
+
+.yellowtext {
+       color: #ffcb05;
+}
+
+.magentatext {
+       color: #dc0065;
+}
+
+.inheritcolor {
+       color: inherit;
+}
+
+.smalltext {
+       font-size: 0.8em;
+}
+
+.yellow {
+       background-color: #ffcb05;
+}
+
+.magenta {
+       background-color: #dc0065;
+}
+
+.nodeco {
+       text-decoration: none;
+}
+
+.redhover:hover {
+       color: red;
+}
+
+.bold {
+       font-weight: bold;
+}
+
+.sidebar {
+       position: relative;
+       padding: 0.25em;
+       color: gray;
+       width: 9em;
+       font-weight: bold;
+}
+
+.separator a, .sidebar a {
+       color: inherit;
+       text-decoration: inherit;
+}
+
+.separator a:hover, .sidebar a:hover {
+       color: red;
+}
+
+.sidebar div {
+       padding-bottom: 0.5em;
+}
+
+.sidebar ul {
+       font-size: 0.9em;
+       color: white;
+       list-style-type: none;
+       padding-left: 1em;
+       margin-top: 0%;
+}
+
+.table {
+       display: table;
+}
+
+.table-row {
+       display: table-row;
+}
+
+.table-cell {
+       display: table-cell;
+}
+
+.left {
+       float: left;
+       text-align: left;
+}
+
+.right {
+       float: right;
+       text-align: right;
+}
+
+.clear {
+       clear: both;
+}
+
+.hidden {
+       display: none;
+}
+
+.inline {
+       display: inline;
+}
+
+.code {
+       background: #f7f7f7;
+       border: 1px solid #d7d7d7;
+       margin: 1em 1.75em;
+       padding: 1em;
+}
+
+code {
+       display: block;
+       background: #f7f7f7;
+       border: 1px solid #d7d7d7;
+       margin: 1em 1.75em;
+       padding: 1em;
+       overflow: auto;
+       white-space: pre;
+}
+
+.cbi-section {
+       margin-top: 1em;
+}
+
+.cbi-section-remove {
+       text-align: right;
+}
+
+.cbi-value {
+       display: table-row;
+}
+
+.cbi-value-title {
+       display: table-cell;
+       line-height: 1.75em;
+       font-weight: bold;
+       padding: 0.25em;
+}
+
+.cbi-value-field {
+       display: table-cell;
+       text-align: left;
+       padding: 0.25em;
+       line-height: 1.75em;
+}
+
+.cbi-value-field input, .cbi-value-field select,
+.cbi-optionals select, .cbi-optionals input,
+.cbi-section-remove input, .cbi-section-create input  {
+       font-size: 0.8em;
+       margin: 0%;
+}
+
+.cbi-section-descr {
+       padding-bottom: 1em;
+}
+
+.cbi-value-description {
+       display: inline;
+       font-style: italic;
+       font-size: 0.8em; 
+       padding: 0.25em;
+       margin-bottom: 0.5em;
+}
+
+.cbi-form-separator {
+       margin-top: 1em;
+}
+
+.cbi-section-node {
+       display: table;
+       padding: 0.25em;
+       background: #f7f7f7;
+       border: 1px solid #d7d7d7;
+}
+
+.cbi-section-row {
+       display: table-row;
+}
+
+.cbi-section-row-head {
+       display: table-cell;
+       font-weight: bold;
+       padding: 0.25em;
+}
+
+.cbi-section-row-descr {
+       display: table-cell;
+       padding: 0.25em;
+       font-size: 0.8em;
+}
+
+.cbi-section-node h3 {
+       margin-bottom: 0.5em;
+}
+
+.cbi-error {
+       color: red;
+       font-weight: bold;
+       font-size: 0.8em;
+       margin-bottom: 0.75em;
+}
+
+.cbi-optionals {
+       margin-top: 1em;
+       display: table-cell;
+}
+
+.cbi-optionals option {
+       font-size: 0.8em;
+}
+
+.error {
+       color: red;
+       font-weight: bold;
+}
+
+.ok {
+       color: green;
+       font-weight: bold;
+}
\ No newline at end of file
diff --git a/themes/fledermaus/htdocs/luci-static/fledermaus/logo.png b/themes/fledermaus/htdocs/luci-static/fledermaus/logo.png
new file mode 100644 (file)
index 0000000..d4c5dd9
Binary files /dev/null and b/themes/fledermaus/htdocs/luci-static/fledermaus/logo.png differ
diff --git a/themes/fledermaus/root/www/luci-static/fledermaus/cascade.css b/themes/fledermaus/root/www/luci-static/fledermaus/cascade.css
deleted file mode 100644 (file)
index 8f30015..0000000
+++ /dev/null
@@ -1,297 +0,0 @@
-@charset "utf-8";
-
-body {
-       font-family: Verdana, Arial, sans-serif;
-       background-color: #aaaaaa;
-}
-
-h1 {
-       margin: 0%;
-       font-size: 1.4em;
-       font-weight: bold;
-       margin-bottom: 0.5em;
-}
-
-h2 {
-       margin: 0%;
-       font-size: 1.2em;
-       font-weight: bold;
-}
-
-h3 {
-       margin: 0%;
-}
-
-#header {
-       padding: 0.2em;
-       height: 4.5em;
-       background-color: #262626;
-}
-
-#columns {
-       border-left: 10.1em solid #262626;
-       border-right: 10.1em solid #262626;
-       display: block;
-       background-color: white;
-       padding: 0.1em;
-}
-
-#columnswrapper {
-       display: block;
-       margin-left: -10em;
-       margin-right: -10em;
-}
-
-#content {
-       margin-left: 14em;
-       margin-right: 14em;
-       display: block;
-       position: relative;
-       padding: 2px;
-       font-size: 0.8em;
-}
-
-.headerlogo {
-       height: 4em;
-       padding: 5px;
-}
-
-.headerlogo img {
-       height: 100%;
-}
-
-.headertitle {
-       font-size: 2.4em;
-       color: gray;
-       letter-spacing: 0.5em;
-       text-transform: lowercase;
-}
-
-.separator {
-       padding-left: 0.25em;
-       font-weight: bold;
-       font-size: 0.8em;
-       line-height: 1.4em;
-}
-
-.whitetext {
-       color: white;
-}
-
-.yellowtext {
-       color: #ffcb05;
-}
-
-.magentatext {
-       color: #dc0065;
-}
-
-.inheritcolor {
-       color: inherit;
-}
-
-.smalltext {
-       font-size: 0.8em;
-}
-
-.yellow {
-       background-color: #ffcb05;
-}
-
-.magenta {
-       background-color: #dc0065;
-}
-
-.nodeco {
-       text-decoration: none;
-}
-
-.redhover:hover {
-       color: red;
-}
-
-.bold {
-       font-weight: bold;
-}
-
-.sidebar {
-       position: relative;
-       padding: 0.25em;
-       color: gray;
-       width: 9em;
-       font-weight: bold;
-}
-
-.separator a, .sidebar a {
-       color: inherit;
-       text-decoration: inherit;
-}
-
-.separator a:hover, .sidebar a:hover {
-       color: red;
-}
-
-.sidebar div {
-       padding-bottom: 0.5em;
-}
-
-.sidebar ul {
-       font-size: 0.9em;
-       color: white;
-       list-style-type: none;
-       padding-left: 1em;
-       margin-top: 0%;
-}
-
-.table {
-       display: table;
-}
-
-.table-row {
-       display: table-row;
-}
-
-.table-cell {
-       display: table-cell;
-}
-
-.left {
-       float: left;
-       text-align: left;
-}
-
-.right {
-       float: right;
-       text-align: right;
-}
-
-.clear {
-       clear: both;
-}
-
-.hidden {
-       display: none;
-}
-
-.inline {
-       display: inline;
-}
-
-.code {
-       background: #f7f7f7;
-       border: 1px solid #d7d7d7;
-       margin: 1em 1.75em;
-       padding: 1em;
-}
-
-code {
-       display: block;
-       background: #f7f7f7;
-       border: 1px solid #d7d7d7;
-       margin: 1em 1.75em;
-       padding: 1em;
-       overflow: auto;
-       white-space: pre;
-}
-
-.cbi-section {
-       margin-top: 1em;
-}
-
-.cbi-section-remove {
-       text-align: right;
-}
-
-.cbi-value {
-       display: table-row;
-}
-
-.cbi-value-title {
-       display: table-cell;
-       line-height: 1.75em;
-       font-weight: bold;
-       padding: 0.25em;
-}
-
-.cbi-value-field {
-       display: table-cell;
-       text-align: left;
-       padding: 0.25em;
-       line-height: 1.75em;
-}
-
-.cbi-value-field input, .cbi-value-field select,
-.cbi-optionals select, .cbi-optionals input,
-.cbi-section-remove input, .cbi-section-create input  {
-       font-size: 0.8em;
-       margin: 0%;
-}
-
-.cbi-section-descr {
-       padding-bottom: 1em;
-}
-
-.cbi-value-description {
-       display: inline;
-       font-style: italic;
-       font-size: 0.8em; 
-       padding: 0.25em;
-       margin-bottom: 0.5em;
-}
-
-.cbi-form-separator {
-       margin-top: 1em;
-}
-
-.cbi-section-node {
-       display: table;
-       padding: 0.25em;
-       background: #f7f7f7;
-       border: 1px solid #d7d7d7;
-}
-
-.cbi-section-row {
-       display: table-row;
-}
-
-.cbi-section-row-head {
-       display: table-cell;
-       font-weight: bold;
-       padding: 0.25em;
-}
-
-.cbi-section-row-descr {
-       display: table-cell;
-       padding: 0.25em;
-       font-size: 0.8em;
-}
-
-.cbi-section-node h3 {
-       margin-bottom: 0.5em;
-}
-
-.cbi-error {
-       color: red;
-       font-weight: bold;
-       font-size: 0.8em;
-       margin-bottom: 0.75em;
-}
-
-.cbi-optionals {
-       margin-top: 1em;
-       display: table-cell;
-}
-
-.cbi-optionals option {
-       font-size: 0.8em;
-}
-
-.error {
-       color: red;
-       font-weight: bold;
-}
-
-.ok {
-       color: green;
-       font-weight: bold;
-}
\ No newline at end of file
diff --git a/themes/fledermaus/root/www/luci-static/fledermaus/logo.png b/themes/fledermaus/root/www/luci-static/fledermaus/logo.png
deleted file mode 100644 (file)
index d4c5dd9..0000000
Binary files a/themes/fledermaus/root/www/luci-static/fledermaus/logo.png and /dev/null differ
diff --git a/themes/openwrt.org/htdocs/luci-static/openwrt.org/cascade.css b/themes/openwrt.org/htdocs/luci-static/openwrt.org/cascade.css
new file mode 100644 (file)
index 0000000..90827ab
--- /dev/null
@@ -0,0 +1,298 @@
+@charset "utf-8";
+
+body {
+       font-family: Verdana, Arial, sans-serif;
+       background-color: #557788;
+}
+
+h1 {
+       margin: 0%;
+       font-size: 1.4em;
+       font-weight: bold;
+       margin-bottom: 0.5em;
+}
+
+h2 {
+       margin: 0%;
+       font-size: 1.2em;
+       font-weight: bold;
+}
+
+h3 {
+       margin: 0%;
+}
+
+#page {
+       background-color: #d4dce0;
+       border-left: 3px solid #000000;
+       border-right: 3px solid #000000;
+}
+
+#header {
+       padding: 0.2em;
+       height: 4.5em;
+       padding-left: 1.2em;
+}
+
+#columns {
+       border-left: 10.1em solid #ccd6db;
+       border-right: 10.1em solid #ccd6db;
+       display: block;
+       padding: 0.1em;
+}
+
+#columnswrapper {
+       display: block;
+       margin-left: -10em;
+       margin-right: -10em;
+}
+
+#content {
+       margin-left: 14em;
+       margin-right: 14em;
+       display: block;
+       position: relative;
+       padding: 2px;
+       font-size: 0.8em;
+}
+
+.headerlogo {
+       height: 4em;
+       padding: 5px;
+}
+
+.headerlogo img {
+       height: 100%;
+}
+
+.headertitle {
+       font-size: 2.4em;
+       color: black;
+       font-weight: bold;
+       letter-spacing: 0.6em;
+       text-transform: lowercase;
+}
+
+.separator {
+       padding-left: 0.25em;
+       font-weight: bold;
+       font-size: 0.8em;
+       line-height: 1.4em;
+}
+
+.whitetext {
+       color: white;
+}
+
+.blacktext {
+       color: #000000;
+}
+
+.magentatext {
+       color: #dc0065;
+}
+
+.inheritcolor {
+       color: inherit;
+}
+
+.smalltext {
+       font-size: 0.8em;
+}
+
+.black {
+       background-color: #000000;
+}
+
+.nodeco {
+       text-decoration: none;
+}
+
+.redhover:hover {
+       color: red;
+}
+
+.bold {
+       font-weight: bold;
+}
+
+.sidebar {
+       position: relative;
+       padding: 0.25em;
+       color: gray;
+       width: 9em;
+       font-weight: bold;
+}
+
+.separator a, .sidebar a {
+       color: inherit;
+       text-decoration: inherit;
+}
+
+.separator a:hover, .sidebar a:hover {
+       color: red;
+}
+
+.sidebar div {
+       padding-bottom: 0.5em;
+}
+
+.sidebar ul {
+       font-size: 0.9em;
+       color: white;
+       list-style-type: none;
+       padding-left: 1em;
+       margin-top: 0%;
+}
+
+.table {
+       display: table;
+}
+
+.table-row {
+       display: table-row;
+}
+
+.table-cell {
+       display: table-cell;
+}
+
+.left {
+       float: left;
+       text-align: left;
+}
+
+.right {
+       float: right;
+       text-align: right;
+}
+
+.clear {
+       clear: both;
+}
+
+.hidden {
+       display: none;
+}
+
+.inline {
+       display: inline;
+}
+
+.code {
+       background: #f7f7f7;
+       border: 1px solid #d7d7d7;
+       margin: 1em 1.75em;
+       padding: 1em;
+}
+
+code {
+       display: block;
+       background: #f7f7f7;
+       border: 1px solid #d7d7d7;
+       margin: 1em 1.75em;
+       padding: 1em;
+       overflow: auto;
+       white-space: pre;
+}
+
+.cbi-section {
+       margin-top: 1em;
+}
+
+.cbi-section-remove {
+       text-align: right;
+}
+
+.cbi-value {
+       display: table-row;
+}
+
+.cbi-value-title {
+       display: table-cell;
+       line-height: 1.75em;
+       font-weight: bold;
+       padding: 0.25em;
+}
+
+.cbi-value-field {
+       display: table-cell;
+       text-align: left;
+       padding: 0.25em;
+       line-height: 1.75em;
+}
+
+.cbi-value-field input, .cbi-value-field select,
+.cbi-optionals select, .cbi-optionals input,
+.cbi-section-remove input, .cbi-section-create input  {
+       font-size: 0.8em;
+       margin: 0%;
+}
+
+.cbi-section-descr {
+       padding-bottom: 1em;
+}
+
+.cbi-value-description {
+       display: inline;
+       font-style: italic;
+       font-size: 0.8em; 
+       padding: 0.25em;
+       margin-bottom: 0.5em;
+}
+
+.cbi-form-separator {
+       margin-top: 1em;
+}
+
+.cbi-section-node {
+       display: table;
+       padding: 0.25em;
+       border: 1px solid #000000;
+}
+
+.cbi-section-row {
+       display: table-row;
+}
+
+.cbi-section-row-head {
+       display: table-cell;
+       font-weight: bold;
+       padding: 0.25em;
+}
+
+.cbi-section-row-descr {
+       display: table-cell;
+       padding: 0.25em;
+       font-size: 0.8em;
+}
+
+.cbi-section-node h3 {
+       margin-bottom: 0.5em;
+}
+
+.cbi-error {
+       color: red;
+       font-weight: bold;
+       font-size: 0.8em;
+       margin-bottom: 0.75em;
+}
+
+.cbi-optionals {
+       margin-top: 1em;
+       display: table-cell;
+}
+
+.cbi-optionals option {
+       font-size: 0.8em;
+}
+
+.error {
+       color: red;
+       font-weight: bold;
+}
+
+.ok {
+       color: green;
+       font-weight: bold;
+}
\ No newline at end of file
diff --git a/themes/openwrt.org/root/www/luci-static/openwrt.org/cascade.css b/themes/openwrt.org/root/www/luci-static/openwrt.org/cascade.css
deleted file mode 100644 (file)
index 90827ab..0000000
+++ /dev/null
@@ -1,298 +0,0 @@
-@charset "utf-8";
-
-body {
-       font-family: Verdana, Arial, sans-serif;
-       background-color: #557788;
-}
-
-h1 {
-       margin: 0%;
-       font-size: 1.4em;
-       font-weight: bold;
-       margin-bottom: 0.5em;
-}
-
-h2 {
-       margin: 0%;
-       font-size: 1.2em;
-       font-weight: bold;
-}
-
-h3 {
-       margin: 0%;
-}
-
-#page {
-       background-color: #d4dce0;
-       border-left: 3px solid #000000;
-       border-right: 3px solid #000000;
-}
-
-#header {
-       padding: 0.2em;
-       height: 4.5em;
-       padding-left: 1.2em;
-}
-
-#columns {
-       border-left: 10.1em solid #ccd6db;
-       border-right: 10.1em solid #ccd6db;
-       display: block;
-       padding: 0.1em;
-}
-
-#columnswrapper {
-       display: block;
-       margin-left: -10em;
-       margin-right: -10em;
-}
-
-#content {
-       margin-left: 14em;
-       margin-right: 14em;
-       display: block;
-       position: relative;
-       padding: 2px;
-       font-size: 0.8em;
-}
-
-.headerlogo {
-       height: 4em;
-       padding: 5px;
-}
-
-.headerlogo img {
-       height: 100%;
-}
-
-.headertitle {
-       font-size: 2.4em;
-       color: black;
-       font-weight: bold;
-       letter-spacing: 0.6em;
-       text-transform: lowercase;
-}
-
-.separator {
-       padding-left: 0.25em;
-       font-weight: bold;
-       font-size: 0.8em;
-       line-height: 1.4em;
-}
-
-.whitetext {
-       color: white;
-}
-
-.blacktext {
-       color: #000000;
-}
-
-.magentatext {
-       color: #dc0065;
-}
-
-.inheritcolor {
-       color: inherit;
-}
-
-.smalltext {
-       font-size: 0.8em;
-}
-
-.black {
-       background-color: #000000;
-}
-
-.nodeco {
-       text-decoration: none;
-}
-
-.redhover:hover {
-       color: red;
-}
-
-.bold {
-       font-weight: bold;
-}
-
-.sidebar {
-       position: relative;
-       padding: 0.25em;
-       color: gray;
-       width: 9em;
-       font-weight: bold;
-}
-
-.separator a, .sidebar a {
-       color: inherit;
-       text-decoration: inherit;
-}
-
-.separator a:hover, .sidebar a:hover {
-       color: red;
-}
-
-.sidebar div {
-       padding-bottom: 0.5em;
-}
-
-.sidebar ul {
-       font-size: 0.9em;
-       color: white;
-       list-style-type: none;
-       padding-left: 1em;
-       margin-top: 0%;
-}
-
-.table {
-       display: table;
-}
-
-.table-row {
-       display: table-row;
-}
-
-.table-cell {
-       display: table-cell;
-}
-
-.left {
-       float: left;
-       text-align: left;
-}
-
-.right {
-       float: right;
-       text-align: right;
-}
-
-.clear {
-       clear: both;
-}
-
-.hidden {
-       display: none;
-}
-
-.inline {
-       display: inline;
-}
-
-.code {
-       background: #f7f7f7;
-       border: 1px solid #d7d7d7;
-       margin: 1em 1.75em;
-       padding: 1em;
-}
-
-code {
-       display: block;
-       background: #f7f7f7;
-       border: 1px solid #d7d7d7;
-       margin: 1em 1.75em;
-       padding: 1em;
-       overflow: auto;
-       white-space: pre;
-}
-
-.cbi-section {
-       margin-top: 1em;
-}
-
-.cbi-section-remove {
-       text-align: right;
-}
-
-.cbi-value {
-       display: table-row;
-}
-
-.cbi-value-title {
-       display: table-cell;
-       line-height: 1.75em;
-       font-weight: bold;
-       padding: 0.25em;
-}
-
-.cbi-value-field {
-       display: table-cell;
-       text-align: left;
-       padding: 0.25em;
-       line-height: 1.75em;
-}
-
-.cbi-value-field input, .cbi-value-field select,
-.cbi-optionals select, .cbi-optionals input,
-.cbi-section-remove input, .cbi-section-create input  {
-       font-size: 0.8em;
-       margin: 0%;
-}
-
-.cbi-section-descr {
-       padding-bottom: 1em;
-}
-
-.cbi-value-description {
-       display: inline;
-       font-style: italic;
-       font-size: 0.8em; 
-       padding: 0.25em;
-       margin-bottom: 0.5em;
-}
-
-.cbi-form-separator {
-       margin-top: 1em;
-}
-
-.cbi-section-node {
-       display: table;
-       padding: 0.25em;
-       border: 1px solid #000000;
-}
-
-.cbi-section-row {
-       display: table-row;
-}
-
-.cbi-section-row-head {
-       display: table-cell;
-       font-weight: bold;
-       padding: 0.25em;
-}
-
-.cbi-section-row-descr {
-       display: table-cell;
-       padding: 0.25em;
-       font-size: 0.8em;
-}
-
-.cbi-section-node h3 {
-       margin-bottom: 0.5em;
-}
-
-.cbi-error {
-       color: red;
-       font-weight: bold;
-       font-size: 0.8em;
-       margin-bottom: 0.75em;
-}
-
-.cbi-optionals {
-       margin-top: 1em;
-       display: table-cell;
-}
-
-.cbi-optionals option {
-       font-size: 0.8em;
-}
-
-.error {
-       color: red;
-       font-weight: bold;
-}
-
-.ok {
-       color: green;
-       font-weight: bold;
-}
\ No newline at end of file