luci-app-ddns: removing unneeded assert 616/head
authorChristian Schoenebeck <christian.schoenebeck@gmail.com>
Thu, 31 Dec 2015 11:14:13 +0000 (12:14 +0100)
committerChristian Schoenebeck <christian.schoenebeck@gmail.com>
Thu, 31 Dec 2015 11:14:13 +0000 (12:14 +0100)
- remove unneeded assert() in tools/ddns.lua
- correct PKG_VERSION to the correct value from controller/ddns.lua

Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
applications/luci-app-ddns/Makefile
applications/luci-app-ddns/luasrc/controller/ddns.lua [changed mode: 0644->0755]
applications/luci-app-ddns/luasrc/tools/ddns.lua [changed mode: 0644->0755]

index dadff5a..1e38c25 100644 (file)
@@ -10,7 +10,7 @@ PKG_NAME:=luci-app-ddns
 
 # Version == major.minor.patch
 # increase on new functionality (minor) or patches (patch)
-PKG_VERSION:=2.2.4
+PKG_VERSION:=2.3.1
 
 # Release == build
 # increase on changes of translation files
old mode 100644 (file)
new mode 100755 (executable)
index 29598ea..abaf1c7
@@ -22,7 +22,7 @@ local srv_ver_min = "2.5.0"                   -- minimum version of service required
 local srv_ver_cmd = [[/usr/lib/ddns/dynamic_dns_updater.sh --version | awk {'print $2'}]]
 local app_name    = "luci-app-ddns"
 local app_title   = "Dynamic DNS"
-local app_version = "2.3.0-1"
+local app_version = "2.3.1-1"
 
 function index()
        local nxfs      = require "nixio.fs"            -- global definitions not available
old mode 100644 (file)
new mode 100755 (executable)
index ecc4131..02331f4
@@ -166,8 +166,6 @@ function value_parse(self, section, novld)
                        return          -- so data is missing
                end
        end
-       -- for whatever reason errtxt set and not handled above
-       assert( not (errtxt and (#errtxt > 0)), "unhandled validate error" )
 
        -- lets continue with value returned from validate
        eq_cfg  = ( vvalue == cvalue )                  -- update equal_config flag