Merge pull request #535 from saik0/redirect-root-if-empty-signed
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 11 Nov 2015 09:14:34 +0000 (10:14 +0100)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 11 Nov 2015 09:14:34 +0000 (10:14 +0100)
Redirect to root on empty path (signed off)

applications/luci-app-privoxy/Makefile
applications/luci-app-privoxy/luasrc/model/cbi/privoxy.lua
applications/luci-app-radicale/Makefile
applications/luci-app-radicale/luasrc/controller/radicale.lua
modules/luci-mod-admin-full/luasrc/model/cbi/admin_network/iface_add.lua
modules/luci-mod-admin-full/luasrc/model/cbi/admin_system/fstab/mount.lua

index e16eb41..260f840 100644 (file)
@@ -10,11 +10,11 @@ PKG_NAME:=luci-app-privoxy
 
 # Version == major.minor.patch
 # increase "minor" on new functionality and "patch" on patches/optimization
-PKG_VERSION:=1.0.4
+PKG_VERSION:=1.0.5
 
 # Release == build
 # increase on changes of translation files
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_LICENSE:=Apache-2.0
 PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
index c415f8e..8ea2496 100644 (file)
@@ -14,7 +14,7 @@ local HELP = [[<a href="http://www.privoxy.org/user-manual/config.html#%s" targe
 local VERINST = CTRL.ipkg_ver_installed("privoxy")
 local VEROK   = CTRL.ipkg_ver_compare(VERINST,">=",CTRL.PRIVOXY_MIN)
 
-local TITLE = [[</a><a href="javascript:alert(']]
+local TITLE = [[<a href="javascript:alert(']]
                .. translate("Version Information")
                .. [[\n\nluci-app-privoxy]]
                .. [[\n\t]] .. translate("Version") .. [[:\t]]
@@ -26,6 +26,7 @@ local TITLE = [[</a><a href="javascript:alert(']]
                .. [[\n\n]]
        .. [[')">]]
        .. translate("Privoxy WEB proxy")
+       .. [[</a>]]
 
 local DESC = translate("Privoxy is a non-caching web proxy with advanced filtering "
                .. "capabilities for enhancing privacy, modifying web page data and HTTP headers, "
index 960618d..1501d4f 100644 (file)
@@ -10,7 +10,7 @@ PKG_NAME:=luci-app-radicale
 
 # Version == major.minor.patch
 # increase "minor" on new functionality and "patch" on patches/optimization
-PKG_VERSION:=1.0.1
+PKG_VERSION:=1.0.2
 
 # Release == build
 # increase on changes of translation files
index 35f5a83..10ec1fe 100644 (file)
@@ -82,7 +82,7 @@ function service_ok()
 end
 
 function app_title_main()
-       return  [[</a><a href="javascript:alert(']]
+       return  [[<a href="javascript:alert(']]
                        .. I18N.translate("Version Information")
                        .. [[\n\n]] .. luci_app_name()
                        .. [[\n\t]] .. I18N.translate("Version") .. [[:\t]]
@@ -100,12 +100,14 @@ function app_title_main()
                        .. [[\n\n]]
                .. [[')">]]
                .. I18N.translate("Radicale CalDAV/CardDAV Server")
+               .. [[</a>]]
 end
 function app_title_back()
-       return  [[</a><a href="]]
+       return  [[<a href="]]
                        .. DISP.build_url("admin", "services", "radicale")
                .. [[">]]
                .. I18N.translate("Radicale CalDAV/CardDAV Server")
+               .. [[</a>]]
 end
 function app_description()
        return  I18N.translate("The Radicale Project is a complete CalDAV (calendar) and CardDAV (contact) server solution.") .. [[<br />]]
index da1e140..e48e3b4 100644 (file)
@@ -17,7 +17,12 @@ newnet = m:field(Value, "_netname", translate("Name of the new interface"),
 
 newnet:depends("_attach", "")
 newnet.default = arg[1] and "net_" .. arg[1]:gsub("[^%w_]+", "_")
-newnet.datatype = "uciname"
+newnet.datatype = "and(uciname,maxlength(15))"
+
+advice = m:field(DummyValue, "d1", translate("Note: interface name length"),
+        translate("Maximum length of the name is 15 characters including " ..
+               "the automatic protocol/bridge prefix (br-, 6in4-, pppoe- etc.)"
+       ))
 
 newproto = m:field(ListValue, "_netproto", translate("Protocol of the new interface"))
 
index 2652e00..f575167 100644 (file)
@@ -112,7 +112,7 @@ o.default = [[
 mkdir -p /tmp/extroot
 mount --bind / /tmp/introot
 mount /dev/sda1 /tmp/extroot
-tar -C /tmp/intproot -cvf - . | tar -C /tmp/extroot -xf -
+tar -C /tmp/introot -cvf - . | tar -C /tmp/extroot -xf -
 umount /tmp/introot
 umount /tmp/extroot</pre>
 ]] %{