contrib/package: make luci depend on uhttpd, add luci-ssl collection
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 27 Mar 2010 20:56:28 +0000 (20:56 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 27 Mar 2010 20:56:28 +0000 (20:56 +0000)
contrib/package/luci/Makefile

index 6229646..c3ee83f 100644 (file)
@@ -780,7 +780,7 @@ define Package/luci-sgi-cgi/install
 endef
 
 define Package/luci-sgi-uhttpd
-  $(call Package/luci/webservertemplate)
+  $(call Package/luci/libtemplate)
   TITLE:=Binding for the uHTTPd server
   DEPENDS+=+uhttpd +uhttpd-mod-lua
 endef
@@ -990,8 +990,9 @@ endef
 ### Collections ###
 define Package/luci
   $(call Package/luci/collectiontemplate)
-  TITLE:=Standard OpenWrt Kamikaze set including full and mini admin and the standard theme
-  DEPENDS:=+luci-admin-full +luci-admin-mini +luci-theme-openwrt +luci-app-firewall +luci-app-initmgr
+  TITLE:=Standard OpenWrt set including full and mini admin and the standard theme
+  DEPENDS:=+uhttpd +luci-admin-full +luci-admin-mini +luci-theme-openwrt \
+    +luci-app-firewall +luci-app-initmgr
 endef
 
 define Package/luci/install
@@ -999,10 +1000,22 @@ define Package/luci/install
 endef
 
 
+define Package/luci-ssl
+  $(call Package/luci/collectiontemplate)
+  TITLE:=Standard OpenWrt set with https support
+  DEPENDS:=+uhttpd +uhttpd-mod-tls +px5g +luci-admin-full +luci-admin-mini \
+    +luci-theme-openwrt +luci-app-firewall +luci-app-initmgr
+endef
+
+define Package/luci-ssl/install
+       true
+endef
+
+
 define Package/luci-light
   $(call Package/luci/collectiontemplate)
   TITLE:=Minimum package set using only admin mini and a theme without grafics
-  DEPENDS:=+luci-admin-mini +luci-theme-openwrtlight
+  DEPENDS:=+uhttpd +luci-admin-mini +luci-theme-openwrtlight
 endef
 
 define Package/luci-light/install
@@ -1324,4 +1337,5 @@ $(eval $(call BuildPackage,luci-i18n-spanish))
 $(eval $(call BuildPackage,luci-i18n-vietnamese))
 
 $(eval $(call BuildPackage,luci))
+$(eval $(call BuildPackage,luci-ssl))
 $(eval $(call BuildPackage,luci-light))