luci-0.11: merge r9571 - r9573
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 29 Dec 2012 13:15:53 +0000 (13:15 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 29 Dec 2012 13:15:53 +0000 (13:15 +0000)
applications/luci-polipo/root/usr/sbin/polipo_purge
contrib/uhttpd/patches/001-pass-env.patch
contrib/uhttpd/patches/002-link-order.patch [new file with mode: 0644]
contrib/uhttpd/patches/series
po/ca/upnp.po
po/de/upnp.po
po/en/upnp.po
po/es/upnp.po
po/pt/upnp.po
po/pt_BR/upnp.po
po/vi/upnp.po

index ce7c885..23ba571 100755 (executable)
@@ -5,7 +5,7 @@ PIDFILE=`uci get polipo.daemon.pidFile`
 CFGFILE=/var/etc/polipo.conf
 
 [ -e "$PIDFILE" ] && {
-       PID=`cat $PID_FILE`
+       PID=`cat $PIDFILE`
 
        # send Polipo USR1 signal to write its in-memory cache to disk
        kill -USR1 $PID
index b69ff17..ab607db 100644 (file)
@@ -1,7 +1,7 @@
 --- a/uhttpd-cgi.c
 +++ b/uhttpd-cgi.c
-@@ -204,7 +204,7 @@ void uh_cgi_request(struct client *cl, s
-                           (pi->stat.st_mode & S_IXOTH)
+@@ -216,7 +216,7 @@ void uh_cgi_request(
+                            (pi->stat.st_mode & S_IXOTH)) || (ip != NULL)
                        ) {
                                /* build environment */
 -                              clearenv();
diff --git a/contrib/uhttpd/patches/002-link-order.patch b/contrib/uhttpd/patches/002-link-order.patch
new file mode 100644 (file)
index 0000000..8bdd335
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -70,7 +70,7 @@ endif
+       $(CC) $(CFLAGS) -c -o $@ $<
+ compile: $(OBJ) $(TLSLIB) $(LUALIB)
+-      $(CC) -o uhttpd $(LDFLAGS) $(LIB) $(OBJ)
++      $(CC) -o uhttpd $(LDFLAGS) $(OBJ) $(LIB)
+ clean:
+       rm -f *.o *.so uhttpd
index dc852df..8a1834e 100644 (file)
@@ -1 +1,2 @@
 001-pass-env.patch
+002-link-order.patch
index 393a562..ad0f408 100644 (file)
@@ -139,7 +139,7 @@ msgid "UPnP lease file"
 msgstr ""
 
 msgid "Universal Plug & Play"
-msgstr "Universal Plug &amp; Play"
+msgstr "Universal Plug & Play"
 
 msgid "Uplink"
 msgstr "Enllaç de pujada"
index acfdb65..7c7ec08 100644 (file)
@@ -143,7 +143,7 @@ msgid "UPnP lease file"
 msgstr "UPnP Lease-Datei"
 
 msgid "Universal Plug & Play"
-msgstr "Universal Plug &amp; Play"
+msgstr "Universal Plug & Play"
 
 msgid "Uplink"
 msgstr "Uplink"
index 25e374d..0afabe2 100644 (file)
@@ -138,7 +138,7 @@ msgid "UPnP lease file"
 msgstr ""
 
 msgid "Universal Plug & Play"
-msgstr "Universal Plug &amp; Play"
+msgstr "Universal Plug & Play"
 
 msgid "Uplink"
 msgstr "Uplink"
index 975ad1a..3ad9b01 100644 (file)
@@ -143,7 +143,7 @@ msgid "UPnP lease file"
 msgstr "Tiempo de cesión UPnP"
 
 msgid "Universal Plug & Play"
-msgstr "Plug &amp; Play universal"
+msgstr "Plug & Play universal"
 
 msgid "Uplink"
 msgstr "Enlace de subida"
index 2a0992c..ea74caf 100644 (file)
@@ -137,7 +137,7 @@ msgid "UPnP lease file"
 msgstr ""
 
 msgid "Universal Plug & Play"
-msgstr "Plug &amp; Play Universal"
+msgstr "Plug & Play Universal"
 
 msgid "Uplink"
 msgstr "Link para Upload"
index 049604d..9df27ee 100644 (file)
@@ -143,7 +143,7 @@ msgid "UPnP lease file"
 msgstr "Arquivo de concessão do UPnP"
 
 msgid "Universal Plug & Play"
-msgstr "Plug &amp; Play Universal"
+msgstr "Plug & Play Universal"
 
 msgid "Uplink"
 msgstr "Velocidade de envio do enlace (uplink)"
index cb2b54e..f13b14b 100644 (file)
@@ -138,7 +138,7 @@ msgid "UPnP lease file"
 msgstr ""
 
 msgid "Universal Plug & Play"
-msgstr "Universal Plug &amp; Play"
+msgstr "Universal Plug & Play"
 
 msgid "Uplink"
 msgstr "Uplink"