i18n: .xml should not overwrite .lua files if they are older
authorSteven Barth <steven@midlink.org>
Sun, 14 Dec 2008 11:54:36 +0000 (11:54 +0000)
committerSteven Barth <steven@midlink.org>
Sun, 14 Dec 2008 11:54:36 +0000 (11:54 +0000)
build/module.mk

index 18eda9d..8f3964a 100644 (file)
@@ -16,7 +16,7 @@ compile:
 clean: luaclean
 
 i18n:
-       [ -n "$(XSLTPROC)" ] && for i in luasrc/i18n/*.xml; do [ -f "$$i" ]\
+       [ -n "$(XSLTPROC)" ] && for i in luasrc/i18n/*.xml; do [ "$$i" -nt "$${i%%[.]xml}.lua" ]\
        && $(XSLTPROC) $(MAKEPATH)i18n-lua-xhtml1.xsl $$i > $${i%%[.]xml}.lua; done || true
 
 luasource: