Fix config files getting overwritten in opkg install
[project/luci.git] / modules / luci-base / Makefile
index 4fb278b..ce7d40d 100644 (file)
@@ -24,6 +24,7 @@ include $(INCLUDE_DIR)/host-build.mk
 
 define Package/luci-base/conffiles
 /etc/luci-uploads
+/etc/config/luci
 endef
 
 include ../../luci.mk
@@ -37,9 +38,9 @@ define Host/Compile
 endef
 
 define Host/Install
-       $(INSTALL_DIR) $(HOST_BUILD_PREFIX)/bin
-       $(INSTALL_BIN) src/po2lmo $(HOST_BUILD_PREFIX)/bin/po2lmo
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(HOST_BUILD_PREFIX)/bin/LuaSrcDiet
+       $(INSTALL_DIR) $(1)/bin
+       $(INSTALL_BIN) src/po2lmo $(1)/bin/po2lmo
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/bin/LuaSrcDiet.lua $(1)/bin/LuaSrcDiet
 endef
 
 $(eval $(call HostBuild))