modules: add failsafe module
[project/luci.git] / contrib / package / luci / Makefile
index ae7a42c..9c0ca74 100644 (file)
@@ -54,7 +54,7 @@ define Package/luci-lib-core
   URL:=http://luci.subsignal.org/
   MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
   SUBMENU:=8. Libraries
-  DEPENDS:=+lua +libuci-lua
+  DEPENDS:=+lua +libuci-lua +libubus-lua
   TITLE:=LuCI core libraries
 endef
 
@@ -173,7 +173,7 @@ ifneq ($(CONFIG_PACKAGE_luci-lib-nixio_cyassl),)
 endif
 
 
-$(eval $(call library,fastindex,Fastindex indexing module))
+$(eval $(call library,fastindex,Fastindex indexing module,+PACKAGE_luci-lib-fastindex:liblua))
 $(eval $(call library,httpclient,HTTP(S) client library,+luci-lib-web +luci-lib-nixio))
 $(eval $(call library,ipkg,LuCI IPKG/OPKG call abstraction library))
 $(eval $(call library,json,LuCI JSON library))
@@ -212,10 +212,9 @@ define protocol
 endef
 
 $(eval $(call protocol,core,Support for static/dhcp/none))
-$(eval $(call protocol,ppp,Support for PPP/PPPoE/PPPoA))
-$(eval $(call protocol,pptp,Support for PPtP,+pptp))
-$(eval $(call protocol,6x4,Support for 6in4/6to4,+6in4 +6to4))
-$(eval $(call protocol,3g,Support for 3G,+comgt))
+$(eval $(call protocol,ppp,Support for PPP/PPPoE/PPPoA/PPtP))
+$(eval $(call protocol,6x4,Support for 6in4/6to4/6rd,+PACKAGE_luci-proto-6x4:6in4 +PACKAGE_luci-proto-6x4:6to4 +PACKAGE_luci-proto-6x4:6rd))
+$(eval $(call protocol,3g,Support for 3G,+PACKAGE_luci-proto-3g:comgt))
 $(eval $(call protocol,relay,Support for relayd pseudo bridges,+PACKAGE_luci-proto-relay:relayd))
 
 
@@ -281,6 +280,7 @@ endef
 $(eval $(call module,admin-core,Web UI Core module,+luci-lib-web +luci-proto-core +luci-i18n-english))
 $(eval $(call module,admin-mini,LuCI Essentials - stripped down and user-friendly,+luci-mod-admin-core @BROKEN))
 $(eval $(call module,admin-full,LuCI Administration - full-featured for full control,+luci-mod-admin-core +luci-lib-ipkg))
+$(eval $(call module,failsafe,LuCI Fail-Safe - Fail-Safe sysupgrade module,+luci-mod-admin-core))
 $(eval $(call module,rpc,LuCI RPC - JSON-RPC API,+luci-lib-json))
 $(eval $(call module,freifunk,LuCI Freifunk module,+luci-mod-admin-full +luci-lib-json +PACKAGE_luci-mod-freifunk:freifunk-firewall +freifunk-common +community-profiles))
 $(eval $(call module,niu,NIU - Next Generation Interface,+luci-mod-admin-core @BROKEN))
@@ -333,6 +333,9 @@ $(eval $(call application,firewall,Firmware and Portforwarding application,\
 $(eval $(call application,freifunk-policyrouting,Policy routing for mesh traffic,\
         +PACKAGE_luci-app-freifunk-policyrouting:freifunk-policyrouting))
 
+$(eval $(call application,freifunk-widgets,Widgets for the Freifunk index page,\
+        +PACKAGE_luci-app-freifunk-widgets:luci-mod-freifunk))
+
 $(eval $(call application,meshwizard, Shellscript based wizard to setup mesh networks,\
         +PACKAGE_luci-app-freifunk-meshwizard:meshwizard))
 
@@ -357,7 +360,8 @@ $(eval $(call application,statistics,LuCI Statistics Application,\
        +PACKAGE_luci-app-statistics:collectd-mod-rrdtool \
        +PACKAGE_luci-app-statistics:collectd-mod-iwinfo \
        +PACKAGE_luci-app-statistics:collectd-mod-interface \
-       +PACKAGE_luci-app-statistics:collectd-mod-load))
+       +PACKAGE_luci-app-statistics:collectd-mod-load)) \
+       +PACKAGE_luci-app-statistics:collectd-mod-network))
 
 
 $(eval $(call application,diag-core,LuCI Diagnostics Tools (Core)))
@@ -386,7 +390,7 @@ $(eval $(call application,ddns,Dynamic DNS configuration module,\
        +PACKAGE_luci-app-ddns:ddns-scripts))
 
 $(eval $(call application,samba,Network Shares - Samba SMB/CIFS module,\
-       +PACKAGE_luci-app-samba:samba3))
+       +PACKAGE_luci-app-samba:samba36-server))
 
 $(eval $(call application,mmc-over-gpio,MMC-over-GPIO configuration module,\
        +PACKAGE_luci-app-mmc-over-gpio:kmod-mmc-over-gpio))
@@ -407,7 +411,7 @@ $(eval $(call application,polipo,LuCI Support for the Polipo Proxy,\
        +PACKAGE_luci-app-polipo:polipo))
 
 $(eval $(call application,openvpn,LuCI Support for OpenVPN,\
-       +PACKAGE_luci-app-openvpn:openvpn))
+       +PACKAGE_luci-app-openvpn:openvpn @BROKEN))
 
 $(eval $(call application,p2pblock,LuCI Support for the Freifunk P2P-Block addon,\
        luci-app-firewall +PACKAGE_luci-app-p2pblock:freifunk-p2pblock))
@@ -448,6 +452,15 @@ $(eval $(call application,pbx-voicemail,LuCI PBX Administration Voicemail Suppor
 
 $(eval $(call application,ltqtapi,Lantiq voip))
 
+$(eval $(call application,minidlna,LuCI Support for miniDLNA,\
+       +PACKAGE_luci-app-minidlna:minidlna))
+
+$(eval $(call application,transmission,LuCI Support for Transmission,\
+       +PACKAGE_luci-app-transmission:transmission-daemon))
+
+$(eval $(call application,watchcat,LuCI Support for Watchcat,\
+       +PACKAGE_luci-app-watchcat:watchcat))
+
 ### Server Gateway Interfaces ###
 define sgi
   define Package/luci-sgi-$(1)
@@ -505,9 +518,6 @@ $(eval $(call theme,base,Common base for all themes))
 $(eval $(call theme,openwrt,OpenWrt.org (default),,,1))
 $(eval $(call theme,bootstrap,Bootstrap Theme))
 
-$(eval $(call theme,freifunk,alternative Freifunk Theme,\
-       Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>))
-
 $(eval $(call theme,freifunk-bno,Freifunk Berlin Nordost Theme,\
        Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>))
 
@@ -555,6 +565,8 @@ $(eval $(call translation,norwegian,Norwegian (by Lars Hardy)))
 $(eval $(call translation,hebrew,Hebrew))
 $(eval $(call translation,romanian,Romanian))
 $(eval $(call translation,ukrainian,Ukrainian))
+$(eval $(call translation,hungarian,Hungarian))
+$(eval $(call translation,polish,Polish))
 
 
 ### Collections ###