* luci-0.8: merge r3724, r3725
[project/luci.git] / contrib / package / luci / Makefile
index fd1fa35..9ae6f57 100644 (file)
@@ -12,7 +12,7 @@ PKG_RELEASE:=1
 ifeq ($(USELOCAL),1)
   PKG_VERSION:=0.8+svn
 else
-  PKG_SOURCE_URL:=http://dev.leipzig.freifunk.net/svn/ff-luci/$(PKG_BRANCH)
+  PKG_SOURCE_URL:=http://svn.luci.subsignal.org/luci/$(PKG_BRANCH)
   ifeq ($(DUMP),)
     PKG_REV:=HEAD
     PKG_VERSION:=0.8.1
@@ -428,6 +428,16 @@ define Package/luci-app-initmgr/install
         $(call Package/luci/install/template,$(1),applications/luci-initmgr)
 endef
 
+#define Package/luci-app-polipo
+#  $(call Package/luci/webtemplate)
+#  TITLE:=LuCI Support for the Polipo Proxy
+#  DEPENDS+=+luci-admin-core +polipo
+#endef
+
+#define Package/luci-app-polipo/install
+#        $(call Package/luci/install/template,$(1),applications/luci-polipo)
+#endef
+
 
 ### Server Gateway Interfaces ###
 
@@ -442,9 +452,20 @@ endef
 
 
 ### Themes ###
+#define Package/luci-theme-base
+#  $(call Package/luci/thtemplate)
+#  DEPENDS:=+luci-web
+#  TITLE:=Common base for all themes
+#endef
+#
+#define Package/luci-theme-base/install
+#      $(call Package/luci/install/template,$(1),themes/base)
+#endef
+
 define Package/luci-theme-openwrt
   $(call Package/luci/thtemplate)
-  TITLE:=OpenWRT.org (default)
+  TITLE:=OpenWrt.org (default)
+# DEPENDS:=+luci-theme-base
 endef
 
 define Package/luci-theme-openwrt/install
@@ -453,7 +474,8 @@ endef
 
 define Package/luci-theme-openwrtlight
   $(call Package/luci/thtemplate)
-  TITLE:=OpenWRT.org - light variant without images
+  TITLE:=OpenWrt.org - light variant without images
+# DEPENDS:=+luci-theme-base
 endef
 
 define Package/luci-theme-openwrtlight/install
@@ -600,12 +622,19 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-initmgr),)
        PKG_SELECTED_MODULES+=applications/luci-initmgr
 endif
+#ifneq ($(CONFIG_PACKAGE_luci-app-polipo),)
+#       PKG_SELECTED_MODULES+=applications/luci-polipo
+#endif
 
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
        PKG_SELECTED_MODULES+=libs/sgi-cgi
 endif
 
+
+#ifneq ($(CONFIG_PACKAGE_luci-theme-base),)
+#      PKG_SELECTED_MODULES+=themes/base
+#endif
 ifneq ($(CONFIG_PACKAGE_luci-theme-openwrt),)
        PKG_SELECTED_MODULES+=themes/openwrt.org
 endif
@@ -669,9 +698,11 @@ $(eval $(call BuildPackage,luci-app-ushare))
 $(eval $(call BuildPackage,luci-app-hd_idle))
 $(eval $(call BuildPackage,luci-app-tinyproxy))
 $(eval $(call BuildPackage,luci-app-initmgr))
+#$(eval $(call BuildPackage,luci-app-polipo))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
 
+#$(eval $(call BuildPackage,luci-theme-base))
 $(eval $(call BuildPackage,luci-theme-openwrt))
 $(eval $(call BuildPackage,luci-theme-openwrtlight))