* luci-0.8: merge r3724, r3725
[project/luci.git] / contrib / package / luci / Makefile
index 9c1fba2..9ae6f57 100644 (file)
@@ -1,6 +1,6 @@
 include $(TOPDIR)/rules.mk
 
-PKG_BRANCH:=branches/luci-0.8
+PKG_BRANCH:=tags/0.8.1
 
 ifeq ($(DUMP),)
   USELOCAL:=$(shell grep luci ../../../.project 2>/dev/null >/dev/null && echo 1)
@@ -12,10 +12,10 @@ PKG_RELEASE:=1
 ifeq ($(USELOCAL),1)
   PKG_VERSION:=0.8+svn
 else
-  PKG_SOURCE_URL:=http://dev.leipzig.freifunk.net/svn/ff-luci/$(PKG_BRANCH)
+  PKG_SOURCE_URL:=http://svn.luci.subsignal.org/luci/$(PKG_BRANCH)
   ifeq ($(DUMP),)
-    PKG_REV:=$(shell LC_ALL=C svn info ${PKG_SOURCE_URL} | sed -ne's/^Last Changed Rev: //p')
-    PKG_VERSION:=0.8+svn$(PKG_REV)
+    PKG_REV:=HEAD
+    PKG_VERSION:=0.8.1
   endif
   PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
   PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
@@ -88,7 +88,7 @@ endef
 
 define Package/luci-core
   $(call Package/luci/libtemplate)
-  DEPENDS:=+lua +luaposix +bitlib
+  DEPENDS:=+lua
   TITLE:=LuCI core libraries
 endef
 
@@ -197,7 +197,7 @@ endef
 
 define Package/luci-web
   $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-http +luci-sys +luci-addons +luci-uci +luci-sgi-cgi
+  DEPENDS+=+luci-http +luci-sys +luci-uci +luci-sgi-cgi
   TITLE:=MVC Webframework
 endef
 
@@ -229,6 +229,11 @@ define Package/luci-admin-core
   TITLE:=Web UI Core Module
 endef
 
+define Package/luci-admin-core/conffiles
+/etc/config/luci_hosts
+/etc/config/luci_ethers
+endef
+
 define Package/luci-admin-core/install
        $(call Package/luci/install/template,$(1),modules/admin-core)
 endef
@@ -372,6 +377,67 @@ define Package/luci-app-uvc_streamer/install
 endef
 
 
+define Package/luci-app-p910nd
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +p910nd
+  TITLE:=p910nd - Printer server module
+endef
+
+define Package/luci-app-p910nd/install
+        $(call Package/luci/install/template,$(1),applications/luci-p910nd)
+endef
+
+
+define Package/luci-app-ushare
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +ushare
+  TITLE:=ushare - UPnP A/V & DLNA Media Server
+endef
+
+define Package/luci-app-ushare/install
+        $(call Package/luci/install/template,$(1),applications/luci-ushare)
+endef
+
+define Package/luci-app-hd_idle
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +hd-idle
+  TITLE:=hd-idle
+endef
+
+define Package/luci-app-hd_idle/install
+        $(call Package/luci/install/template,$(1),applications/luci-hd_idle)
+endef
+
+define Package/luci-app-tinyproxy
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full +tinyproxy
+  TITLE:=Tinyproxy - HTTP(S)-Proxy
+endef
+
+define Package/luci-app-tinyproxy/install
+        $(call Package/luci/install/template,$(1),applications/luci-tinyproxy)
+endef
+
+define Package/luci-app-initmgr
+  $(call Package/luci/webtemplate)
+  DEPENDS+=+luci-admin-full
+  TITLE:=LuCI Initscript Management
+endef
+
+define Package/luci-app-initmgr/install
+        $(call Package/luci/install/template,$(1),applications/luci-initmgr)
+endef
+
+#define Package/luci-app-polipo
+#  $(call Package/luci/webtemplate)
+#  TITLE:=LuCI Support for the Polipo Proxy
+#  DEPENDS+=+luci-admin-core +polipo
+#endef
+
+#define Package/luci-app-polipo/install
+#        $(call Package/luci/install/template,$(1),applications/luci-polipo)
+#endef
+
 
 ### Server Gateway Interfaces ###
 
@@ -386,9 +452,20 @@ endef
 
 
 ### Themes ###
+#define Package/luci-theme-base
+#  $(call Package/luci/thtemplate)
+#  DEPENDS:=+luci-web
+#  TITLE:=Common base for all themes
+#endef
+#
+#define Package/luci-theme-base/install
+#      $(call Package/luci/install/template,$(1),themes/base)
+#endef
+
 define Package/luci-theme-openwrt
   $(call Package/luci/thtemplate)
-  TITLE:=OpenWRT.org (default)
+  TITLE:=OpenWrt.org (default)
+# DEPENDS:=+luci-theme-base
 endef
 
 define Package/luci-theme-openwrt/install
@@ -397,7 +474,8 @@ endef
 
 define Package/luci-theme-openwrtlight
   $(call Package/luci/thtemplate)
-  TITLE:=OpenWRT.org - light variant without images
+  TITLE:=OpenWrt.org - light variant without images
+# DEPENDS:=+luci-theme-base
 endef
 
 define Package/luci-theme-openwrtlight/install
@@ -446,6 +524,16 @@ define Package/luci-i18n-russian/install
 endef
 
 
+define Package/luci-i18n-portuguese_brazilian
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Portuguese (Brazilian) (by Carlos Cesario)
+endef
+
+define Package/luci-i18n-portuguese_brazilian/install
+       $(call Package/luci/install/template,$(1),i18n/portuguese_brazilian)
+endef
+
+
 
 ### Compile ###
 ifneq ($(CONFIG_PACKAGE_luci-core),)
@@ -519,12 +607,34 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-uvc_streamer),)
        PKG_SELECTED_MODULES+=applications/luci-uvc_streamer
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-p910nd),)
+        PKG_SELECTED_MODULES+=applications/luci-p910nd
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-ushare),)
+        PKG_SELECTED_MODULES+=applications/luci-ushare
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-hd_idle),)
+       PKG_SELECTED_MODULES+=applications/luci-hd_idle
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-tinyproxy),)
+       PKG_SELECTED_MODULES+=applications/luci-tinyproxy
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-initmgr),)
+       PKG_SELECTED_MODULES+=applications/luci-initmgr
+endif
+#ifneq ($(CONFIG_PACKAGE_luci-app-polipo),)
+#       PKG_SELECTED_MODULES+=applications/luci-polipo
+#endif
 
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
        PKG_SELECTED_MODULES+=libs/sgi-cgi
 endif
 
+
+#ifneq ($(CONFIG_PACKAGE_luci-theme-base),)
+#      PKG_SELECTED_MODULES+=themes/base
+#endif
 ifneq ($(CONFIG_PACKAGE_luci-theme-openwrt),)
        PKG_SELECTED_MODULES+=themes/openwrt.org
 endif
@@ -544,6 +654,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-russian),)
        PKG_SELECTED_MODULES+=i18n/russian
 endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-portuguese_brazilian),)
+       PKG_SELECTED_MODULES+=i18n/portuguese_brazilian
+endif
 
 
 MAKE_FLAGS += \
@@ -580,9 +693,16 @@ $(eval $(call BuildPackage,luci-app-ntpc))
 $(eval $(call BuildPackage,luci-app-ddns))
 $(eval $(call BuildPackage,luci-app-samba))
 $(eval $(call BuildPackage,luci-app-uvc_streamer))
+$(eval $(call BuildPackage,luci-app-p910nd))
+$(eval $(call BuildPackage,luci-app-ushare))
+$(eval $(call BuildPackage,luci-app-hd_idle))
+$(eval $(call BuildPackage,luci-app-tinyproxy))
+$(eval $(call BuildPackage,luci-app-initmgr))
+#$(eval $(call BuildPackage,luci-app-polipo))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
 
+#$(eval $(call BuildPackage,luci-theme-base))
 $(eval $(call BuildPackage,luci-theme-openwrt))
 $(eval $(call BuildPackage,luci-theme-openwrtlight))
 
@@ -590,3 +710,4 @@ $(eval $(call BuildPackage,luci-i18n-german))
 $(eval $(call BuildPackage,luci-i18n-english))
 $(eval $(call BuildPackage,luci-i18n-french))
 $(eval $(call BuildPackage,luci-i18n-russian))
+$(eval $(call BuildPackage,luci-i18n-portuguese_brazilian))