contrib/package: drop build dependency for libnotimpl, obsoleted by recent uclibc...
[project/luci.git] / contrib / package / luci / Makefile
index 2e7e7a5..872f0cc 100644 (file)
@@ -26,7 +26,6 @@ endif
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-PKG_BUILD_DEPENDS:=libnotimpl
 LUA_TARGET:=source
 PKG_SELECTED_MODULES:=
 
@@ -266,6 +265,10 @@ define Package/luci-nixio/config
                        select PACKAGE_dropbear
                        select PACKAGE_dropbearconvert
 
+               config PACKAGE_luci-nixio_cyassl
+                       bool "CyaSSL"
+                       select PACKAGE_libcyassl-luci
+
                config PACKAGE_luci-nixio_openssl
                        bool "OpenSSL"
                        select PACKAGE_libopenssl
@@ -276,6 +279,9 @@ ifneq ($(CONFIG_PACKAGE_luci-nixio_openssl),)
   NIXIO_TLS:=openssl
 endif
 
+ifneq ($(CONFIG_PACKAGE_luci-nixio_cyassl),)
+  NIXIO_TLS:=cyassl
+endif
 
 define Package/luci-sys
   $(call Package/luci/libtemplate)