contrib: prepare for renaming of firewall3 in OpenWrt
[project/luci.git] / contrib / package / luci / Makefile
index ca68735..6be79a9 100644 (file)
@@ -1,32 +1,16 @@
 include $(TOPDIR)/rules.mk
 
-PKG_BRANCH:=trunk
-
-ifeq ($(DUMP),)
-  USELOCAL:=$(shell grep luci ../../../.project 2>/dev/null >/dev/null && echo 1)
-endif
+LUCI_TOPDIR=../../..
 
 PKG_NAME:=luci
 PKG_RELEASE:=1
 
 PKG_BUILD_PARALLEL:=0
 
-ifeq ($(USELOCAL),1)
-  PKG_VERSION:=trunk+svn
-else
-  PKG_SOURCE_URL:=http://svn.luci.subsignal.org/luci/$(PKG_BRANCH)
-  ifeq ($(DUMP),)
-    PKG_REV:=$(shell LC_ALL=C svn info $(CURDIR) | sed -ne's/^Revision: //p')
-    PKG_VERSION:=trunk+svn$(PKG_REV)
-  endif
-  PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-  PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
-  PKG_SOURCE_PROTO:=svn
-  PKG_SOURCE_VERSION:=$(PKG_REV)
-endif
+PKG_VERSION:=$(shell $(LUCI_TOPDIR)/build/mkrevision.sh 2>/dev/null || echo unknown)
 
 PKG_BUILD_DEPENDS:=$(if $(STAGING_DIR_ROOT),lua/host)
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 LUA_TARGET:=source
@@ -63,7 +47,7 @@ define Package/luci-lib-core/install
        $(PKG_BUILD_DIR)/build/mkversion.sh $(1)/usr/lib/lua/luci/version.lua \
                "OpenWrt Firmware" \
                "$(OPENWRTVERSION)" \
-               "$(PKG_BRANCH)" \
+               "trunk" \
                "$(PKG_VERSION)"
 endef
 
@@ -177,14 +161,13 @@ $(eval $(call library,fastindex,Fastindex indexing module,+PACKAGE_luci-lib-fast
 $(eval $(call library,httpclient,HTTP(S) client library,+luci-lib-web +luci-lib-nixio))
 $(eval $(call library,ipkg,LuCI IPKG/OPKG call abstraction library))
 $(eval $(call library,json,LuCI JSON library))
-$(eval $(call library,lmo,LuCI LMO I18N library))
 $(eval $(call library,lucid,LuCId Full-Stack Webserver,+luci-lib-nixio +luci-lib-web +luci-lib-px5g))
 $(eval $(call library,lucid-http,LuCId HTTP Backend,+luci-lib-lucid))
 $(eval $(call library,lucid-rpc,LuCId RPC Backend,+luci-lib-lucid))
 $(eval $(call library,nixio,NIXIO POSIX library,+PACKAGE_luci-lib-nixio_openssl:libopenssl +PACKAGE_luci-lib-nixio_cyassl:libcyassl))
 $(eval $(call library,px5g,RSA/X.509 Key Generator (required for LuCId SSL support),+luci-lib-nixio))
 $(eval $(call library,sys,LuCI Linux/POSIX system library))
-$(eval $(call library,web,MVC Webframework,+luci-lib-sys +luci-lib-nixio +luci-lib-core +luci-sgi-cgi +luci-lib-lmo))
+$(eval $(call library,web,MVC Webframework,+luci-lib-sys +luci-lib-nixio +luci-lib-core +luci-sgi-cgi))
 
 
 ### Protocols ###
@@ -213,7 +196,7 @@ endef
 
 $(eval $(call protocol,core,Support for static/dhcp/none))
 $(eval $(call protocol,ppp,Support for PPP/PPPoE/PPPoA/PPtP))
-$(eval $(call protocol,6x4,Support for 6in4/6to4/6rd,+PACKAGE_luci-proto-6x4:6in4 +PACKAGE_luci-proto-6x4:6to4 +PACKAGE_luci-proto-6x4:6rd))
+$(eval $(call protocol,ipv6,Support for DHCPv6/6in4/6to4/6rd/DS-Lite))
 $(eval $(call protocol,3g,Support for 3G,+PACKAGE_luci-proto-3g:comgt))
 $(eval $(call protocol,relay,Support for relayd pseudo bridges,+PACKAGE_luci-proto-relay:relayd))
 
@@ -282,7 +265,7 @@ $(eval $(call module,admin-mini,LuCI Essentials - stripped down and user-friendl
 $(eval $(call module,admin-full,LuCI Administration - full-featured for full control,+luci-mod-admin-core +luci-lib-ipkg))
 $(eval $(call module,failsafe,LuCI Fail-Safe - Fail-Safe sysupgrade module,+luci-mod-admin-core))
 $(eval $(call module,rpc,LuCI RPC - JSON-RPC API,+luci-lib-json))
-$(eval $(call module,freifunk,LuCI Freifunk module,+luci-mod-admin-full +luci-lib-json +PACKAGE_luci-mod-freifunk:freifunk-firewall +freifunk-common +community-profiles))
+$(eval $(call module,freifunk,LuCI Freifunk module,+luci-mod-admin-full +luci-lib-json +PACKAGE_luci-mod-freifunk:freifunk-firewall +freifunk-common))
 $(eval $(call module,niu,NIU - Next Generation Interface,+luci-mod-admin-core @BROKEN))
 
 
@@ -327,7 +310,7 @@ endef
 $(eval $(call application,siitwizard,SIIT IPv4-over-IPv6 configuration wizard,\
        +PACKAGE_luci-app-siitwizard:kmod-siit))
 
-$(eval $(call application,firewall,Firmware and Portforwarding application,\
+$(eval $(call application,firewall,Firewall and Portforwarding application,\
        +PACKAGE_luci-app-firewall:firewall))
 
 $(eval $(call application,freifunk-policyrouting,Policy routing for mesh traffic,\
@@ -340,11 +323,13 @@ $(eval $(call application,meshwizard, Shellscript based wizard to setup mesh net
         +PACKAGE_luci-app-freifunk-meshwizard:meshwizard))
 
 $(eval $(call application,olsr,OLSR configuration and status module,\
-       +olsrd-mod-txtinfo))
+       +olsrd +olsrd-mod-jsoninfo))
 
 $(eval $(call application,olsr-viz,OLSR Visualisation,\
        luci-app-olsr +olsrd-mod-txtinfo))
 
+$(eval $(call application,freifunk-diagnostics,Tools for network diagnosis like traceroute and ping))
+
 $(eval $(call application,olsr-services,Show services announced with the nameservice plugin,\
        luci-app-olsr +olsrd-mod-nameservice))
 
@@ -447,10 +432,16 @@ $(eval $(call application,pbx,LuCI PBX Administration,\
        +PACKAGE_luci-app-pbx:asterisk18-codec-a-mu \
        +PACKAGE_luci-app-pbx:asterisk18-codec-alaw \
        +PACKAGE_luci-app-pbx:asterisk18-func-cut \
-       +PACKAGE_luci-app-pbx:asterisk18-res-clioriginate))
+       +PACKAGE_luci-app-pbx:asterisk18-res-clioriginate \
+       +PACKAGE_luci-app-pbx:asterisk18-func-channel \
+       +PACKAGE_luci-app-pbx:asterisk18-chan-local \
+       +PACKAGE_luci-app-pbx:asterisk18-app-record \
+       +PACKAGE_luci-app-pbx:asterisk18-app-senddtmf \
+       +PACKAGE_luci-app-pbx:asterisk18-res-crypto))
 
 $(eval $(call application,pbx-voicemail,LuCI PBX Administration Voicemail Support,\
-       luci-app-pbx +PACKAGE_luci-app-pbx-voicemail:msmtp))
+       luci-app-pbx +PACKAGE_luci-app-pbx-voicemail:msmtp \
+       +PACKAGE_luci-app-pbx-voicemail:coreutils-base64))
 
 $(eval $(call application,ltqtapi,Lantiq voip))
 
@@ -517,8 +508,8 @@ define theme
 endef
 
 $(eval $(call theme,base,Common base for all themes))
-$(eval $(call theme,openwrt,OpenWrt.org (default),,,1))
-$(eval $(call theme,bootstrap,Bootstrap Theme))
+$(eval $(call theme,openwrt,OpenWrt.org))
+$(eval $(call theme,bootstrap,Bootstrap Theme (default),,,1))
 
 $(eval $(call theme,freifunk-bno,Freifunk Berlin Nordost Theme,\
        Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>))
@@ -594,12 +585,12 @@ endef
 $(eval $(call collection,,\
        Standard OpenWrt set including full admin with ppp support and the \
        default OpenWrt theme,\
-       +uhttpd +luci-mod-admin-full +luci-theme-openwrt +luci-app-firewall \
-       +luci-proto-core +luci-proto-ppp +libiwinfo-lua))
+       +uhttpd +uhttpd-mod-ubus +luci-mod-admin-full +luci-theme-bootstrap \
+       +luci-app-firewall +luci-proto-core +luci-proto-ppp +libiwinfo-lua))
 
 $(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\
-       +luci +uhttpd-mod-tls +px5g))
+       +luci +libustream-cyassl +px5g))
 
 $(eval $(call collection,light,\
        Minimum package set using only admin mini and the standard theme,\
@@ -611,16 +602,20 @@ PKG_CONFIG_DEPENDS=$(patsubst %,CONFIG_PACKAGE_%,$(LUCI_BUILD_PACKAGES))
 
 include $(INCLUDE_DIR)/package.mk
 
-ifeq ($(USELOCAL),1)
-  define Build/Prepare
+define Build/Prepare
+       @if [ ! -x $(LUCI_TOPDIR)/build/mkrevision.sh ]; then \
+               echo "*** Repository layout changed!" >&2; \
+               echo "*** Please change the LuCI url in feeds.conf to http://svn.luci.subsignal.org/luci/trunk and reinstall the feed with" >&2; \
+               echo "*** ./scripts/feeds update luci; ./scripts/feeds install -a -p luci" >&2; \
+               exit 1; \
+       fi
        mkdir -p $(PKG_BUILD_DIR)
-       $(TAR) c -C ../../../ . \
+       $(TAR) c -C $(LUCI_TOPDIR) . \
                --exclude=.pc --exclude=.svn --exclude=.git \
                --exclude='boa-0*' --exclude='*.o' --exclude='*.so' \
                --exclude=dist | \
                        tar x -C $(PKG_BUILD_DIR)/
-  endef
-endif
+endef
 
 define Build/Configure
 endef