contrib: prefer libustream-polarssl for luci-ssl (#677)
[project/luci.git] / contrib / package / luci / Makefile
index ebec815..64abf69 100644 (file)
@@ -12,6 +12,7 @@ PKG_VERSION:=$(shell $(LUCI_TOPDIR)/build/mkrevision.sh 2>/dev/null || echo unkn
 PKG_BUILD_DEPENDS:=$(if $(STAGING_DIR_ROOT),lua/host)
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_USE_MIPS16:=0
 
 LUA_TARGET:=source
 LUCI_CFLAGS:=
@@ -168,6 +169,7 @@ $(eval $(call library,nixio,NIXIO POSIX library,+PACKAGE_luci-lib-nixio_openssl:
 $(eval $(call library,px5g,RSA/X.509 Key Generator (required for LuCId SSL support),+luci-lib-nixio))
 $(eval $(call library,sys,LuCI Linux/POSIX system library))
 $(eval $(call library,web,MVC Webframework,+luci-lib-sys +luci-lib-nixio +luci-lib-core +luci-sgi-cgi))
+$(eval $(call library,luaneightbl,neightbl - Lua lib for IPv6 neighbors,+luci-lib-core))
 
 
 ### Protocols ###
@@ -196,7 +198,7 @@ endef
 
 $(eval $(call protocol,core,Support for static/dhcp/none))
 $(eval $(call protocol,ppp,Support for PPP/PPPoE/PPPoA/PPtP))
-$(eval $(call protocol,ipv6,Support for DHCPv6/6in4/6to4/6rd,+PACKAGE_luci-proto-ipv6:6in4 +PACKAGE_luci-proto-ipv6:6to4 +PACKAGE_luci-proto-ipv6:6rd +PACKAGE_luci-proto-ipv6:ipv6-support))
+$(eval $(call protocol,ipv6,Support for DHCPv6/6in4/6to4/6rd/DS-Lite))
 $(eval $(call protocol,3g,Support for 3G,+PACKAGE_luci-proto-3g:comgt))
 $(eval $(call protocol,relay,Support for relayd pseudo bridges,+PACKAGE_luci-proto-relay:relayd))
 
@@ -213,7 +215,7 @@ define Package/luci-mod-freifunk-community
   DEPENDS+= \
    +luci-lib-web +luci-app-splash +luci-i18n-german \
    +PACKAGE_luci-mod-freifunk-community:olsrd +PACKAGE_luci-mod-freifunk-community:olsrd-mod-dyn-gw-plain \
-   +PACKAGE_luci-mod-freifunk-community:olsrd-mod-txtinfo +PACKAGE_luci-mod-freifunk-community:olsrd-mod-nameservice \
+   +PACKAGE_luci-mod-freifunk-community:olsrd-mod-jsoninfo +PACKAGE_luci-mod-freifunk-community:olsrd-mod-nameservice \
    +PACKAGE_luci-mod-freifunk-community:olsrd-mod-watchdog +PACKAGE_luci-mod-freifunk-community:kmod-tun \
    +PACKAGE_luci-mod-freifunk-community:ip +PACKAGE_luci-mod-freifunk-community:freifunk-watchdog +luci-app-olsr \
    +luci-app-olsr-services +freifunk-gwcheck +freifunk-mapupdate
@@ -265,7 +267,7 @@ $(eval $(call module,admin-mini,LuCI Essentials - stripped down and user-friendl
 $(eval $(call module,admin-full,LuCI Administration - full-featured for full control,+luci-mod-admin-core +luci-lib-ipkg))
 $(eval $(call module,failsafe,LuCI Fail-Safe - Fail-Safe sysupgrade module,+luci-mod-admin-core))
 $(eval $(call module,rpc,LuCI RPC - JSON-RPC API,+luci-lib-json))
-$(eval $(call module,freifunk,LuCI Freifunk module,+luci-mod-admin-full +luci-lib-json +PACKAGE_luci-mod-freifunk:freifunk-firewall +freifunk-common +community-profiles))
+$(eval $(call module,freifunk,LuCI Freifunk module,+luci-mod-admin-full +luci-lib-json +PACKAGE_luci-mod-freifunk:freifunk-firewall +freifunk-common))
 $(eval $(call module,niu,NIU - Next Generation Interface,+luci-mod-admin-core @BROKEN))
 
 
@@ -296,6 +298,7 @@ endef
 define Package/luci-app-splash/conffiles
 /etc/config/luci_splash
 /usr/lib/luci-splash/splashtext.html
+/usr/lib/luci-splash/splashtextinclude.html
 endef
 
 define Package/luci-app-statistics/conffiles
@@ -311,7 +314,7 @@ $(eval $(call application,siitwizard,SIIT IPv4-over-IPv6 configuration wizard,\
        +PACKAGE_luci-app-siitwizard:kmod-siit))
 
 $(eval $(call application,firewall,Firewall and Portforwarding application,\
-       +PACKAGE_luci-app-firewall:firewall3))
+       +PACKAGE_luci-app-firewall:firewall))
 
 $(eval $(call application,freifunk-policyrouting,Policy routing for mesh traffic,\
         +PACKAGE_luci-app-freifunk-policyrouting:freifunk-policyrouting))
@@ -323,7 +326,7 @@ $(eval $(call application,meshwizard, Shellscript based wizard to setup mesh net
         +PACKAGE_luci-app-freifunk-meshwizard:meshwizard))
 
 $(eval $(call application,olsr,OLSR configuration and status module,\
-       +olsrd +olsrd-mod-jsoninfo))
+       +olsrd +olsrd-mod-jsoninfo +luci-lib-luaneightbl))
 
 $(eval $(call application,olsr-viz,OLSR Visualisation,\
        luci-app-olsr +olsrd-mod-txtinfo))
@@ -590,7 +593,7 @@ $(eval $(call collection,,\
 
 $(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\
-       +luci +libustream-cyassl +px5g))
+       +luci +libustream-polarssl +px5g))
 
 $(eval $(call collection,light,\
        Minimum package set using only admin mini and the standard theme,\
@@ -615,6 +618,7 @@ define Build/Prepare
                --exclude='boa-0*' --exclude='*.o' --exclude='*.so' \
                --exclude=dist | \
                        tar x -C $(PKG_BUILD_DIR)/
+       $(call Build/Prepare/Default)
 endef
 
 define Build/Configure