modules/admin-full: rework luci-bwc/libiwinfo integration
[project/luci.git] / contrib / package / luci / Makefile
index b875f0d..5ee13d4 100644 (file)
@@ -9,7 +9,7 @@ PKG_BUILD_PARALLEL:=0
 
 PKG_VERSION:=$(shell $(LUCI_TOPDIR)/build/mkrevision.sh 2>/dev/null || echo unknown)
 
 
 PKG_VERSION:=$(shell $(LUCI_TOPDIR)/build/mkrevision.sh 2>/dev/null || echo unknown)
 
-PKG_BUILD_DEPENDS:=$(if $(STAGING_DIR_ROOT),lua/host)
+PKG_BUILD_DEPENDS:=$(if $(STAGING_DIR_ROOT),lua/host) iwinfo
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 PKG_USE_MIPS16:=0
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 PKG_USE_MIPS16:=0
@@ -270,9 +270,7 @@ define theme
     URL:=http://luci.subsignal.org/
     SUBMENU:=4. Themes
     TITLE:=$(if $(2),$(2),LuCI $(1) theme)
     URL:=http://luci.subsignal.org/
     SUBMENU:=4. Themes
     TITLE:=$(if $(2),$(2),LuCI $(1) theme)
-       MAINTAINER:=$(if $(3),$(3),LuCI Development Team <luci@lists.subsignal.org>)
-       DEPENDS:=+luci-base $(4)
-       $(if $(5),DEFAULT:=PACKAGE_luci-base)
+    MAINTAINER:=$(if $(3),$(3),LuCI Development Team <luci@lists.subsignal.org>)
   endef
 
   define Package/luci-theme-$(1)/install
   endef
 
   define Package/luci-theme-$(1)/install
@@ -287,7 +285,7 @@ define theme
 endef
 
 $(eval $(call theme,openwrt,OpenWrt.org))
 endef
 
 $(eval $(call theme,openwrt,OpenWrt.org))
-$(eval $(call theme,bootstrap,Bootstrap Theme (default),,,1))
+$(eval $(call theme,bootstrap,Bootstrap Theme (default)))
 
 
 ### Translations ###
 
 
 ### Translations ###
@@ -359,7 +357,7 @@ $(eval $(call collection,,\
        Standard OpenWrt set including full admin with ppp support and the \
        default OpenWrt theme,\
        +uhttpd +uhttpd-mod-ubus +luci-mod-admin-full +luci-theme-bootstrap \
        Standard OpenWrt set including full admin with ppp support and the \
        default OpenWrt theme,\
        +uhttpd +uhttpd-mod-ubus +luci-mod-admin-full +luci-theme-bootstrap \
-       +luci-app-firewall +luci-proto-ppp +libiwinfo-lua))
+       +luci-app-firewall +luci-proto-ppp +libiwinfo-lua +luci-lib-nixio))
 
 $(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\
 
 $(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\