libs: merge libs/cbi into libs/web
[project/luci.git] / contrib / package / luci / Makefile
index 6229646..4fe804b 100644 (file)
@@ -10,12 +10,12 @@ PKG_NAME:=luci
 PKG_RELEASE:=1
 
 ifeq ($(USELOCAL),1)
-  PKG_VERSION:=0.9+svn
+  PKG_VERSION:=0.10+svn
 else
   PKG_SOURCE_URL:=http://svn.luci.subsignal.org/luci/$(PKG_BRANCH)
   ifeq ($(DUMP),)
     PKG_REV:=$(shell LC_ALL=C svn info $(CURDIR) | sed -ne's/^Revision: //p')
-    PKG_VERSION:=0.9+svn$(PKG_REV)
+    PKG_VERSION:=0.10+svn$(PKG_REV)
   endif
   PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
   PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
@@ -158,17 +158,6 @@ endif
 
 
 ### Libraries ###
-define Package/luci-cbi
-  $(call Package/luci/libtemplate)
-  DEPENDS+=+luci-web +luci-uvl +luci-uci
-  TITLE:=Configuration Binding Interface
-endef
-
-define Package/luci-cbi/install
-       $(call Package/luci/install/template,$(1),libs/cbi)
-endef
-
-
 define Package/luci-uci
   $(call Package/luci/libtemplate)
   DEPENDS+=+libuci-lua
@@ -396,7 +385,7 @@ endef
 
 define Package/luci-admin-core
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-web +luci-cbi +luci-i18n-english
+  DEPENDS+=+luci-web +luci-i18n-english
   TITLE:=Web UI Core Module
 endef
 
@@ -767,6 +756,38 @@ define Package/luci-app-p2pblock/install
         $(call Package/luci/install/template,$(1),applications/luci-p2pblock)
 endef
 
+define Package/luci-app-multiwan
+  $(call Package/luci/webtemplate)
+  TITLE:=LuCI Support for the OpenWrt MultiWAN agent
+  DEPENDS+=+luci-admin-core +luci-app-firewall \
+    +PACKAGE_luci-app-multiwan:multiwan
+endef
+
+define Package/luci-app-multiwan/install
+        $(call Package/luci/install/template,$(1),applications/luci-multiwan)
+endef
+
+define Package/luci-app-wol
+  $(call Package/luci/webtemplate)
+  TITLE:=LuCI Support for Wake-on-LAN
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-wol:etherwake
+endef
+
+define Package/luci-app-wol/install
+        $(call Package/luci/install/template,$(1),applications/luci-wol)
+endef
+
+define Package/luci-app-vnstat
+  $(call Package/luci/webtemplate)
+  TITLE:=LuCI Support for VnStat
+  DEPENDS+=+luci-admin-core +PACKAGE_luci-app-vnstat:vnstat \
+    +PACKAGE_luci-app-vnstat:vnstati
+endef
+
+define Package/luci-app-vnstat/install
+        $(call Package/luci/install/template,$(1),applications/luci-vnstat)
+endef
+
 
 ### Server Gateway Interfaces ###
 
@@ -780,7 +801,7 @@ define Package/luci-sgi-cgi/install
 endef
 
 define Package/luci-sgi-uhttpd
-  $(call Package/luci/webservertemplate)
+  $(call Package/luci/libtemplate)
   TITLE:=Binding for the uHTTPd server
   DEPENDS+=+uhttpd +uhttpd-mod-lua
 endef
@@ -986,12 +1007,22 @@ define Package/luci-i18n-vietnamese/install
        $(call Package/luci/install/template,$(1),i18n/vietnamese)
 endef
 
+define Package/luci-i18n-malay
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Malay (by Teow Wai Chet)
+endef
+
+define Package/luci-i18n-malay/install
+       $(call Package/luci/install/template,$(1),i18n/malay)
+endef
+
 
 ### Collections ###
 define Package/luci
   $(call Package/luci/collectiontemplate)
-  TITLE:=Standard OpenWrt Kamikaze set including full and mini admin and the standard theme
-  DEPENDS:=+luci-admin-full +luci-admin-mini +luci-theme-openwrt +luci-app-firewall +luci-app-initmgr
+  TITLE:=Standard OpenWrt set including full and mini admin and the standard theme
+  DEPENDS:=+uhttpd +luci-admin-full +luci-admin-mini +luci-theme-openwrt \
+    +luci-app-firewall +luci-app-initmgr
 endef
 
 define Package/luci/install
@@ -999,10 +1030,33 @@ define Package/luci/install
 endef
 
 
+define Package/luci-ssl
+  $(call Package/luci/collectiontemplate)
+  TITLE:=Standard OpenWrt set with https support
+  DEPENDS:=+uhttpd +uhttpd-mod-tls +px5g +luci-admin-full +luci-admin-mini \
+    +luci-theme-openwrt +luci-app-firewall +luci-app-initmgr
+endef
+
+define Package/luci-ssl/install
+       true
+endef
+
+
+define Package/luci-medium
+  $(call Package/luci/collectiontemplate)
+  TITLE:=Medium package set using only admin full and a theme without graphics
+  DEPENDS:=+uhttpd +luci-admin-full +luci-theme-openwrtlight
+endef
+
+define Package/luci-medium/install
+       true
+endef
+
+
 define Package/luci-light
   $(call Package/luci/collectiontemplate)
-  TITLE:=Minimum package set using only admin mini and a theme without grafics
-  DEPENDS:=+luci-admin-mini +luci-theme-openwrtlight
+  TITLE:=Minimum package set using only admin mini and a theme without graphics
+  DEPENDS:=+uhttpd +luci-admin-mini +luci-theme-openwrtlight
 endef
 
 define Package/luci-light/install
@@ -1014,9 +1068,6 @@ endef
 ifneq ($(CONFIG_PACKAGE_luci-core),)
        PKG_SELECTED_MODULES+=libs/core
 endif
-ifneq ($(CONFIG_PACKAGE_luci-cbi),)
-       PKG_SELECTED_MODULES+=libs/cbi
-endif
 ifneq ($(CONFIG_PACKAGE_luci-fastindex),)
        PKG_SELECTED_MODULES+=libs/fastindex
 endif
@@ -1164,6 +1215,15 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-app-p2pblock),)
        PKG_SELECTED_MODULES+=applications/luci-p2pblock
 endif
+ifneq ($(CONFIG_PACKAGE_luci-app-multiwan),)
+       PKG_SELECTED_MODULES+=applications/luci-multiwan
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-wol),)
+       PKG_SELECTED_MODULES+=applications/luci-wol
+endif
+ifneq ($(CONFIG_PACKAGE_luci-app-vnstat),)
+       PKG_SELECTED_MODULES+=applications/luci-vnstat
+endif
 
 
 ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
@@ -1234,6 +1294,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-vietnamese),)
        PKG_SELECTED_MODULES+=i18n/vietnamese
 endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-malay),)
+       PKG_SELECTED_MODULES+=i18n/malay
+endif
 
 
 MAKE_FLAGS += \
@@ -1246,7 +1309,6 @@ MAKE_FLAGS += \
 
 
 $(eval $(call BuildPackage,luci-core))
-$(eval $(call BuildPackage,luci-cbi))
 $(eval $(call BuildPackage,luci-fastindex))
 $(eval $(call BuildPackage,luci-http))
 $(eval $(call BuildPackage,luci-httpclient))
@@ -1298,6 +1360,9 @@ $(eval $(call BuildPackage,luci-app-asterisk))
 $(eval $(call BuildPackage,luci-app-polipo))
 $(eval $(call BuildPackage,luci-app-openvpn))
 $(eval $(call BuildPackage,luci-app-p2pblock))
+$(eval $(call BuildPackage,luci-app-multiwan))
+$(eval $(call BuildPackage,luci-app-wol))
+$(eval $(call BuildPackage,luci-app-vnstat))
 
 $(eval $(call BuildPackage,luci-sgi-cgi))
 $(eval $(call BuildPackage,luci-sgi-uhttpd))
@@ -1322,6 +1387,9 @@ $(eval $(call BuildPackage,luci-i18n-catalan))
 $(eval $(call BuildPackage,luci-i18n-portuguese))
 $(eval $(call BuildPackage,luci-i18n-spanish))
 $(eval $(call BuildPackage,luci-i18n-vietnamese))
+$(eval $(call BuildPackage,luci-i18n-malay))
 
 $(eval $(call BuildPackage,luci))
+$(eval $(call BuildPackage,luci-ssl))
+$(eval $(call BuildPackage,luci-medium))
 $(eval $(call BuildPackage,luci-light))