contrib: make luci meta package depend on luci-lib-nixio as well
[project/luci.git] / contrib / package / luci / Makefile
index 6814b6b..40009a2 100644 (file)
@@ -1,33 +1,18 @@
 include $(TOPDIR)/rules.mk
 
-PKG_BRANCH:=trunk
-
-ifeq ($(DUMP),)
-  USELOCAL:=$(shell grep luci ../../../.project 2>/dev/null >/dev/null && echo 1)
-endif
+LUCI_TOPDIR=../../..
 
 PKG_NAME:=luci
 PKG_RELEASE:=1
 
 PKG_BUILD_PARALLEL:=0
 
-ifeq ($(USELOCAL),1)
-  PKG_VERSION:=0.10+svn
-else
-  PKG_SOURCE_URL:=http://svn.luci.subsignal.org/luci/$(PKG_BRANCH)
-  ifeq ($(DUMP),)
-    PKG_REV:=$(shell LC_ALL=C svn info $(CURDIR) | sed -ne's/^Revision: //p')
-    PKG_VERSION:=0.10+svn$(PKG_REV)
-  endif
-  PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-  PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
-  PKG_SOURCE_PROTO:=svn
-  PKG_SOURCE_VERSION:=$(PKG_REV)
-endif
+PKG_VERSION:=$(shell $(LUCI_TOPDIR)/build/mkrevision.sh 2>/dev/null || echo unknown)
 
 PKG_BUILD_DEPENDS:=$(if $(STAGING_DIR_ROOT),lua/host)
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_USE_MIPS16:=0
 
 LUA_TARGET:=source
 LUCI_CFLAGS:=
@@ -39,31 +24,6 @@ ifeq ($(BOARD),brcm-2.4)
 endif
 
 
-include $(INCLUDE_DIR)/package.mk
-
-ifeq ($(USELOCAL),1)
-  define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-       $(TAR) c -C ../../../ . \
-               --exclude=.pc --exclude=.svn --exclude=.git \
-               --exclude='boa-0*' --exclude='*.o' --exclude='*.so' \
-               --exclude=dist | \
-                       tar x -C $(PKG_BUILD_DIR)/
-  endef
-endif
-
-define Build/Configure
-endef
-
-MAKE_FLAGS += \
-       MODULES="$(LUCI_SELECTED_MODULES)" \
-       LUA_TARGET="$(LUA_TARGET)" \
-       LUA_SHLIBS="-llua -lm -ldl -lcrypt" \
-       CFLAGS="$(TARGET_CFLAGS) $(LUCI_CFLAGS) -I$(STAGING_DIR)/usr/include" \
-       LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib" \
-       NIXIO_TLS="$(NIXIO_TLS)" OS="Linux"
-
-
 ### Templates ###
 define Package/luci/install/template
        $(CP) -a $(PKG_BUILD_DIR)/$(2)/dist/* $(1)/ -R
@@ -72,60 +32,67 @@ endef
 
 
 ### Core package ###
-define Package/luci-lib-core
+define Package/luci-base
   SECTION:=luci
   CATEGORY:=LuCI
   TITLE:=LuCI - Lua Configuration Interface
   URL:=http://luci.subsignal.org/
   MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
-  SUBMENU:=Libraries
-  DEPENDS:=+lua +libuci-lua
+  SUBMENU:=8. Libraries
+  DEPENDS:=+lua +libuci-lua +libubus-lua
   TITLE:=LuCI core libraries
 endef
 
-define Package/luci-lib-core/install
-       $(call Package/luci/install/template,$(1),libs/core)
+define Package/luci-base/install
+       $(call Package/luci/install/template,$(1),modules/base)
        $(PKG_BUILD_DIR)/build/mkversion.sh $(1)/usr/lib/lua/luci/version.lua \
                "OpenWrt Firmware" \
                "$(OPENWRTVERSION)" \
-               "$(PKG_BRANCH)" \
+               "trunk" \
                "$(PKG_VERSION)"
 endef
 
-define Package/luci-lib-core/config
+define Package/luci-base/config
        choice
                prompt "Build Target"
-               default PACKAGE_luci-lib-core_source
+               default PACKAGE_luci-base_source
 
-       config PACKAGE_luci-lib-core_compile
+       config PACKAGE_luci-base_compile
                bool "Precompiled"
 
-       config PACKAGE_luci-lib-core_stripped
+       config PACKAGE_luci-base_stripped
                bool "Stripped"
 
-       config PACKAGE_luci-lib-core_source
+       config PACKAGE_luci-base_srcdiet
+               bool "Compressed Source"
+
+       config PACKAGE_luci-base_source
                bool "Full Source"
 
        endchoice
 endef
 
-ifneq ($(CONFIG_PACKAGE_luci-lib-core_compile),)
+define Package/luci-base/conffiles
+/etc/config/luci
+endef
+
+ifneq ($(CONFIG_PACKAGE_luci-base_compile),)
   LUA_TARGET:=compile
 endif
 
-ifneq ($(CONFIG_PACKAGE_luci-lib-core_stripped),)
+ifneq ($(CONFIG_PACKAGE_luci-base_stripped),)
   LUA_TARGET:=strip
 endif
 
-ifneq ($(CONFIG_PACKAGE_luci-lib-core_zipped),)
-  LUA_TARGET:=gzip
+ifneq ($(CONFIG_PACKAGE_luci-base_srcdiet),)
+  LUA_TARGET:=diet
 endif
 
-ifneq ($(CONFIG_PACKAGE_luci-lib-core),)
-  LUCI_SELECTED_MODULES+=libs/core
+ifneq ($(CONFIG_PACKAGE_luci-base),)
+  LUCI_SELECTED_MODULES+=modules/base
 endif
 
-LUCI_BUILD_PACKAGES += luci-lib-core
+LUCI_BUILD_PACKAGES += luci-base
 
 
 ### Libraries ###
@@ -136,9 +103,9 @@ define library
     TITLE:=LuCI - Lua Configuration Interface
     URL:=http://luci.subsignal.org/
     MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
-    SUBMENU:=Libraries
+    SUBMENU:=8. Libraries
     TITLE:=$(if $(2),$(2),LuCI $(1) library)
-    $(if $(3),DEPENDS:=+luci-lib-core $(3))
+    $(if $(3),DEPENDS:=+luci-base $(3))
   endef
 
   define Package/luci-lib-$(1)/install
@@ -153,10 +120,6 @@ define library
   LUCI_BUILD_PACKAGES += luci-lib-$(1)
 endef
 
-define Package/luci-lib-web/conffiles
-/etc/config/luci
-endef
-
 define Package/luci-lib-nixio/config
        choice
                prompt "TLS Provider"
@@ -195,49 +158,41 @@ ifneq ($(CONFIG_PACKAGE_luci-lib-nixio_cyassl),)
 endif
 
 
-$(eval $(call library,fastindex,Fastindex indexing module))
-$(eval $(call library,httpclient,HTTP(S) client library,+luci-lib-web +luci-lib-nixio))
-$(eval $(call library,ipkg,LuCI IPKG/OPKG call abstraction library))
+$(eval $(call library,httpclient,HTTP(S) client library,+luci-base +luci-lib-nixio))
 $(eval $(call library,json,LuCI JSON library))
-$(eval $(call library,lmo,LuCI LMO I18N library))
-$(eval $(call library,lucid,LuCId Full-Stack Webserver,+luci-lib-nixio +luci-lib-web +luci-lib-px5g))
-$(eval $(call library,lucid-http,LuCId HTTP Backend,+luci-lib-lucid))
-$(eval $(call library,lucid-rpc,LuCId RPC Backend,+luci-lib-lucid))
 $(eval $(call library,nixio,NIXIO POSIX library,+PACKAGE_luci-lib-nixio_openssl:libopenssl +PACKAGE_luci-lib-nixio_cyassl:libcyassl))
 $(eval $(call library,px5g,RSA/X.509 Key Generator (required for LuCId SSL support),+luci-lib-nixio))
-$(eval $(call library,sys,LuCI Linux/POSIX system library,+libiwinfo))
-$(eval $(call library,web,MVC Webframework,+luci-lib-sys +luci-lib-nixio +luci-lib-core +luci-sgi-cgi +luci-lib-lmo))
-$(eval $(call library,uvl,UVL - UCI Validation Layer,+luci-lib-sys +luci-lib-core))
+$(eval $(call library,luaneightbl,neightbl - Lua lib for IPv6 neighbors,+luci-base))
 
 
-### Community Packages ###
-define Package/luci-mod-freifunk-community
-  SECTION:=luci
-  CATEGORY:=LuCI
-  TITLE:=LuCI - Lua Configuration Interface
-  URL:=http://luci.subsignal.org/
-  MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
-  SUBMENU:=Freifunk
-  TITLE:=Freifunk Community Meta-Package
-  DEPENDS+= \
-   +luci-lib-web +luci-app-splash \
-   +luci-app-ffwizard-leipzig \
-   +luci-i18n-german \
-   +PACKAGE_luci-mod-freifunk-community:olsrd-luci +PACKAGE_luci-mod-freifunk-community:olsrd-luci-mod-dyn-gw-plain \
-   +PACKAGE_luci-mod-freifunk-community:olsrd-luci-mod-txtinfo +PACKAGE_luci-mod-freifunk-community:olsrd-luci-mod-nameservice \
-   +PACKAGE_luci-mod-freifunk-community:olsrd-luci-mod-watchdog +PACKAGE_luci-mod-freifunk-community:kmod-tun \
-   +PACKAGE_luci-mod-freifunk-community:ip +PACKAGE_luci-mod-freifunk-community:freifunk-watchdog +luci-app-olsr
-endef
+### Protocols ###
+define protocol
+  define Package/luci-proto-$(1)
+    SECTION:=luci
+    CATEGORY:=LuCI
+    TITLE:=LuCI - Lua Configuration Interface
+    URL:=http://luci.subsignal.org/
+    MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
+    SUBMENU:=6. Protocols
+    TITLE:=$(if $(2),$(2),LuCI $(1) protocol support)
+    DEPENDS:=$(3)
+  endef
 
-define Package/luci-mod-freifunk-community/install
-       $(call Package/luci/install/template,$(1),applications/freifunk-community)
-endef
+  define Package/luci-proto-$(1)/install
+       $(call Package/luci/install/template,$$(1),protocols/$(1))
+  endef
 
-ifneq ($(CONFIG_PACKAGE_luci-mod-freifunk-community),)
-       LUCI_SELECTED_MODULES+=applications/freifunk-community
-endif
+  ifneq ($(CONFIG_PACKAGE_luci-proto-$(1)),)
+    LUCI_SELECTED_MODULES+=protocols/$(1)
+  endif
 
-LUCI_BUILD_PACKAGES += luci-mod-freifunk-community
+  LUCI_BUILD_PACKAGES += luci-proto-$(1)
+endef
+
+$(eval $(call protocol,ppp,Support for PPP/PPPoE/PPPoA/PPtP))
+$(eval $(call protocol,ipv6,Support for DHCPv6/6in4/6to4/6rd/DS-Lite))
+$(eval $(call protocol,3g,Support for 3G,+PACKAGE_luci-proto-3g:comgt))
+$(eval $(call protocol,relay,Support for relayd pseudo bridges,+PACKAGE_luci-proto-relay:relayd))
 
 
 ### Modules ###
@@ -248,7 +203,7 @@ define module
     TITLE:=LuCI - Lua Configuration Interface
     URL:=http://luci.subsignal.org/
     MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
-    SUBMENU:=Modules
+    SUBMENU:=2. Modules
     TITLE:=$(if $(2),$(2),LuCI $(1) module)
     $(if $(3),DEPENDS+=$(3))
   endef
@@ -266,20 +221,10 @@ define module
 endef
 
 
-define Package/luci-mod-admin-core/extra-install
-       touch $(1)/etc/init.d/luci_fixtime || true
-endef
-
-define Package/luci-mod-freifunk/conffiles
-/etc/config/freifunk
-endef
-
-$(eval $(call module,admin-core,Web UI Core module,+luci-lib-web +luci-i18n-english))
-$(eval $(call module,admin-mini,LuCI Essentials - stripped down and user-friendly,+luci-mod-admin-core))
-$(eval $(call module,admin-full,LuCI Administration - full-featured for full control,+luci-mod-admin-core +luci-lib-ipkg))
+$(eval $(call module,admin-mini,LuCI Essentials - stripped down and user-friendly,+luci-base @BROKEN))
+$(eval $(call module,admin-full,LuCI Administration - full-featured for full control,+luci-base))
+$(eval $(call module,failsafe,LuCI Fail-Safe - Fail-Safe sysupgrade module,+luci-base))
 $(eval $(call module,rpc,LuCI RPC - JSON-RPC API,+luci-lib-json))
-$(eval $(call module,freifunk,LuCI Freifunk module,+luci-mod-admin-full +luci-lib-json +PACKAGE_luci-mod-freifunk:freifunk-firewall))
-$(eval $(call module,niu,NIU - Next Generation Interface,+luci-mod-admin-core @BROKEN))
 
 
 ### Applications ###
@@ -290,9 +235,9 @@ define application
     TITLE:=LuCI - Lua Configuration Interface
     URL:=http://luci.subsignal.org/
     MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
-    SUBMENU:=Applications
+    SUBMENU:=3. Applications
     TITLE:=$(if $(2),$(2),LuCI $(1) application)
-       DEPENDS:=+luci-mod-admin-core $(3)
+       DEPENDS:=$(3)
   endef
 
   define Package/luci-app-$(1)/install
@@ -306,147 +251,14 @@ define application
   LUCI_BUILD_PACKAGES += luci-app-$(1)
 endef
 
-define Package/luci-app-splash/conffiles
-/etc/config/luci_splash
-endef
-
-define Package/luci-app-statistics/conffiles
-/etc/config/luci_statistics
-endef
-
-define Package/luci-app-diag-devinfo/conffiles
-/etc/config/luci_devinfo
-endef
-
 
-$(eval $(call application,ffwizard-leipzig,Freifunk Leipzig configuration wizard))
-
-$(eval $(call application,siitwizard,SIIT IPv4-over-IPv6 configuration wizard,\
-       +PACKAGE_luci-app-siitwizard:kmod-siit))
-
-$(eval $(call application,firewall,Firmware and Portforwarding application,\
+$(eval $(call application,firewall,Firewall and Portforwarding application,\
        +PACKAGE_luci-app-firewall:firewall))
 
-$(eval $(call application,olsr,OLSR configuration and status module,\
-       +luci-mod-admin-full +PACKAGE_luci-app-olsr:olsrd-luci +PACKAGE_luci-app-olsr:olsrd-luci-mod-txtinfo))
-
 $(eval $(call application,qos,Quality of Service configuration module,\
        +PACKAGE_luci-app-qos:qos-scripts))
 
-$(eval $(call application,splash,Freifunk DHCP-Splash application,\
-       +luci-lib-nixio +PACKAGE_luci-app-splash:tc \
-       +PACKAGE_luci-app-splash:kmod-sched +PACKAGE_luci-app-splash:iptables-mod-nat-extra \
-       +PACKAGE_luci-app-splash:iptables-mod-ipopt))
-
-$(eval $(call application,statistics,LuCI Statistics Application,\
-       +luci-mod-admin-full +PACKAGE_luci-app-statistics:collectd \
-       +PACKAGE_luci-app-statistics:rrdtool1 \
-       +PACKAGE_luci-app-statistics:collectd-mod-rrdtool \
-       +PACKAGE_luci-app-statistics:collectd-mod-wireless \
-       +PACKAGE_luci-app-statistics:collectd-mod-interface \
-       +PACKAGE_luci-app-statistics:collectd-mod-load))
-
-
-$(eval $(call application,diag-core,LuCI Diagnostics Tools (Core)))
-
-$(eval $(call application,diag-devinfo,LuCI Diagnostics Tools (Device Info),\
-       +luci-app-diag-core \
-       +PACKAGE_luci-app-diag-devinfo:smap \
-       +PACKAGE_luci-app-diag-devinfo:netdiscover \
-       +PACKAGE_luci-app-diag-devinfo:mac-to-devinfo \
-       +PACKAGE_luci-app-diag-devinfo:httping \
-       +PACKAGE_luci-app-diag-devinfo:smap-to-devinfo \
-       +PACKAGE_luci-app-diag-devinfo:netdiscover-to-devinfo))
-
-$(eval $(call application,voice-core,LuCI Voice Software (Core)))
-
-$(eval $(call application,voice-diag,LuCI Voice Software (Diagnostics),\
-       +luci-app-voice-core +luci-app-diag-devinfo))
-
-
-$(eval $(call application,upnp,Universal Plug & Play configuration module,\
-       +PACKAGE_luci-app-upnp:miniupnpd))
-
-$(eval $(call application,ntpc,NTP time synchronisation configuration module,\
-       +PACKAGE_luci-app-ntpc:ntpclient))
-
-$(eval $(call application,ddns,Dynamic DNS configuration module,\
-       +PACKAGE_luci-app-ddns:ddns-scripts))
-
-$(eval $(call application,samba,Network Shares - Samba SMB/CIFS module,\
-       +luci-mod-admin-full +PACKAGE_luci-app-samba:samba3))
-
-$(eval $(call application,mmc-over-gpio,MMC-over-GPIO configuration module,\
-       +luci-mod-admin-full +PACKAGE_luci-app-mmc-over-gpio:kmod-mmc-over-gpio))
-
-$(eval $(call application,p910nd,p910nd - Printer server module,\
-       +luci-mod-admin-full +PACKAGE_luci-app-p910nd:p910nd))
-
-$(eval $(call application,ushare,uShare - UPnP A/V & DLNA Media Server,\
-       +luci-mod-admin-full +PACKAGE_luci-app-ushare:ushare))
-
-$(eval $(call application,hd-idle,Hard Disk Idle Spin-Down module,\
-       +luci-mod-admin-full +PACKAGE_luci-app-hd-idle:hd-idle))
-
-$(eval $(call application,tinyproxy,Tinyproxy - HTTP(S)-Proxy configuration,\
-       +luci-mod-admin-full +PACKAGE_luci-app-tinyproxy:tinyproxy))
-
-$(eval $(call application,initmgr,LuCI Initscript Management,\
-       +luci-mod-admin-full))
-
-$(eval $(call application,livestats,LuCI Realtime Statistics,\
-       +luci-mod-rpc))
-
-$(eval $(call application,asterisk,LuCI Support for Asterisk PBX,\
-       @BROKEN +PACKAGE_luci-app-asterisk:asterisk14-xip-core))
-
-$(eval $(call application,polipo,LuCI Support for the Polipo Proxy,\
-       +PACKAGE_luci-app-polipo:polipo))
-
-$(eval $(call application,openvpn,LuCI Support for OpenVPN,\
-       +PACKAGE_luci-app-openvpn:openvpn))
-
-$(eval $(call application,p2pblock,LuCI Support for the Freifunk P2P-Block addon,\
-       +luci-app-firewall +PACKAGE_luci-app-p2pblock:freifunk-p2pblock))
-
-$(eval $(call application,multiwan,LuCI Support for the OpenWrt MultiWAN agent,\
-       +luci-app-firewall +PACKAGE_luci-app-multiwan:multiwan))
-
-$(eval $(call application,wol,LuCI Support for Wake-on-LAN,\
-       +PACKAGE_luci-app-wol:etherwake))
-
-$(eval $(call application,vnstat,LuCI Support for VnStat,\
-       +PACKAGE_luci-app-vnstat:vnstat \
-    +PACKAGE_luci-app-vnstat:vnstati))
-
-$(eval $(call application,lqtapifoss,Lantiq voip))
-
-### Server Gateway Interfaces ###
-define sgi
-  define Package/luci-sgi-$(1)
-    SECTION:=luci
-    CATEGORY:=LuCI
-    TITLE:=LuCI - Lua Configuration Interface
-    URL:=http://luci.subsignal.org/
-    MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
-    SUBMENU:=Server Interfaces
-    TITLE:=$(if $(2),$(2),LuCI $(1) server gateway interface)
-       $(if $(3),DEPENDS:=$(3))
-  endef
-
-  define Package/luci-sgi-$(1)/install
-       $(call Package/luci/install/template,$$(1),libs/sgi-$(1))
-  endef
-
-  ifneq ($(CONFIG_PACKAGE_luci-sgi-$(1)),)
-    LUCI_SELECTED_MODULES+=libs/sgi-$(1)
-  endif
-
-  LUCI_BUILD_PACKAGES += luci-sgi-$(1)
-endef
-
-$(eval $(call sgi,cgi,CGI Gateway behind existing Webserver))
-$(eval $(call sgi,uhttpd,Binding for the uHTTPd server,+uhttpd +uhttpd-mod-lua))
+$(eval $(call application,commands,LuCI Shell Command Module))
 
 
 ### Themes ###
@@ -456,11 +268,9 @@ define theme
     CATEGORY:=LuCI
     TITLE:=LuCI - Lua Configuration Interface
     URL:=http://luci.subsignal.org/
-    SUBMENU:=Themes
+    SUBMENU:=4. Themes
     TITLE:=$(if $(2),$(2),LuCI $(1) theme)
-       MAINTAINER:=$(if $(3),$(3),LuCI Development Team <luci@lists.subsignal.org>)
-       DEPENDS:=$(if $(filter-out base,$(1)),+luci-theme-base) $(4)
-       $(if $(5),DEFAULT:=PACKAGE_luci-lib-core)
+    MAINTAINER:=$(if $(3),$(3),LuCI Development Team <luci@lists.subsignal.org>)
   endef
 
   define Package/luci-theme-$(1)/install
@@ -474,21 +284,9 @@ define theme
   LUCI_BUILD_PACKAGES += luci-theme-$(1)
 endef
 
-$(eval $(call theme,base,Common base for all themes,,+luci-lib-web))
-$(eval $(call theme,openwrt,OpenWrt.org (default),,,1))
-$(eval $(call theme,fledermaus,Fledermaus Theme))
-
-$(eval $(call theme,freifunk,alternative Freifunk Theme,\
-       Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>))
+$(eval $(call theme,openwrt,OpenWrt.org))
+$(eval $(call theme,bootstrap,Bootstrap Theme (default)))
 
-$(eval $(call theme,freifunk-bno,Freifunk Berlin Nordost Theme,\
-       Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>))
-
-$(eval $(call theme,freifunk-hannover,Freifunk Hannover Theme,\
-       Mikolas Bingemer <mickey-at-freifunk-hannover-dot-de>))
-
-$(eval $(call theme,freifunk-generic,Freifunk Generic Theme,\
-        Manuel Munz <freifunk-at-somakoma-dot-de>))
 
 ### Translations ###
 define translation
@@ -498,7 +296,7 @@ define translation
     TITLE:=LuCI - Lua Configuration Interface
     URL:=http://luci.subsignal.org/
     MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
-    SUBMENU:=Translations
+    SUBMENU:=5. Translations
     TITLE:=$(if $(2),$(2),$(1))
   endef
 
@@ -518,7 +316,8 @@ $(eval $(call translation,english,English))
 $(eval $(call translation,french,French (by Florian Fainelli)))
 $(eval $(call translation,italian,Italian (by Matteo Croce)))
 $(eval $(call translation,russian,Russian (by Skryabin Dmitry)))
-$(eval $(call translation,portuguese_brazilian,Portuguese (Brazilian) (by Carlos Cesario)))
+$(eval $(call translation,portuguese-brazilian,Portuguese (Brazilian) (by Carlos Cesario)))
+$(eval $(call translation,chinese,Chinese (by Chinese Translators)))
 $(eval $(call translation,japanese,Japanese (by Tsukasa Hamano)))
 $(eval $(call translation,greek,Greek (by Vasilis Tsiligiannis)))
 $(eval $(call translation,catalan,Catalan (by Eduard Duran)))
@@ -527,6 +326,11 @@ $(eval $(call translation,spanish,Spanish (by Guillermo Javier Nardoni)))
 $(eval $(call translation,vietnamese,Vietnamese (by Hong Phuc Dang)))
 $(eval $(call translation,malay,Malay (by Teow Wai Chet)))
 $(eval $(call translation,norwegian,Norwegian (by Lars Hardy)))
+$(eval $(call translation,hebrew,Hebrew))
+$(eval $(call translation,romanian,Romanian))
+$(eval $(call translation,ukrainian,Ukrainian))
+$(eval $(call translation,hungarian,Hungarian))
+$(eval $(call translation,polish,Polish))
 
 
 ### Collections ###
@@ -537,7 +341,7 @@ define collection
     TITLE:=LuCI - Lua Configuration Interface
     URL:=http://luci.subsignal.org/
     MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
-    SUBMENU:=Collections
+    SUBMENU:=1. Collections
     TITLE:=$(if $(2),$(2),LuCI $(if $(1),$(1),general) collection)
     $(if $(3),DEPENDS:=$(3))
   endef
@@ -550,20 +354,51 @@ define collection
 endef
 
 $(eval $(call collection,,\
-       Standard OpenWrt set including full and mini admin and the standard theme,\
-       +uhttpd +luci-mod-admin-full +luci-theme-openwrt +luci-app-firewall \
-       +luci-app-initmgr))
+       Standard OpenWrt set including full admin with ppp support and the \
+       default OpenWrt theme,\
+       +uhttpd +uhttpd-mod-ubus +luci-mod-admin-full +luci-theme-bootstrap \
+       +luci-app-firewall +luci-proto-ppp +libiwinfo-lua +luci-lib-nixio))
 
 $(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\
-       +uhttpd +uhttpd-mod-tls +px5g +luci-mod-admin-full +luci-theme-openwrt \
-       +luci-app-firewall +luci-app-initmgr))
+       +luci +libustream-polarssl +px5g))
 
 $(eval $(call collection,light,\
        Minimum package set using only admin mini and the standard theme,\
-       +uhttpd +luci-mod-admin-mini +luci-theme-openwrt-light))
+       +uhttpd +luci-mod-admin-mini +luci-theme-openwrt @BROKEN))
 
 
 ### Compile ###
-PKG_CONFIG_DEPENDS := $(patsubst %,CONFIG_PACKAGE_%,$(LUCI_BUILD_PACKAGES))
+PKG_CONFIG_DEPENDS=$(patsubst %,CONFIG_PACKAGE_%,$(LUCI_BUILD_PACKAGES))
+
+include $(INCLUDE_DIR)/package.mk
+
+define Build/Prepare
+       @if [ ! -x $(LUCI_TOPDIR)/build/mkrevision.sh ]; then \
+               echo "*** Repository layout changed!" >&2; \
+               echo "*** Please change the LuCI url in feeds.conf to http://svn.luci.subsignal.org/luci/trunk and reinstall the feed with" >&2; \
+               echo "*** ./scripts/feeds update luci; ./scripts/feeds install -a -p luci" >&2; \
+               exit 1; \
+       fi
+       mkdir -p $(PKG_BUILD_DIR)
+       $(TAR) c -C $(LUCI_TOPDIR) . \
+               --exclude=.pc --exclude=.svn --exclude=.git \
+               --exclude='*.o' --exclude='*.so' \
+               --exclude=dist | \
+                       tar x -C $(PKG_BUILD_DIR)/
+       $(call Build/Prepare/Default)
+endef
+
+define Build/Configure
+endef
+
+MAKE_FLAGS += \
+       MODULES="$(LUCI_SELECTED_MODULES)" \
+       LUA_TARGET="$(LUA_TARGET)" \
+       LUA_SHLIBS="-llua -lm -ldl -lcrypt" \
+       CFLAGS="$(TARGET_CFLAGS) $(LUCI_CFLAGS) -I$(STAGING_DIR)/usr/include" \
+       LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib" \
+       NIXIO_TLS="$(NIXIO_TLS)" OS="Linux"
+
+
 $(foreach b,$(LUCI_BUILD_PACKAGES),$(eval $(call BuildPackage,$(b))))