contrib/package: make luci-app-firewall depend on firewall3
[project/luci.git] / contrib / package / luci / Makefile
index 2a15d5d..353e69e 100644 (file)
@@ -54,7 +54,7 @@ define Package/luci-lib-core
   URL:=http://luci.subsignal.org/
   MAINTAINER:=LuCI Development Team <luci@lists.subsignal.org>
   SUBMENU:=8. Libraries
-  DEPENDS:=+lua +libuci-lua
+  DEPENDS:=+lua +libuci-lua +libubus-lua
   TITLE:=LuCI core libraries
 endef
 
@@ -173,18 +173,17 @@ ifneq ($(CONFIG_PACKAGE_luci-lib-nixio_cyassl),)
 endif
 
 
-$(eval $(call library,fastindex,Fastindex indexing module))
+$(eval $(call library,fastindex,Fastindex indexing module,+PACKAGE_luci-lib-fastindex:liblua))
 $(eval $(call library,httpclient,HTTP(S) client library,+luci-lib-web +luci-lib-nixio))
 $(eval $(call library,ipkg,LuCI IPKG/OPKG call abstraction library))
 $(eval $(call library,json,LuCI JSON library))
-$(eval $(call library,lmo,LuCI LMO I18N library))
 $(eval $(call library,lucid,LuCId Full-Stack Webserver,+luci-lib-nixio +luci-lib-web +luci-lib-px5g))
 $(eval $(call library,lucid-http,LuCId HTTP Backend,+luci-lib-lucid))
 $(eval $(call library,lucid-rpc,LuCId RPC Backend,+luci-lib-lucid))
 $(eval $(call library,nixio,NIXIO POSIX library,+PACKAGE_luci-lib-nixio_openssl:libopenssl +PACKAGE_luci-lib-nixio_cyassl:libcyassl))
 $(eval $(call library,px5g,RSA/X.509 Key Generator (required for LuCId SSL support),+luci-lib-nixio))
 $(eval $(call library,sys,LuCI Linux/POSIX system library))
-$(eval $(call library,web,MVC Webframework,+luci-lib-sys +luci-lib-nixio +luci-lib-core +luci-sgi-cgi +luci-lib-lmo))
+$(eval $(call library,web,MVC Webframework,+luci-lib-sys +luci-lib-nixio +luci-lib-core +luci-sgi-cgi))
 
 
 ### Protocols ###
@@ -212,11 +211,10 @@ define protocol
 endef
 
 $(eval $(call protocol,core,Support for static/dhcp/none))
-$(eval $(call protocol,ppp,Support for PPP/PPPoE/PPPoA))
-$(eval $(call protocol,pptp,Support for PPtP,+pptp))
-$(eval $(call protocol,6x4,Support for 6in4/6to4,+6in4 +6to4))
-$(eval $(call protocol,3g,Support for 3G,+comgt))
-$(eval $(call protocol,relay,Support for relayd pseudo bridges,+relayd))
+$(eval $(call protocol,ppp,Support for PPP/PPPoE/PPPoA/PPtP))
+$(eval $(call protocol,ipv6,Support for DHCPv6/6in4/6to4/6rd,+PACKAGE_luci-proto-ipv6:6in4 +PACKAGE_luci-proto-ipv6:6to4 +PACKAGE_luci-proto-ipv6:6rd +PACKAGE_luci-proto-ipv6:ipv6-support))
+$(eval $(call protocol,3g,Support for 3G,+PACKAGE_luci-proto-3g:comgt))
+$(eval $(call protocol,relay,Support for relayd pseudo bridges,+PACKAGE_luci-proto-relay:relayd))
 
 
 ### Community Packages ###
@@ -281,6 +279,7 @@ endef
 $(eval $(call module,admin-core,Web UI Core module,+luci-lib-web +luci-proto-core +luci-i18n-english))
 $(eval $(call module,admin-mini,LuCI Essentials - stripped down and user-friendly,+luci-mod-admin-core @BROKEN))
 $(eval $(call module,admin-full,LuCI Administration - full-featured for full control,+luci-mod-admin-core +luci-lib-ipkg))
+$(eval $(call module,failsafe,LuCI Fail-Safe - Fail-Safe sysupgrade module,+luci-mod-admin-core))
 $(eval $(call module,rpc,LuCI RPC - JSON-RPC API,+luci-lib-json))
 $(eval $(call module,freifunk,LuCI Freifunk module,+luci-mod-admin-full +luci-lib-json +PACKAGE_luci-mod-freifunk:freifunk-firewall +freifunk-common +community-profiles))
 $(eval $(call module,niu,NIU - Next Generation Interface,+luci-mod-admin-core @BROKEN))
@@ -327,21 +326,26 @@ endef
 $(eval $(call application,siitwizard,SIIT IPv4-over-IPv6 configuration wizard,\
        +PACKAGE_luci-app-siitwizard:kmod-siit))
 
-$(eval $(call application,firewall,Firmware and Portforwarding application,\
-       +PACKAGE_luci-app-firewall:firewall))
+$(eval $(call application,firewall,Firewall and Portforwarding application,\
+       +PACKAGE_luci-app-firewall:firewall3))
 
 $(eval $(call application,freifunk-policyrouting,Policy routing for mesh traffic,\
         +PACKAGE_luci-app-freifunk-policyrouting:freifunk-policyrouting))
 
+$(eval $(call application,freifunk-widgets,Widgets for the Freifunk index page,\
+        +PACKAGE_luci-app-freifunk-widgets:luci-mod-freifunk))
+
 $(eval $(call application,meshwizard, Shellscript based wizard to setup mesh networks,\
         +PACKAGE_luci-app-freifunk-meshwizard:meshwizard))
 
 $(eval $(call application,olsr,OLSR configuration and status module,\
-       +olsrd-mod-txtinfo))
+       +olsrd +olsrd-mod-txtinfo))
 
 $(eval $(call application,olsr-viz,OLSR Visualisation,\
        luci-app-olsr +olsrd-mod-txtinfo))
 
+$(eval $(call application,freifunk-diagnostics,Tools for network diagnosis like traceroute and ping))
+
 $(eval $(call application,olsr-services,Show services announced with the nameservice plugin,\
        luci-app-olsr +olsrd-mod-nameservice))
 
@@ -355,9 +359,10 @@ $(eval $(call application,statistics,LuCI Statistics Application,\
        +PACKAGE_luci-app-statistics:collectd \
        +PACKAGE_luci-app-statistics:rrdtool1 \
        +PACKAGE_luci-app-statistics:collectd-mod-rrdtool \
-       +PACKAGE_luci-app-statistics:collectd-mod-wireless \
+       +PACKAGE_luci-app-statistics:collectd-mod-iwinfo \
        +PACKAGE_luci-app-statistics:collectd-mod-interface \
-       +PACKAGE_luci-app-statistics:collectd-mod-load))
+       +PACKAGE_luci-app-statistics:collectd-mod-load)) \
+       +PACKAGE_luci-app-statistics:collectd-mod-network))
 
 
 $(eval $(call application,diag-core,LuCI Diagnostics Tools (Core)))
@@ -376,6 +381,8 @@ $(eval $(call application,voice-core,LuCI Voice Software (Core)))
 $(eval $(call application,voice-diag,LuCI Voice Software (Diagnostics),\
        luci-app-diag-devinfo))
 
+$(eval $(call application,commands,LuCI Shell Command Module))
+
 $(eval $(call application,upnp,Universal Plug & Play configuration module,\
        +PACKAGE_luci-app-upnp:miniupnpd))
 
@@ -386,7 +393,7 @@ $(eval $(call application,ddns,Dynamic DNS configuration module,\
        +PACKAGE_luci-app-ddns:ddns-scripts))
 
 $(eval $(call application,samba,Network Shares - Samba SMB/CIFS module,\
-       +PACKAGE_luci-app-samba:samba3))
+       +PACKAGE_luci-app-samba:samba36-server))
 
 $(eval $(call application,mmc-over-gpio,MMC-over-GPIO configuration module,\
        +PACKAGE_luci-app-mmc-over-gpio:kmod-mmc-over-gpio))
@@ -407,7 +414,7 @@ $(eval $(call application,polipo,LuCI Support for the Polipo Proxy,\
        +PACKAGE_luci-app-polipo:polipo))
 
 $(eval $(call application,openvpn,LuCI Support for OpenVPN,\
-       +PACKAGE_luci-app-openvpn:openvpn))
+       +PACKAGE_luci-app-openvpn:openvpn @BROKEN))
 
 $(eval $(call application,p2pblock,LuCI Support for the Freifunk P2P-Block addon,\
        luci-app-firewall +PACKAGE_luci-app-p2pblock:freifunk-p2pblock))
@@ -431,7 +438,31 @@ $(eval $(call application,ahcp,LuCI Support for AHCPd,\
 $(eval $(call application,wshaper,LuCI Support for wshaper,\
        +PACKAGE_luci-app-wshaper:wshaper))
 
-$(eval $(call application,lqtapifoss,Lantiq voip))
+$(eval $(call application,pbx,LuCI PBX Administration,\
+       +PACKAGE_luci-app-pbx:asterisk18 \
+       +PACKAGE_luci-app-pbx:asterisk18-app-authenticate \
+       +PACKAGE_luci-app-pbx:asterisk18-app-disa \
+       +PACKAGE_luci-app-pbx:asterisk18-app-setcallerid \
+       +PACKAGE_luci-app-pbx:asterisk18-app-system \
+       +PACKAGE_luci-app-pbx:asterisk18-chan-gtalk \
+       +PACKAGE_luci-app-pbx:asterisk18-codec-a-mu \
+       +PACKAGE_luci-app-pbx:asterisk18-codec-alaw \
+       +PACKAGE_luci-app-pbx:asterisk18-func-cut \
+       +PACKAGE_luci-app-pbx:asterisk18-res-clioriginate))
+
+$(eval $(call application,pbx-voicemail,LuCI PBX Administration Voicemail Support,\
+       luci-app-pbx +PACKAGE_luci-app-pbx-voicemail:msmtp))
+
+$(eval $(call application,ltqtapi,Lantiq voip))
+
+$(eval $(call application,minidlna,LuCI Support for miniDLNA,\
+       +PACKAGE_luci-app-minidlna:minidlna))
+
+$(eval $(call application,transmission,LuCI Support for Transmission,\
+       +PACKAGE_luci-app-transmission:transmission-daemon))
+
+$(eval $(call application,watchcat,LuCI Support for Watchcat,\
+       +PACKAGE_luci-app-watchcat:watchcat))
 
 ### Server Gateway Interfaces ###
 define sgi
@@ -488,19 +519,13 @@ endef
 
 $(eval $(call theme,base,Common base for all themes))
 $(eval $(call theme,openwrt,OpenWrt.org (default),,,1))
-$(eval $(call theme,fledermaus,Fledermaus Theme))
-
-$(eval $(call theme,freifunk,alternative Freifunk Theme,\
-       Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>))
+$(eval $(call theme,bootstrap,Bootstrap Theme))
 
 $(eval $(call theme,freifunk-bno,Freifunk Berlin Nordost Theme,\
        Stefan Pirwitz <stefan-at-freifunk-bno-dot-de>))
 
-$(eval $(call theme,freifunk-hannover,Freifunk Hannover Theme,\
-       Mikolas Bingemer <mickey-at-freifunk-hannover-dot-de>))
-
 $(eval $(call theme,freifunk-generic,Freifunk Generic Theme,\
-        Manuel Munz <freifunk-at-somakoma-dot-de>))
+       Manuel Munz <freifunk-at-somakoma-dot-de>))
 
 ### Translations ###
 define translation
@@ -530,7 +555,7 @@ $(eval $(call translation,english,English))
 $(eval $(call translation,french,French (by Florian Fainelli)))
 $(eval $(call translation,italian,Italian (by Matteo Croce)))
 $(eval $(call translation,russian,Russian (by Skryabin Dmitry)))
-$(eval $(call translation,portuguese_brazilian,Portuguese (Brazilian) (by Carlos Cesario)))
+$(eval $(call translation,portuguese-brazilian,Portuguese (Brazilian) (by Carlos Cesario)))
 $(eval $(call translation,chinese,Chinese (by Chinese Translators)))
 $(eval $(call translation,japanese,Japanese (by Tsukasa Hamano)))
 $(eval $(call translation,greek,Greek (by Vasilis Tsiligiannis)))
@@ -542,6 +567,9 @@ $(eval $(call translation,malay,Malay (by Teow Wai Chet)))
 $(eval $(call translation,norwegian,Norwegian (by Lars Hardy)))
 $(eval $(call translation,hebrew,Hebrew))
 $(eval $(call translation,romanian,Romanian))
+$(eval $(call translation,ukrainian,Ukrainian))
+$(eval $(call translation,hungarian,Hungarian))
+$(eval $(call translation,polish,Polish))
 
 
 ### Collections ###
@@ -567,12 +595,12 @@ endef
 $(eval $(call collection,,\
        Standard OpenWrt set including full admin with ppp support and the \
        default OpenWrt theme,\
-       +uhttpd +luci-mod-admin-full +luci-theme-openwrt +luci-app-firewall \
-       +luci-proto-core +luci-proto-ppp +libiwinfo))
+       +uhttpd +uhttpd-mod-ubus +luci-mod-admin-full +luci-theme-openwrt \
+       +luci-app-firewall +luci-proto-core +luci-proto-ppp +libiwinfo-lua))
 
 $(eval $(call collection,ssl,\
        Standard OpenWrt set with HTTPS support,\
-       +luci +uhttpd-mod-tls +px5g))
+       +luci +libustream-cyassl +px5g))
 
 $(eval $(call collection,light,\
        Minimum package set using only admin mini and the standard theme,\