Make luci-app-diag and friends use conditional dependencies
[project/luci.git] / contrib / package / luci / Makefile
index 69263e7..2823d7d 100644 (file)
@@ -236,6 +236,16 @@ define Package/luci-luanet/install
 endef
 
 
+define Package/luci-iwinfo
+  $(call Package/luci/libtemplate)
+  TITLE:=Wireless abstration library
+endef
+
+define Package/luci-iwinfo/install
+       $(call Package/luci/install/template,$(1),libs/iwinfo)
+endef
+
+
 define Package/luci-lucid
   $(call Package/luci/libtemplate)
   TITLE:=LuCId Superserver
@@ -303,6 +313,7 @@ endef
 define Package/luci-sys
   $(call Package/luci/libtemplate)
   TITLE:=LuCI Linux/POSIX system library
+  DEPENDS:=+luci-iwinfo
 endef
 
 define Package/luci-sys/install
@@ -349,8 +360,7 @@ define Package/luci-freifunk-community
    +PACKAGE_luci-freifunk-community:olsrd-luci +PACKAGE_luci-freifunk-community:olsrd-luci-mod-dyn-gw-plain \
    +PACKAGE_luci-freifunk-community:olsrd-luci-mod-txtinfo +PACKAGE_luci-freifunk-community:olsrd-luci-mod-nameservice \
    +PACKAGE_luci-freifunk-community:olsrd-luci-mod-watchdog +PACKAGE_luci-freifunk-community:kmod-tun \
-   +PACKAGE_luci-freifunk-community:ip +PACKAGE_luci-freifunk-community:freifunk-watchdog +luci-app-olsr \
-   +PACKAGE_luci-freifunk-community:remote-update
+   +PACKAGE_luci-freifunk-community:ip +PACKAGE_luci-freifunk-community:freifunk-watchdog +luci-app-olsr
   TITLE:=Freifunk Community Meta-Package
 endef
 
@@ -522,25 +532,32 @@ endef
 
 define Package/luci-app-diag-core
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core 
+  DEPENDS+=+PACKAGE_luci-app-diag-core:luci-admin-core 
   TITLE:=LuCI Diagnostics Tools (Core)
 endef
 
 define Package/luci-app-diag-devinfo
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-app-diag-core +smap +netdiscover +mac-to-devinfo +httping +smap-to-devinfo +netdiscover-to-devinfo
+  DEPENDS+=+PACKAGE_luci_app-diag-devinfo:luci-app-diag-core \
+       +PACKAGE_luci-app-diag-devinfo:smap \
+       +PACKAGE_luci-app-diag-devinfo:netdiscover \
+       +PACKAGE_luci-app-diag-devinfo:mac-to-devinfo \
+       +PACKAGE_luci-app-diag-devinfo:httping \
+       +PACKAGE_luci-app-diag-devinfo:smap-to-devinfo \
+       +PACAKGE_luci-app-diag-devinfo:netdiscover-to-devinfo
   TITLE:=LuCI Diagnostics Tools (Device Info)
 endef
 
 define Package/luci-app-voice-core
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-admin-core 
+  DEPENDS+=+PACKAGE_luci-app-voice-core:luci-admin-core 
   TITLE:=LuCI Voice Software (Core)
 endef
 
 define Package/luci-app-voice-diag
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-app-voice-core +luci-app-diag-devinfo
+  DEPENDS+=+PACKAGE_luci-app-voice-diag:luci-app-voice-core \
+       +PACKAGE_luci-apps-voice-diag:luci-app-diag-devinfo
   TITLE:=LuCI Voice Software (Diagnostics)
 endef
 
@@ -801,7 +818,8 @@ endef
 define Package/luci-theme-openwrt
   $(call Package/luci/thtemplate)
   TITLE:=OpenWrt.org (default)
-  DEPENDS:=+luci-theme-base
+  DEPENDS:=+luci-theme-base luci-core
+  DEFAULT:=y if PACKAGE_luci-core
 endef
 
 define Package/luci-theme-openwrt/install
@@ -930,6 +948,16 @@ define Package/luci-i18n-spanish/install
 endef
 
 
+define Package/luci-i18n-vietnamese
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Vietnamese (by Hong Phuc Dang)
+endef
+
+define Package/luci-i18n-vietnamese/install
+       $(call Package/luci/install/template,$(1),i18n/vietnamese)
+endef
+
+
 ### Compile ###
 ifneq ($(CONFIG_PACKAGE_luci-core),)
        PKG_SELECTED_MODULES+=libs/core
@@ -958,6 +986,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-luanet),)
        PKG_SELECTED_MODULES+=libs/luanet
 endif
+ifneq ($(CONFIG_PACKAGE_luci-iwinfo),)
+       PKG_SELECTED_MODULES+=libs/iwinfo
+endif
 ifneq ($(CONFIG_PACKAGE_luci-lucid),)
        PKG_SELECTED_MODULES+=libs/lucid libs/lucid-http
 endif
@@ -1145,6 +1176,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-spanish),)
        PKG_SELECTED_MODULES+=i18n/spanish
 endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-vietnamese),)
+       PKG_SELECTED_MODULES+=i18n/vietnamese
+endif
 
 
 MAKE_FLAGS += \
@@ -1165,6 +1199,7 @@ $(eval $(call BuildPackage,luci-ipkg))
 $(eval $(call BuildPackage,luci-json))
 $(eval $(call BuildPackage,luci-lmo))
 $(eval $(call BuildPackage,luci-luanet))
+$(eval $(call BuildPackage,luci-iwinfo))
 $(eval $(call BuildPackage,luci-lucid))
 $(eval $(call BuildPackage,luci-nixio))
 $(eval $(call BuildPackage,luci-px5g))
@@ -1230,3 +1265,4 @@ $(eval $(call BuildPackage,luci-i18n-greek))
 $(eval $(call BuildPackage,luci-i18n-catalan))
 $(eval $(call BuildPackage,luci-i18n-portuguese))
 $(eval $(call BuildPackage,luci-i18n-spanish))
+$(eval $(call BuildPackage,luci-i18n-vietnamese))