luci-app-voice-diag, luci-app-diag-devinfo: Fix dependencies for the network
[project/luci.git] / contrib / package / luci / Makefile
index 1d00314..23a28c2 100644 (file)
@@ -23,6 +23,7 @@ else
   PKG_SOURCE_VERSION:=$(PKG_REV)
 endif
 
+PKG_BUILD_DEPENDS:=$(if $(STAGING_DIR_ROOT),lua/host)
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
@@ -59,10 +60,15 @@ define Package/luci/libtemplate
   TITLE:=LuCI - Lua Configuration Interface
   URL:=http://luci.freifunk-halle.net/
   MAINTAINER:=Steven Barth <steven-at-midlink-dot-org>
-  SUBMENU:=Libraries
+  SUBMENU:=Internal Libraries
   DEPENDS:=+luci-core
 endef
 
+define Package/luci/webservertemplate
+  $(call Package/luci/libtemplate)
+  SUBMENU:=Webserver
+endef
+
 define Package/luci/fftemplate
   $(call Package/luci/libtemplate)
   SUBMENU:=Freifunk
@@ -81,11 +87,21 @@ define Package/luci/thtemplate
   DEPENDS:=+luci-web
 endef
 
+define Package/luci/maintemplate
+  $(call Package/luci/libtemplate)
+  SUBMENU:=
+endef
+
 define Package/luci/webtemplate
   $(call Package/luci/libtemplate)
   SUBMENU:=Components
 endef
 
+define Package/luci/collectiontemplate
+  $(call Package/luci/libtemplate)
+  SUBMENU:=Collections
+endef
+
 
 define Package/luci/install/template
        $(CP) -a $(PKG_BUILD_DIR)/$(2)/dist/* $(1)/ -R
@@ -247,8 +263,8 @@ endef
 
 
 define Package/luci-lucid
-  $(call Package/luci/libtemplate)
-  TITLE:=LuCId Superserver
+  $(call Package/luci/webservertemplate)
+  TITLE:=LuCId Full-Stack Webserver
   DEPENDS+=+luci-nixio +luci-http +luci-px5g
 endef
 
@@ -300,8 +316,8 @@ endif
 
 
 define Package/luci-px5g
-  $(call Package/luci/libtemplate)
-  TITLE:=PX5G RSA Keymaster
+  $(call Package/luci/webservertemplate)
+  TITLE:=RSA/X.509 Key Generator (required for LuCId SSL support)
   DEPENDS:=+luci-nixio
 endef
 
@@ -325,7 +341,7 @@ define Package/luci-web
   $(call Package/luci/libtemplate)
   DEPENDS+=+luci-http +luci-sys +luci-uci +luci-lucid +luci-sgi-cgi +luci-lmo
   TITLE:=MVC Webframework
-  $(call Config,luci.main.lang,string,en,Default Language)
+  $(call Config,luci.main.lang,string,auto,Default Language)
 endef
 
 define Package/luci-web/conffiles
@@ -387,6 +403,16 @@ define Package/luci-admin-core/install
 endef
 
 
+define Package/luci-niu
+  $(call Package/luci/maintemplate)
+  DEPENDS+=+luci-admin-core @BROKEN
+  TITLE:=NIU - Next Generation Interface 
+endef
+
+define Package/luci-niu/install        
+       $(call Package/luci/install/template,$(1),modules/niu)
+endef
+
 define Package/luci-admin-mini
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-admin-core
@@ -515,7 +541,7 @@ define Package/luci-app-statistics
   $(call Package/luci/webtemplate)
   DEPENDS+=+luci-admin-full +PACKAGE_luci-app-statistics:collectd \
    +PACKAGE_luci-app-statistics:rrdtool1 \
-   +PACKAGE_luci-app-statistics:collectd-mod-rrdtool1 \
+   +PACKAGE_luci-app-statistics:collectd-mod-rrdtool \
    +PACKAGE_luci-app-statistics:collectd-mod-wireless \
    +PACKAGE_luci-app-statistics:collectd-mod-interface \
    +PACKAGE_luci-app-statistics:collectd-mod-load
@@ -538,7 +564,13 @@ endef
 
 define Package/luci-app-diag-devinfo
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-app-diag-core +smap +netdiscover +mac-to-devinfo +httping +smap-to-devinfo +netdiscover-to-devinfo
+  DEPENDS+=+PACKAGE_luci-app-diag-devinfo:luci-app-diag-core \
+       +PACKAGE_luci-app-diag-devinfo:smap \
+       +PACKAGE_luci-app-diag-devinfo:netdiscover \
+       +PACKAGE_luci-app-diag-devinfo:mac-to-devinfo \
+       +PACKAGE_luci-app-diag-devinfo:httping \
+       +PACKAGE_luci-app-diag-devinfo:smap-to-devinfo \
+       +PACKAGE_luci-app-diag-devinfo:netdiscover-to-devinfo
   TITLE:=LuCI Diagnostics Tools (Device Info)
 endef
 
@@ -550,7 +582,8 @@ endef
 
 define Package/luci-app-voice-diag
   $(call Package/luci/webtemplate)
-  DEPENDS+=+luci-app-voice-core +luci-app-diag-devinfo
+  DEPENDS+=+PACKAGE_luci-app-voice-diag:luci-app-voice-core \
+     +PACKAGE_luci-app-voice-diag:luci-app-diag-devinfo
   TITLE:=LuCI Voice Software (Diagnostics)
 endef
 
@@ -746,8 +779,8 @@ endef
 ### Server Gateway Interfaces ###
 
 define Package/luci-sgi-cgi
-  $(call Package/luci/libtemplate)
-  TITLE:=SGI for CGI
+  $(call Package/luci/webservertemplate)
+  TITLE:=CGI Gateway behind existing Webserver
 endef
 
 define Package/luci-sgi-cgi/install
@@ -941,6 +974,29 @@ define Package/luci-i18n-spanish/install
 endef
 
 
+define Package/luci-i18n-vietnamese
+  $(call Package/luci/i18ntemplate)
+  TITLE:=Vietnamese (by Hong Phuc Dang)
+endef
+
+define Package/luci-i18n-vietnamese/install
+       $(call Package/luci/install/template,$(1),i18n/vietnamese)
+endef
+
+
+### Collections ###
+define Package/luci-kamikaze
+  $(call Package/luci/collectiontemplate)
+  TITLE:=Standard OpenWrt Kamikaze set including full and mini admin and the standard theme
+  DEPENDS:=+luci-admin-full +luci-admin-mini +luci-theme-openwrt +luci-app-firewall
+endef
+
+define Package/luci-light
+  $(call Package/luci/collectiontemplate)
+  TITLE:=Minimum package set using only admin mini and a theme without grafics
+  DEPENDS:=+luci-admin-mini +luci-theme-openwrtlight
+endef
+
 ### Compile ###
 ifneq ($(CONFIG_PACKAGE_luci-core),)
        PKG_SELECTED_MODULES+=libs/core
@@ -1003,6 +1059,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-admin-full),)
        PKG_SELECTED_MODULES+=modules/admin-full
 endif
+ifneq ($(CONFIG_PACKAGE_luci-niu),)
+       PKG_SELECTED_MODULES+=modules/niu
+endif
 ifneq ($(CONFIG_PACKAGE_luci-admin-rpc),)
        PKG_SELECTED_MODULES+=modules/rpc
 endif
@@ -1159,6 +1218,9 @@ endif
 ifneq ($(CONFIG_PACKAGE_luci-i18n-spanish),)
        PKG_SELECTED_MODULES+=i18n/spanish
 endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-vietnamese),)
+       PKG_SELECTED_MODULES+=i18n/vietnamese
+endif
 
 
 MAKE_FLAGS += \
@@ -1191,6 +1253,7 @@ $(eval $(call BuildPackage,luci-uvl))
 $(eval $(call BuildPackage,luci-admin-core))
 $(eval $(call BuildPackage,luci-admin-mini))
 $(eval $(call BuildPackage,luci-admin-full))
+$(eval $(call BuildPackage,luci-niu))
 $(eval $(call BuildPackage,luci-admin-rpc))
 $(eval $(call BuildPackage,luci-mod-freifunk))
 
@@ -1245,3 +1308,7 @@ $(eval $(call BuildPackage,luci-i18n-greek))
 $(eval $(call BuildPackage,luci-i18n-catalan))
 $(eval $(call BuildPackage,luci-i18n-portuguese))
 $(eval $(call BuildPackage,luci-i18n-spanish))
+$(eval $(call BuildPackage,luci-i18n-vietnamese))
+
+$(eval $(call BuildPackage,luci-kamikaze))
+$(eval $(call BuildPackage,luci-light))