Bug fix: various cbi files in luci-diag-devinfo were missing 'require's for
[project/luci.git] / Makefile
index 775820c..3bf8c68 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -28,6 +28,7 @@ i18nbuild:
        ./build/i18n-po2lua.pl ./po host/lua-po
 
 clean:
+       rm -rf docs
        make -C libs/lmo host-clean
        for i in $(MODULES); do make -C$$i clean; done
 
@@ -40,6 +41,7 @@ luahost: luabuild hostcopy
 
 hostcopy: 
        mkdir -p host/tmp
+       mkdir -p host/var/state
        for i in $(MODULES); do cp -pR $$i/dist/* host/ 2>/dev/null || true; done
        for i in $(MODULES); do cp -pR $$i/hostfiles/* host/ 2>/dev/null || true; done
        rm -f host/luci