luci-base: fix logic errors in ipmask4 and ipmask6 datatype validators
[project/luci.git] / collections / luci-ssl-openssl / Makefile
1 #
2 # Copyright (C) 2016 The LuCI Team
3 #
4 # This is free software, licensed under the Apache License, Version 2.0 .
5 #
6
7 include $(TOPDIR)/rules.mk
8
9 LUCI_TYPE:=col
10 LUCI_BASENAME:=ssl-openssl
11
12 LUCI_TITLE:=LuCI with HTTPS support (OpenSSL as SSL backend)
13 LUCI_DESCRIPTION:=LuCI with OpenSSL as the SSL backend (libustream-openssl). \
14  Note: px5g still requires libmbedtls (in LEDE) or libpolarssl (in Openwrt). \
15  In LEDE it is also possible to replace px5g with openssl-util as uhttpd can \
16  also generate keys with openssl commandline tools if px5g is not installed.
17 LUCI_DEPENDS:=+luci +libustream-openssl +px5g
18
19 include ../../luci.mk
20
21 # call BuildPackage - OpenWrt buildroot signature