examples: fix linking with json-c
authorLuka Perkov <luka@openwrt.org>
Thu, 3 Jul 2014 10:28:22 +0000 (12:28 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 3 Jul 2014 10:53:13 +0000 (12:53 +0200)
Signed-off-by: Luka Perkov <luka@openwrt.org>
examples/CMakeLists.txt

index 51b97df..2126d29 100644 (file)
@@ -11,8 +11,10 @@ ENDIF()
 INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
 LINK_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
 
 INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
 LINK_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
 
+FIND_LIBRARY(json NAMES json-c json)
+
 ADD_EXECUTABLE(blobmsg-example blobmsg-example.c)
 ADD_EXECUTABLE(blobmsg-example blobmsg-example.c)
-TARGET_LINK_LIBRARIES(blobmsg-example ubox blobmsg_json json)
+TARGET_LINK_LIBRARIES(blobmsg-example ubox blobmsg_json  ${json})
 
 ADD_EXECUTABLE(ustream-example ustream-example.c)
 TARGET_LINK_LIBRARIES(ustream-example ubox)
 
 ADD_EXECUTABLE(ustream-example ustream-example.c)
 TARGET_LINK_LIBRARIES(ustream-example ubox)