add a json to blobmsg parsing library
authorFelix Fietkau <nbd@openwrt.org>
Sun, 6 Feb 2011 15:14:15 +0000 (16:14 +0100)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 6 Feb 2011 15:14:15 +0000 (16:14 +0100)
CMakeLists.txt
blobmsg_json.c [new file with mode: 0644]
blobmsg_json.h [new file with mode: 0644]

index f5ba86b..ae4ff17 100644 (file)
@@ -3,9 +3,17 @@ cmake_minimum_required(VERSION 2.8)
 PROJECT(ubox C)
 ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3)
 
 PROJECT(ubox C)
 ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3)
 
+IF(APPLE)
+  INCLUDE_DIRECTORIES(/opt/local/include)
+  LINK_DIRECTORIES(/opt/local/lib)
+ENDIF()
+
 SET(SOURCES avl.c blob.c blobmsg.c hash.c uhtbl.c uloop.c usock.c)
 
 ADD_LIBRARY(ubox SHARED ${SOURCES})
 SET(SOURCES avl.c blob.c blobmsg.c hash.c uhtbl.c uloop.c usock.c)
 
 ADD_LIBRARY(ubox SHARED ${SOURCES})
+ADD_LIBRARY(blobmsg_json SHARED blobmsg_json.c)
+
+TARGET_LINK_LIBRARIES(blobmsg_json ubox json)
 
 SET(CMAKE_INSTALL_PREFIX /usr)
 
 
 SET(CMAKE_INSTALL_PREFIX /usr)
 
@@ -13,6 +21,6 @@ FILE(GLOB headers *.h)
 INSTALL(FILES ${headers}
        DESTINATION include/libubox
 )
 INSTALL(FILES ${headers}
        DESTINATION include/libubox
 )
-INSTALL(TARGETS ubox
+INSTALL(TARGETS ubox blobmsg_json
        LIBRARY DESTINATION lib
 )
        LIBRARY DESTINATION lib
 )
diff --git a/blobmsg_json.c b/blobmsg_json.c
new file mode 100644 (file)
index 0000000..aad4d97
--- /dev/null
@@ -0,0 +1,77 @@
+#include "blobmsg.h"
+#include "blobmsg_json.h"
+
+static bool blobmsg_add_object(struct blob_buf *b, json_object *obj)
+{
+       json_object_object_foreach(obj, key, val) {
+               if (!blobmsg_add_json_element(b, key, val))
+                       return false;
+       }
+       return true;
+}
+
+static bool blobmsg_add_array(struct blob_buf *b, struct array_list *a)
+{
+       int i, len;
+
+       for (i = 0, len = array_list_length(a); i < len; i++) {
+               if (!blobmsg_add_json_element(b, NULL, array_list_get_idx(a, i)))
+                       return false;
+       }
+
+       return true;
+}
+
+bool blobmsg_add_json_element(struct blob_buf *b, const char *name, json_object *obj)
+{
+       bool ret = true;
+       void *c;
+
+       if (!obj)
+               return false;
+
+       switch (json_object_get_type(obj)) {
+       case json_type_object:
+               c = blobmsg_open_table(b, name);
+               ret = blobmsg_add_object(b, obj);
+               blobmsg_close_table(b, c);
+               break;
+       case json_type_array:
+               c = blobmsg_open_array(b, name);
+               ret = blobmsg_add_array(b, json_object_get_array(obj));
+               blobmsg_close_array(b, c);
+               break;
+       case json_type_string:
+               blobmsg_add_string(b, name, json_object_get_string(obj));
+               break;
+       case json_type_boolean:
+               blobmsg_add_u8(b, name, json_object_get_boolean(obj));
+               break;
+       case json_type_int:
+               blobmsg_add_u32(b, name, json_object_get_int(obj));
+               break;
+       default:
+               return false;
+       }
+       return ret;
+}
+
+bool blobmsg_add_json_from_string(struct blob_buf *b, const char *str)
+{
+       json_object *obj;
+       bool ret = false;
+
+       obj = json_tokener_parse(str);
+       if (is_error(obj))
+               return false;
+
+       if (json_object_get_type(obj) != json_type_object)
+               goto out;
+
+       ret = blobmsg_add_object(b, obj);
+
+out:
+       json_object_put(obj);
+       return ret;
+}
+
diff --git a/blobmsg_json.h b/blobmsg_json.h
new file mode 100644 (file)
index 0000000..9374f42
--- /dev/null
@@ -0,0 +1,12 @@
+#ifndef __BLOBMSG_JSON_H
+#define __BLOBMSG_JSON_H
+
+#include <json/json.h>
+#include <stdbool.h>
+
+struct blob_buf;
+
+bool blobmsg_add_json_element(struct blob_buf *b, const char *name, json_object *obj);
+bool blobmsg_add_json_from_string(struct blob_buf *b, const char *str);
+
+#endif