ubox: CMake: fix json-c detection
authorYegor Yefremov <yegorslists@googlemail.com>
Mon, 27 Apr 2015 20:13:42 +0000 (22:13 +0200)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 10 May 2015 12:14:45 +0000 (14:14 +0200)
Use PKG_SEARCH_MODULE() to detect json-c library,
otherwise the search fails, if both json-c and json
are not present in pkg-config database.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
CMakeLists.txt

index 3522fe4..38709ec 100644 (file)
@@ -8,7 +8,7 @@ ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
 OPTION(BUILD_LUA "build Lua plugin" ON)
 
 INCLUDE(FindPkgConfig)
-PKG_CHECK_MODULES(JSONC json-c)
+PKG_SEARCH_MODULE(JSONC json-c)
 IF(JSONC_FOUND)
   ADD_DEFINITIONS(-DJSONC)
   INCLUDE_DIRECTORIES(${JSONC_INCLUDE_DIRS})