examples: add example code for json_script.
[project/libubox.git] / examples / CMakeLists.txt
index 2126d29..6399c7a 100644 (file)
@@ -3,11 +3,6 @@ cmake_minimum_required(VERSION 2.6)
 PROJECT(ubox-examples C)
 ADD_DEFINITIONS(-O1 -Wall -Werror --std=gnu99 -g3)
 
-IF(APPLE)
-  INCLUDE_DIRECTORIES(/opt/local/include)
-  LINK_DIRECTORIES(/opt/local/lib)
-ENDIF()
-
 INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
 LINK_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/..)
 
@@ -22,3 +17,5 @@ TARGET_LINK_LIBRARIES(ustream-example ubox)
 ADD_EXECUTABLE(runqueue-example runqueue-example.c)
 TARGET_LINK_LIBRARIES(runqueue-example ubox)
 
+ADD_EXECUTABLE(json_script-example json_script-example.c)
+TARGET_LINK_LIBRARIES(json_script-example ubox blobmsg_json json_script ${json})