make usock generic
[project/libubox.git] / Makefile
index 104df19..5e7d038 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -9,9 +9,9 @@ LIBDIR=$(PREFIX)/lib
 CPPFLAGS=
 
 OS=$(shell uname)
-FILES=blob.c blobmsg.c hash.c uhtbl.c
+FILES=blob.c blobmsg.c hash.c uhtbl.c usock.c
 ifeq ($(OS),Linux)
-  FILES += usock.c uloop.c unl.c
+  FILES += uloop.c unl.c
   LIBS += $(LIBNL)
   LDFLAGS_SHARED=-shared -Wl,-soname,$@
   SHLIB_EXT=so