blobmsg: add blobmsg_realloc_string_buffer()
[project/libubox.git] / CMakeLists.txt
index ab82270..ba7ccaa 100644 (file)
@@ -1,4 +1,6 @@
 cmake_minimum_required(VERSION 2.6)
+INCLUDE(CheckLibraryExists)
+INCLUDE(CheckFunctionExists)
 
 PROJECT(ubox C)
 ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
@@ -14,7 +16,14 @@ SET(SOURCES avl.c avl-cmp.c blob.c blobmsg.c uloop.c usock.c ustream.c ustream-f
 
 ADD_LIBRARY(ubox SHARED ${SOURCES})
 
-SET(CMAKE_INSTALL_PREFIX /usr)
+SET(LIBS)
+CHECK_FUNCTION_EXISTS(clock_gettime HAVE_GETTIME)
+IF(NOT HAVE_GETTIME)
+       CHECK_LIBRARY_EXISTS(rt clock_gettime "" NEED_GETTIME)
+       IF(NEED_GETTIME)
+               TARGET_LINK_LIBRARIES(ubox rt)
+       ENDIF()
+ENDIF()
 
 FILE(GLOB headers *.h)
 INSTALL(FILES ${headers}
@@ -26,13 +35,13 @@ INSTALL(TARGETS ubox
 
 ADD_SUBDIRECTORY(lua)
 
-find_library(json json)
+find_library(json NAMES json-c json)
 IF(EXISTS ${json})
        ADD_LIBRARY(blobmsg_json SHARED blobmsg_json.c)
-       TARGET_LINK_LIBRARIES(blobmsg_json ubox json)
+       TARGET_LINK_LIBRARIES(blobmsg_json ubox ${json})
 
        ADD_EXECUTABLE(jshn jshn.c)
-       TARGET_LINK_LIBRARIES(jshn json)
+       TARGET_LINK_LIBRARIES(jshn ${json})
 
        INSTALL(TARGETS blobmsg_json jshn
                LIBRARY DESTINATION lib