uloop: use clock_gettime with the monotonic clock instead of using gettimeofday()
[project/libubox.git] / CMakeLists.txt
index ab82270..b756247 100644 (file)
@@ -1,4 +1,6 @@
 cmake_minimum_required(VERSION 2.6)
+INCLUDE(CheckLibraryExists)
+INCLUDE(CheckFunctionExists)
 
 PROJECT(ubox C)
 ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
@@ -14,6 +16,16 @@ SET(SOURCES avl.c avl-cmp.c blob.c blobmsg.c uloop.c usock.c ustream.c ustream-f
 
 ADD_LIBRARY(ubox SHARED ${SOURCES})
 
+SET(LIBS)
+CHECK_FUNCTION_EXISTS(clock_gettime HAVE_GETTIME)
+IF(NOT HAVE_GETTIME)
+       CHECK_LIBRARY_EXISTS(rt clock_gettime "" NEED_GETTIME)
+       IF(NEED_GETTIME)
+               TARGET_LINK_LIBRARIES(ubox rt)
+       ENDIF()
+ENDIF()
+
+
 SET(CMAKE_INSTALL_PREFIX /usr)
 
 FILE(GLOB headers *.h)