support building without json support
[project/libubox.git] / CMakeLists.txt
index 8ef71b2..9e8f093 100644 (file)
@@ -11,9 +11,6 @@ ENDIF()
 SET(SOURCES avl.c blob.c blobmsg.c uloop.c usock.c)
 
 ADD_LIBRARY(ubox SHARED ${SOURCES})
 SET(SOURCES avl.c blob.c blobmsg.c uloop.c usock.c)
 
 ADD_LIBRARY(ubox SHARED ${SOURCES})
-ADD_LIBRARY(blobmsg_json SHARED blobmsg_json.c)
-
-TARGET_LINK_LIBRARIES(blobmsg_json ubox json)
 
 SET(CMAKE_INSTALL_PREFIX /usr)
 
 
 SET(CMAKE_INSTALL_PREFIX /usr)
 
@@ -21,6 +18,15 @@ FILE(GLOB headers *.h)
 INSTALL(FILES ${headers}
        DESTINATION include/libubox
 )
 INSTALL(FILES ${headers}
        DESTINATION include/libubox
 )
-INSTALL(TARGETS ubox blobmsg_json
+INSTALL(TARGETS ubox
        LIBRARY DESTINATION lib
 )
        LIBRARY DESTINATION lib
 )
+
+find_library(json json)
+IF(EXISTS ${json})
+       ADD_LIBRARY(blobmsg_json SHARED blobmsg_json.c)
+       TARGET_LINK_LIBRARIES(blobmsg_json ubox json)
+       INSTALL(TARGETS blobmsg_json
+               LIBRARY DESTINATION lib
+       )
+ENDIF()