uloop: allow passing 0 as timeout to uloop_run
[project/libubox.git] / CMakeLists.txt
index 737f2ae..57804cf 100644 (file)
@@ -6,20 +6,16 @@ PROJECT(ubox C)
 ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -g3 -Wmissing-declarations)
 
 OPTION(BUILD_LUA "build Lua plugin" ON)
-
-IF(APPLE)
-  INCLUDE_DIRECTORIES(/opt/local/include)
-  LINK_DIRECTORIES(/opt/local/lib)
-ENDIF()
+OPTION(BUILD_EXAMPLES "build examples" ON)
 
 INCLUDE(FindPkgConfig)
-PKG_CHECK_MODULES(JSONC json-c)
+PKG_SEARCH_MODULE(JSONC json-c)
 IF(JSONC_FOUND)
   ADD_DEFINITIONS(-DJSONC)
   INCLUDE_DIRECTORIES(${JSONC_INCLUDE_DIRS})
 ENDIF()
 
-SET(SOURCES avl.c avl-cmp.c blob.c blobmsg.c uloop.c usock.c ustream.c ustream-fd.c vlist.c utils.c safe_list.c runqueue.c md5.c kvlist.c)
+SET(SOURCES avl.c avl-cmp.c blob.c blobmsg.c uloop.c usock.c ustream.c ustream-fd.c vlist.c utils.c safe_list.c runqueue.c md5.c kvlist.c ulog.c base64.c)
 
 ADD_LIBRARY(ubox SHARED ${SOURCES})
 ADD_LIBRARY(ubox-static STATIC ${SOURCES})
@@ -44,19 +40,25 @@ INSTALL(TARGETS ubox ubox-static
 )
 
 ADD_SUBDIRECTORY(lua)
+ADD_SUBDIRECTORY(examples)
 
 find_library(json NAMES json-c)
 IF(EXISTS ${json})
        ADD_LIBRARY(blobmsg_json SHARED blobmsg_json.c)
        TARGET_LINK_LIBRARIES(blobmsg_json ubox ${json})
 
+       ADD_LIBRARY(blobmsg_json-static STATIC blobmsg_json.c)
+       SET_TARGET_PROPERTIES(blobmsg_json-static
+                             PROPERTIES OUTPUT_NAME blobmsg_json)
+
        ADD_EXECUTABLE(jshn jshn.c)
        TARGET_LINK_LIBRARIES(jshn blobmsg_json ${json})
 
        ADD_LIBRARY(json_script SHARED json_script.c)
        TARGET_LINK_LIBRARIES(json_script ubox)
 
-       INSTALL(TARGETS blobmsg_json jshn json_script
+       INSTALL(TARGETS blobmsg_json blobmsg_json-static jshn json_script
+               ARCHIVE DESTINATION lib
                LIBRARY DESTINATION lib
                RUNTIME DESTINATION bin
        )