implement POSIX regexp support
[project/jsonpath.git] / CMakeLists.txt
index 0301db5..7361eb2 100644 (file)
@@ -3,11 +3,8 @@ cmake_minimum_required(VERSION 2.6)
 PROJECT(jsonpath C)
 ADD_DEFINITIONS(-Os -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-error=unused-variable -ffunction-sections -D_GNU_SOURCE)
 
-SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "-Wl,--gc-sections")
-
-IF(APPLE)
-  INCLUDE_DIRECTORIES(/opt/local/include)
-  LINK_DIRECTORIES(/opt/local/lib)
+IF(NOT APPLE)
+  SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "-Wl,--gc-sections")
 ENDIF()
 
 find_library(json NAMES json-c json)