build: disable the format-truncation warning error to fix gcc 7 build errors
authorFelix Fietkau <nbd@nbd.name>
Thu, 4 May 2017 14:13:34 +0000 (16:13 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 30 Jun 2017 15:25:24 +0000 (17:25 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
CMakeLists.txt

index e7a97db..14b6e0a 100644 (file)
@@ -1,7 +1,7 @@
 cmake_minimum_required(VERSION 2.6)
 
 PROJECT(fs-tools C)
-ADD_DEFINITIONS(-Os -ggdb -Wall -Werror --std=gnu99 -Wmissing-declarations)
+ADD_DEFINITIONS(-Os -ggdb -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-error=format-truncation)
 
 SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")