build: disable the format-truncation warning error to fix gcc 7 build errors
[project/fstools.git] / CMakeLists.txt
index a828244..04d9470 100644 (file)
@@ -1,7 +1,7 @@
 cmake_minimum_required(VERSION 2.6)
 
 PROJECT(fs-tools C)
 cmake_minimum_required(VERSION 2.6)
 
 PROJECT(fs-tools C)
-ADD_DEFINITIONS(-Os -ggdb -Wall -Werror --std=gnu99 -Wmissing-declarations)
+ADD_DEFINITIONS(-Os -ggdb -Wall -Werror --std=gnu99 -Wmissing-declarations -Wno-error=format-truncation)
 
 SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
 
 
 SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")