[package] shell-fm: add libao support
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Apr 2012 16:20:00 +0000 (16:20 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Apr 2012 16:20:00 +0000 (16:20 +0000)
- remove madplay dependency
- enable libao support (we already depend on it)
- disable external command in default configuration
- add symlink for .libao
   To configure libao, the library looks for a .libao configuration file in
   the users home directory.
   To allow configuring libao for shell-fm running as a daemon, we symlink
   /etc/libao.conf to the temporary HOME for shell-fm.

[florian: added missing libmad dependency]

Signed-off-by: Christoph Gysin <christoph.gysin@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@31162 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/shell-fm/Makefile
sound/shell-fm/files/shell-fm.init
sound/shell-fm/files/shell-fm.rc

index 8fea1a1..2c08ca4 100644 (file)
@@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/shell-fm
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libao +madplay +libpthread
+  DEPENDS:=+libao +libpthread +libmad
   TITLE:=Console Based Last.FM Radio Player
   URL:=http://nex.scrapping.cc
 endef
@@ -43,7 +43,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -I./include/ $(TARGET_CPPFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) -I./include/ -DLIBAO $(TARGET_CPPFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                LDFLAGS="$(TARGET_LDFLAGS) -lmad -lao -lpthread" \
                all install
index 0e68d34..f0403b6 100644 (file)
@@ -5,6 +5,7 @@ START=99
 start() {
        [ -d /tmp/.shell-fm ] || mkdir /tmp/.shell-fm
        [ -L /tmp/.shell-fm/shell-fm.rc ] || ln -s /etc/shell-fm.rc /tmp/.shell-fm/shell-fm.rc
+       [ -L /tmp/.libao ] || ln -s /etc/libao.conf /tmp/.libao
        HOME=/tmp shell-fm -d
 }
 
index 43ec7d2..b3f6a2d 100644 (file)
@@ -6,4 +6,4 @@ t-color = 1;32          # light green track titles
 a-color = 0;32          # dark green track artist names
 s-color = 1;37          # white station names
 bind = 0.0.0.0
-extern = madplay -q -
+#extern = madplay -q -