gpsd: moved to github
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Nov 2015 21:08:29 +0000 (21:08 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Nov 2015 21:08:29 +0000 (21:08 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@47530 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/gpsd/Makefile [deleted file]
net/gpsd/files/gpsd.config [deleted file]
net/gpsd/files/gpsd.hotplug [deleted file]
net/gpsd/files/gpsd.init [deleted file]

diff --git a/net/gpsd/Makefile b/net/gpsd/Makefile
deleted file mode 100644 (file)
index 9195b25..0000000
+++ /dev/null
@@ -1,159 +0,0 @@
-#
-# Copyright (C) 2006-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=gpsd
-PKG_VERSION:=3.10
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://download-mirror.savannah.gnu.org/releases/gpsd/
-PKG_MD5SUM:=fc5b03aae38b9b5b6880b31924d0ace3
-
-PKG_BUILD_DEPENDS:=libncurses libusb-1.0
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/scons.mk
-
-define Package/gpsd/Default
-  DEPENDS:=+librt
-  URL:=http://catb.org/gpsd/
-endef
-
-define Package/gpsd/Default/description
-  gpsd is a userland daemon acting as a translator between GPS and AIS receivers
-  and their clients. gpsd listens on port 2947 for clients requesting
-  position/time/velocity information.  The receivers are expected to generate
-  position information in a well-known format -- as NMEA-0183 sentences, SiRF
-  binary, Rockwell binary, Garmin binary format, or other vendor binary
-  protocols.  gpsd takes this information from the GPS and translates it into
-  something uniform and easier to understand for clients.
-endef
-
-define Package/gpsd
-  $(call Package/gpsd/Default)
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS+= +libgps +libgpsd
-  TITLE:=An interface daemon for GPS receivers
-endef
-
-define Package/gpsd/conffiles
-/etc/config/gpsd
-endef
-
-define Package/gpsd/description
-  $(call Package/gpsd/Default/description)
-  This package contains the GPS daemon.
-endef
-
-define Package/gpsd-clients
-  $(call Package/gpsd/Default)
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS+= +libgps +libgpsd +libncurses
-  TITLE:=GPS tools and clients
-endef
-
-define Package/gpsd-clients/description
-  $(call Package/gpsd/Default/description)
-  This package contains auxiliary tools and example clients for monitoring and
-  testing the GPS daemon.
-endef
-
-define Package/libgps
-  $(call Package/gpsd/Default)
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS+= +libcap
-  TITLE:=C service library for communicating with the GPS daemon
-endef
-
-define Package/libgps/description
-  $(call Package/gpsd/Default/description)
-  This package contains the libgps library.
-endef
-
-define Package/libgpsd
-  $(call Package/gpsd/Default)
-  SECTION:=libs
-  CATEGORY:=Libraries
-  DEPENDS+= +libcap +libusb-1.0
-  TITLE:=C service library for GPS applications
-endef
-
-define Package/libgpsd/description
-  $(call Package/gpsd/Default/description)
-  This package contains the libgpsd library.
-endef
-
-SCONS_OPTIONS += \
-       dbus_export=no \
-       tsip=no \
-       fv18=no \
-       tripmate=no \
-       earthmate=no \
-       itrax=no \
-       navcom=no \
-       ubx=no \
-       evermore=no \
-       ntrip=no \
-       libgpsmm=no \
-       libQgpsmm=no \
-       bluez=no \
-       strip=no \
-       python=no \
-       implicit_link=no \
-       chrpath=no
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/gps.h $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgps*.so* $(1)/usr/lib/
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libgps*.pc \
-               $(1)/usr/lib/pkgconfig/
-endef
-
-define Package/gpsd/install
-       $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_CONF) ./files/gpsd.config $(1)/etc/config/gpsd
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/gpsd.init $(1)/etc/init.d/gpsd
-       $(INSTALL_DIR) $(1)/etc/hotplug.d/usb
-       $(INSTALL_DATA) ./files/gpsd.hotplug $(1)/etc/hotplug.d/usb/20-gpsd
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/gpsd $(1)/usr/sbin/
-endef
-
-define Package/gpsd-clients/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) \
-               $(PKG_INSTALL_DIR)/usr/bin/cgps \
-               $(PKG_INSTALL_DIR)/usr/bin/gps{ctl,decode,mon,pipe} \
-               $(PKG_INSTALL_DIR)/usr/bin/gpxlogger \
-               $(PKG_INSTALL_DIR)/usr/bin/lcdgps \
-               $(1)/usr/bin/
-endef
-
-define Package/libgps/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgps.so.* $(1)/usr/lib/
-endef
-
-define Package/libgpsd/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgpsd.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,gpsd))
-$(eval $(call BuildPackage,gpsd-clients))
-$(eval $(call BuildPackage,libgps))
-$(eval $(call BuildPackage,libgpsd))
diff --git a/net/gpsd/files/gpsd.config b/net/gpsd/files/gpsd.config
deleted file mode 100644 (file)
index ef19202..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-config gpsd core
-    option device    "/dev/ttyUSB0"
-    option port    "2947"
-    option listen_globally    "false"
-    option enabled    "true"
diff --git a/net/gpsd/files/gpsd.hotplug b/net/gpsd/files/gpsd.hotplug
deleted file mode 100644 (file)
index fc15dda..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-case "$ACTION" in
-    add)
-        # start process
-        # only pl2303 devices are handled
-        if [ "$PRODUCT" = "67b/2303/300" ] && [ "$TYPE" = "0/0/0" ] && [ "$INTERFACE" = "255/0/0" ]; then
-            sleep 3 && /etc/init.d/gpsd start
-        fi
-        ;;
-    remove)
-        # stop process
-        # only pl2303 devices are handled
-        if [ "$PRODUCT" = "67b/2303/300" ] && [ "$TYPE" = "0/0/0" ] && [ "$INTERFACE" = "255/0/0" ]; then
-            /etc/init.d/gpsd stop
-        fi
-        ;;
-esac
diff --git a/net/gpsd/files/gpsd.init b/net/gpsd/files/gpsd.init
deleted file mode 100644 (file)
index 96cee78..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2009-2011 OpenWrt.org
-START=50
-
-NAME=gpsd
-PIDF=/var/run/$NAME.pid
-PROG=/usr/sbin/$NAME
-
-start() {
-    config_load gpsd
-    config_get device core device
-    config_get port core port
-    config_get_bool listen_globally core listen_globally
-    config_get_bool enabled core enabled
-    [ "$enabled" != "1" ] && exit
-    logger -t "$NAME" "Starting..."
-    [ ! -c "$device" ] && {
-        logger -t "$NAME" "Unable to find device $device. Exiting."
-        exit 1
-    }
-    [ "$listen_globally" != "0" ] && append args "-G"
-    $PROG -n -P $PIDF -S $port $args $device
-}
-
-stop() {
-    logger -t "$NAME" "Stopping..."
-    [ -f "$PIDF" ] && {
-        read PID < "$PIDF"
-        kill -9 $PID
-        rm $PIDF
-    }
-}