grep: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Jul 2014 10:51:04 +0000 (10:51 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Jul 2014 10:51:04 +0000 (10:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41600 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/grep/Makefile [deleted file]

diff --git a/utils/grep/Makefile b/utils/grep/Makefile
deleted file mode 100644 (file)
index 6e648e0..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-#
-# Copyright (C) 2010-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=grep
-PKG_VERSION:=2.14
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=@GNU/grep
-PKG_MD5SUM:=d4a3f03849d1e17ce56ab76aa5a24cab
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/grep
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=grep search utility - full version
-  DEPENDS:=+libpcre
-  URL:=http://www.gnu.org/software/grep/
-endef
-
-define Package/grep/description
-The grep command searches one or more input files for lines
-containing a match to a specified pattern. By default, grep
-prints the matching lines.
-endef
-
-define Package/grep/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/grep $(1)/usr/bin/grep
-endef
-
-define Package/grep/postinst
-#!/bin/sh
-[ -L "$${IPKG_INSTROOT}/bin/grep" ] && rm -f "$${IPKG_INSTROOT}/bin/grep"
-exit 0
-endef
-
-define Package/grep/prerm
-$${IPKG_INSTROOT}/bin/busybox grep -h 2>&1 | grep -q BusyBox && \
-ln -sf busybox $${IPKG_INSTROOT}/bin/grep
-exit 0
-endef
-
-$(eval $(call BuildPackage,grep))