pcsc-lite: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Jun 2014 15:11:09 +0000 (15:11 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Jun 2014 15:11:09 +0000 (15:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41210 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/pcsc-lite/Makefile [deleted file]
utils/pcsc-lite/files/pcscd.init [deleted file]

diff --git a/utils/pcsc-lite/Makefile b/utils/pcsc-lite/Makefile
deleted file mode 100644 (file)
index db3eeec..0000000
+++ /dev/null
@@ -1,98 +0,0 @@
-#
-# Copyright (C) 2009-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=pcsc-lite
-PKG_VERSION:=1.8.2
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://alioth.debian.org/frs/download.php/3695
-PKG_MD5SUM:=cb7156346e9478c19085c918b605ed43
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/pcsc-lite/Default
-  TITLE:=Middleware to access a smart card using SCard API (PC/SC).
-  URL:=http://pcsclite.alioth.debian.org/
-endef
-
-define Package/pcsc-lite/Default/description
-  The purpose of PC/SC Lite is to provide a Windows(R) SCard
-  interface in a very small form factor for communicating to
-  smart cards and smart cards readers.
-endef
-
-define Package/libpcsclite
-  $(call Package/pcsc-lite/Default)
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE+= (library)
-  DEPENDS:=+libusb-1.0 +libpthread +librt
-endef
-
-define Package/libpcsclite/description
-  $(call Package/pcsc-lite/Default/description)
-  .
-  This package contains the PC/SC shared library.
-endef
-
-define Package/pcscd
-  $(call Package/pcsc-lite/Default)
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE+= (daemon)
-  DEPENDS:=+libpcsclite
-endef
-
-define Package/pcscd/description
-  $(call Package/pcsc-lite/Default/description)
-  .
-  This package contains the PC/SC daemon.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-TARGET_LDFLAGS += -lpthread
-
-CONFIGURE_ARGS += \
-       --disable-libudev \
-       --enable-libusb \
-       --enable-static \
-       --enable-usbdropdir=/usr/lib/pcsc/drivers
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/PCSC
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/PCSC/* $(1)/usr/include/PCSC/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcsclite.{a,so*} $(1)/usr/lib/
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libpcsclite.pc $(1)/usr/lib/pkgconfig/
-endef
-
-define Package/libpcsclite/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcsclite.so.* $(1)/usr/lib/
-endef
-
-define Package/pcscd/conffiles
-/etc/reader.conf.d/reader.conf
-endef
-
-define Package/pcscd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pcscd $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/pcscd.init $(1)/etc/init.d/pcscd
-       $(INSTALL_DIR) $(1)/etc/reader.conf.d
-endef
-
-$(eval $(call BuildPackage,libpcsclite))
-$(eval $(call BuildPackage,pcscd))
diff --git a/utils/pcsc-lite/files/pcscd.init b/utils/pcsc-lite/files/pcscd.init
deleted file mode 100644 (file)
index 9a7a905..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2009-2011 OpenWrt.org
-
-START=50
-
-SERVICE_PID_FILE=/var/run/pcscd/pcscd.pid
-
-start() {
-       service_start /usr/sbin/pcscd
-}
-
-stop() {
-       service_stop /usr/sbin/pcscd
-}