dovecot: explicitely disable lzma and lz4 support
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 11 Mar 2014 19:46:14 +0000 (19:46 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 11 Mar 2014 19:46:14 +0000 (19:46 +0000)
Avoid linking with liblzma and liblz4 for now.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39881 3c298f89-4303-0410-b956-a3cf2f4a3e73

mail/dovecot/Makefile

index fd6447c..4a1a991 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dovecot
 PKG_VERSION:=2.2.12
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.dovecot.org/releases/2.2
@@ -39,7 +39,9 @@ CONFIGURE_ARGS += \
        --without-gssapi \
        --without-pam \
        --with-moduledir=/usr/lib/dovecot/modules \
-       --with-notify=dnotify
+       --with-notify=dnotify \
+       --without-lzma \
+       --without-lz4
 
 CONFIGURE_VARS += \
        RPCGEN= \