libupnp: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Jul 2014 08:36:34 +0000 (08:36 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Jul 2014 08:36:34 +0000 (08:36 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41712 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libupnp/Makefile [deleted file]

diff --git a/libs/libupnp/Makefile b/libs/libupnp/Makefile
deleted file mode 100644 (file)
index f76f520..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-#
-# Copyright (C) 2006-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libupnp
-PKG_VERSION:=1.6.18
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/pupnp
-PKG_MD5SUM:=11c6484fd2e2927bf3b8d8108407ca56
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libupnp/Default
-  SECTION:=libs
-  CATEGORY:=Libraries
-  URL:=http://pupnp.sourceforge.net/
-endef
-
-define Package/libupnp
-  $(call Package/libupnp/Default)
-  DEPENDS:=+libpthread
-  TITLE:=UPnP SDK library
-  MENU:=1
-endef
-
-define Package/libupnp/description
-The portable SDK for UPnP Devices (libupnp) provides developers with an API and
-open source code for building control points, devices, and bridges that are
-compliant with Version 1.0 of the  Universal Plug and Play Device Architecture
-Specification.
-endef
-
-define Package/libupnp-sample
-  $(call Package/libupnp/Default)
-  DEPENDS:=libupnp
-  TITLE:=UPnP sample applications
-endef
-
-define Package/libupnp-sample/description
-TVcontrolpoint & tvdevice sample applications run inside /etc/upnp-tvdevice/
-endef
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/upnp $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ixml,threadutil,upnp}.{a,so*,la} $(1)/usr/lib/
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libupnp.pc $(1)/usr/lib/pkgconfig/
-endef
-
-define Package/libupnp/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ixml,threadutil,upnp}.so.* $(1)/usr/lib/
-endef
-
-define Package/libupnp-sample/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/upnp/sample/.libs/* $(1)/usr/bin
-       $(INSTALL_DIR) $(1)/etc/upnp-tvdevice/web
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/upnp/sample/web/* $(1)/etc/upnp-tvdevice
-endef
-
-$(eval $(call BuildPackage,libupnp))
-$(eval $(call BuildPackage,libupnp-sample))