[packages] htop: fix undefined references to rpl_malloc, rpl_realloc (#8997)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Mar 2011 18:12:40 +0000 (18:12 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Mar 2011 18:12:40 +0000 (18:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25941 3c298f89-4303-0410-b956-a3cf2f4a3e73

admin/htop/Makefile

index 15265c7..9a33d11 100644 (file)
@@ -20,10 +20,6 @@ PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-CONFIGURE_VARS += \
-       ac_cv_file__proc_stat=yes \
-       ac_cv_file__proc_meminfo=yes
-
 define Package/htop
   SECTION:=admin
   CATEGORY:=Administration
@@ -41,6 +37,8 @@ endef
 CONFIGURE_VARS += \
        ac_cv_file__proc_stat=yes \
        ac_cv_file__proc_meminfo=yes \
+       ac_cv_func_malloc_0_nonnull=yes \
+       ac_cv_func_realloc_0_nonnull=yes
 
 define Package/htop/install
        $(INSTALL_DIR) $(1)/usr/bin