nagios-plugins: Fix check_procs command
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 May 2014 18:16:09 +0000 (18:16 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 May 2014 18:16:09 +0000 (18:16 +0000)
Fix check_procs: ps command line parameters were misconfigured

Signed-off-by: Bernd Krumböck <krumboeck@universalnet.at>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@40637 3c298f89-4303-0410-b956-a3cf2f4a3e73

admin/nagios-plugins/Makefile

index 6bb7a23..d5fa97e 100644 (file)
@@ -36,10 +36,10 @@ CONFIGURE_ARGS += \
        --with-openssl="$(STAGING_DIR)/usr" \
        --with-ping-command="/bin/ping -w %d -c %d %s" \
        --with-ping6-command="/bin/ping6 -w %d -c %d %s" \
-       --with-ps-command="/bin/ps -Aopid" \
+       --with-ps-command="/bin/ps w" \
        --with-ps-cols="6" \
        --with-ps-format="%d %s %d %s %s %n" \
-       --with-ps-varlist="&procuid$(comma)&procpid$(comma)&procvsz$(comma)procstat$(comma)procprog$(comma)&pos" \
+       --with-ps-varlist="&procpid$(comma)&procuid$(comma)&procvsz$(comma)procstat$(comma)procprog$(comma)&pos" \
        --with-uptime-command="/usr/bin/uptime" \
        --with-ssh-command="/usr/bin/ssh" \
        --with-nslookup-command="/usr/bin/nslookup"