[package] add git (#6023)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Nov 2009 23:39:30 +0000 (23:39 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Nov 2009 23:39:30 +0000 (23:39 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18555 3c298f89-4303-0410-b956-a3cf2f4a3e73

devel/git/Makefile [new file with mode: 0644]

diff --git a/devel/git/Makefile b/devel/git/Makefile
new file mode 100644 (file)
index 0000000..2882f52
--- /dev/null
@@ -0,0 +1,80 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# Alessandro Di Marco <dmr-wrt@ethzero.com>
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=git
+PKG_VERSION:=1.6.5
+PKG_RELEASE:=1
+
+PKG_SOURCE:=${PKG_NAME}-${PKG_VERSION}.tar.gz
+PKG_SOURCE_URL:=http://git-scm.com
+PKG_MD5SUM:=91bddd06604c6f9a37c3b38f99db47d5
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/git
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libopenssl +zlib +dropbear
+  TITLE:=The fast version control system
+  URL:=http://git-scm.com
+endef
+
+define Package/git/description
+ Git is a free & open source, distributed version control system 
+ designed to handle everything from small to very large projects 
+ with speed and efficiency.
+endef
+
+define Build/Configure
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               configure
+
+       (cd $(PKG_BUILD_DIR); \
+               ./configure \
+                       --prefix=/usr \
+       );
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               LD="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               NO_PERL="YesPlease" \
+               NO_EXPAT="YesPlease" \
+               NO_WISH="YesPlease" \
+               NO_ICONV="YesPlease" \
+               NO_NSEC="YesPlease" \
+               NO_CURL="YesPlease" \
+               NO_TCLTK="YesPlease" \
+               all
+endef
+
+define Package/git/install
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(1)" \
+               CC="$(TARGET_CC)" \
+               LD="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               NO_PERL="YesPlease" \
+               NO_EXPAT="YesPlease" \
+               NO_WISH="YesPlease" \
+               NO_ICONV="YesPlease" \
+               NO_NSEC="YesPlease" \
+               NO_CURL="YesPlease" \
+               NO_TCLTK="YesPlease" \
+               install
+endef
+
+$(eval $(call BuildPackage,git))