[package] perl-test-harness: Add new package perl-test-harness
authorhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 17 Oct 2012 16:28:40 +0000 (16:28 +0000)
committerhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 17 Oct 2012 16:28:40 +0000 (16:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@33813 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/perl-test-harness/Makefile [new file with mode: 0644]

diff --git a/lang/perl-test-harness/Makefile b/lang/perl-test-harness/Makefile
new file mode 100644 (file)
index 0000000..bddb89c
--- /dev/null
@@ -0,0 +1,39 @@
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=perl-test-harness
+PKG_VERSION:=3.25
+PKG_RELEASE:=1
+PKG_MD5SUM:=69a8a019eeb952fe97e3ac0767c726da
+
+PKG_SOURCE_URL:=http://search.cpan.org/CPAN/authors/id/O/OV/OVID
+PKG_SOURCE:=Test-Harness-$(PKG_VERSION).tar.gz
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Test-Harness-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include ../perl/perlmod.mk
+
+define Package/perl-test-harness
+SUBMENU:=Perl
+SECTION:=lang
+CATEGORY:=Languages
+TITLE:=Perl Test Harness
+URL:=http://search.cpan.org/~ovid/Test-Harness-3.25/bin/prove
+DEPENDS:=+perl
+endef
+
+define Build/Configure
+       $(call perlmod/Configure,,)
+endef
+
+define Build/Compile
+       $(call perlmod/Compile,,)
+endef
+
+define Package/perl-test-harness/install
+       $(call perlmod/Install,$(1),App auto/Test TAP Test)
+endef
+
+
+$(eval $(call BuildPackage,perl-test-harness))